aboutsummaryrefslogtreecommitdiff
path: root/games/qudos
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-07-29 19:59:36 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-07-29 19:59:36 +0000
commitcba93ee80a9c660bc483e5f574485f0b10efb3b1 (patch)
tree78e2d9f574492ceb7bd3ac42cea20a611b694246 /games/qudos
parenta7ed23ba92f8f40e14f1ccb2c974cd028e3bf999 (diff)
downloadports-cba93ee80a9c660bc483e5f574485f0b10efb3b1.tar.gz
ports-cba93ee80a9c660bc483e5f574485f0b10efb3b1.zip
- Bump PORTREVISION.
- Add a GAME option (disabled by default, because original game.so is provided by "games/quake2-data"). - Follow rules in "games/quake2-data/Makefile.include": fix search path handling.
Notes
Notes: svn path=/head/; revision=169077
Diffstat (limited to 'games/qudos')
-rw-r--r--games/qudos/Makefile2
-rw-r--r--games/qudos/files/patch-src__qcommon__files.c34
2 files changed, 36 insertions, 0 deletions
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index 1330ddbf1256..82a2786b13a1 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qudos
PORTVERSION= 0.40.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/QuDos/
DISTNAME= QuDos-${PORTVERSION}-src
@@ -28,6 +29,7 @@ OPTIONS= 3ZB2 "Build 3zb2 modification (bots)" on \
CLIENT "Build client" on \
CTF "Build CTF (Capture The Flag) modification" off \
DEDICATED "Build dedicated server" on \
+ GAME "Build a main game .so modification" off \
GAME_MOD "Enable custom addons in main modification" on \
GLX "Build OpenGL renderer" on \
IPV6 "Enable IPv6 support" off \
diff --git a/games/qudos/files/patch-src__qcommon__files.c b/games/qudos/files/patch-src__qcommon__files.c
new file mode 100644
index 000000000000..7cc749e0ebc5
--- /dev/null
+++ b/games/qudos/files/patch-src__qcommon__files.c
@@ -0,0 +1,34 @@
+--- src/qcommon/files.c.orig Fri Jun 2 12:50:53 2006
++++ src/qcommon/files.c Thu Jul 27 17:11:03 2006
+@@ -1377,6 +1377,9 @@
+ Cvar_FullSet("gamedir", dir, CVAR_SERVERINFO | CVAR_NOSET);
+ if (fs_cddir->string[0] == '\0')
+ FS_AddGameDirectory(va("%s/%s", fs_cddir->string, dir));
++#ifdef DATADIR
++ FS_AddGameDirectory(va("%s/%s", DATADIR, dir));
++#endif
+ #ifdef LIBDIR
+ FS_AddGameDirectory(va("%s/%s", LIBDIR, dir));
+ #endif
+@@ -1707,11 +1710,7 @@
+ /*
+ * basedir <path> Allows the game to run from outside the data tree.
+ */
+-#ifdef DATADIR
+- fs_basedir = Cvar_Get("basedir", DATADIR, CVAR_NOSET);
+-#else
+ fs_basedir = Cvar_Get("basedir", ".", CVAR_NOSET);
+-#endif
+
+ /*
+ * cddir <path> Logically concatenates the cddir after the basedir to
+@@ -1731,6 +1730,9 @@
+ fs_homepath = Cvar_Get("homepath", Sys_GetCurrentDirectory(), CVAR_NOSET);
+
+ /* Add baseq2 to search path. */
++#ifdef DATADIR
++ FS_AddGameDirectory(va("%s/" BASEDIRNAME, DATADIR));
++#endif
+ #ifdef LIBDIR
+ FS_AddGameDirectory(va("%s/" BASEDIRNAME, LIBDIR));
+ #endif