aboutsummaryrefslogtreecommitdiff
path: root/games/qudos
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-30 13:26:28 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-30 13:26:28 +0000
commite5db50f06bfde553b9c4cb7493bbc9825a8c419f (patch)
tree1f810f6eb1d6e2a4ee23ca0555c30d11f3937e68 /games/qudos
parent3e113f7e6b08a82830599d61982222a7f19d82ac (diff)
downloadports-e5db50f06bfde553b9c4cb7493bbc9825a8c419f.tar.gz
ports-e5db50f06bfde553b9c4cb7493bbc9825a8c419f.zip
- Avoid creating a "baseq2" subdirectory in the current directory.
- Use GCC 3.4+ instead of 3.2+ (because it is supported in more platforms). - Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=181047
Diffstat (limited to 'games/qudos')
-rw-r--r--games/qudos/Makefile6
-rw-r--r--games/qudos/files/patch-src__qcommon__files.c26
2 files changed, 25 insertions, 7 deletions
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index f4ca750aa6c2..345f65ae5575 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qudos
PORTVERSION= 0.40.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/QuDos/
DISTNAME= QuDos-${PORTVERSION}-src
@@ -19,7 +19,7 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Enhaced OpenGL only Quake II engine
USE_BZIP2= yes
-USE_GCC= 3.2+
+USE_GCC= 3.4+
USE_GL= yes
USE_GMAKE= yes
@@ -46,7 +46,7 @@ OPTIONS= 3ZB2 "Build 3zb2 modification (bots)" on \
XATRIX "Build The Reckoning (Xatrix) mission pack" off \
ZAERO "Build Zaero modification" off
-MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES WITH_XMMS=NO\
+MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES WITH_XMMS=NO \
DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}" VER="${PORTVERSION}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
diff --git a/games/qudos/files/patch-src__qcommon__files.c b/games/qudos/files/patch-src__qcommon__files.c
index 7cc749e0ebc5..926adbd8401f 100644
--- a/games/qudos/files/patch-src__qcommon__files.c
+++ b/games/qudos/files/patch-src__qcommon__files.c
@@ -1,6 +1,16 @@
--- src/qcommon/files.c.orig Fri Jun 2 12:50:53 2006
-+++ src/qcommon/files.c Thu Jul 27 17:11:03 2006
-@@ -1377,6 +1377,9 @@
++++ src/qcommon/files.c Sat Dec 30 10:12:59 2006
+@@ -1099,9 +1099,6 @@
+ /* Set game directory. */
+ Q_strncpyz(fs_gamedir, dir, sizeof(fs_gamedir));
+
+- /* Create directory if it does not exist. */
+- Sys_Mkdir(fs_gamedir);
+-
+ /* Add the directory to the search path. */
+ search = Z_Malloc(sizeof(fsSearchPath_t));
+ Q_strncpyz(search->path, dir, sizeof(search->path));
+@@ -1377,6 +1374,9 @@
Cvar_FullSet("gamedir", dir, CVAR_SERVERINFO | CVAR_NOSET);
if (fs_cddir->string[0] == '\0')
FS_AddGameDirectory(va("%s/%s", fs_cddir->string, dir));
@@ -10,7 +20,7 @@
#ifdef LIBDIR
FS_AddGameDirectory(va("%s/%s", LIBDIR, dir));
#endif
-@@ -1707,11 +1710,7 @@
+@@ -1707,11 +1707,7 @@
/*
* basedir <path> Allows the game to run from outside the data tree.
*/
@@ -22,7 +32,7 @@
/*
* cddir <path> Logically concatenates the cddir after the basedir to
-@@ -1731,6 +1730,9 @@
+@@ -1731,6 +1727,9 @@
fs_homepath = Cvar_Get("homepath", Sys_GetCurrentDirectory(), CVAR_NOSET);
/* Add baseq2 to search path. */
@@ -32,3 +42,11 @@
#ifdef LIBDIR
FS_AddGameDirectory(va("%s/" BASEDIRNAME, LIBDIR));
#endif
+@@ -1748,6 +1747,7 @@
+ FS_SetGamedir(fs_gamedirvar->string);
+
+ /* Create directory if it does not exist. */
++ FS_CreatePath(fs_gamedir);
+ Sys_Mkdir(fs_gamedir);
+
+ Com_Printf("Using '%s' for writing.\n", fs_gamedir);