aboutsummaryrefslogtreecommitdiff
path: root/games/redeclipse/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-02 14:48:10 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-02 14:48:10 +0000
commitf062eb801f1a8e54090c6b623d2b79068d43ecc9 (patch)
tree20e39d56198f008aad085f86c628b66d3210c0eb /games/redeclipse/Makefile
parent1a5ecb5fcd4e6430221931305b3bf79bc56a53cb (diff)
downloadports-f062eb801f1a8e54090c6b623d2b79068d43ecc9.tar.gz
ports-f062eb801f1a8e54090c6b623d2b79068d43ecc9.zip
Notes
Diffstat (limited to 'games/redeclipse/Makefile')
-rw-r--r--games/redeclipse/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index 329eeff992f4..078841d82721 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -9,11 +9,13 @@ CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Single-player and multi-player first-person ego-shooter
-LICENSE_COMB= multi
LICENSE= MIT ZLIB
+LICENSE_COMB= multi
RUN_DEPENDS= redeclipse-data>=1.5.0:${PORTSDIR}/games/redeclipse-data
+BROKEN_sparc64= does not build on sparc64
+
USE_GITHUB= yes
GH_ACCOUNT= red-eclipse
GH_PROJECT= base
@@ -46,10 +48,6 @@ OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer -ffast-math
.include <bsd.port.options.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= does not build on sparc64
-.endif
-
.if ${PORT_OPTIONS:MCLIENT}
DESKTOP_ENTRIES="Red Eclipse" \
"${COMMENT}" \
@@ -70,11 +68,11 @@ do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f:T}_bsd \
${STAGEDIR}${PREFIX}/${f}
.endfor
-.if ${PORT_OPTIONS:MCLIENT}
- ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico \
- ${STAGEDIR}${PREFIX}/share/pixmaps
-.endif
(cd ${WRKSRC} && ${COPYTREE_SHARE} config ${STAGEDIR}${DATADIR})
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+do-install-CLIENT-on:
+ ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+
.include <bsd.port.mk>