aboutsummaryrefslogtreecommitdiff
path: root/games/redeclipse
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-28 22:09:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-28 22:09:38 +0000
commit018b8d347922c12ca1f771a2f7c72ed567786751 (patch)
treea2529a6c7e7f1658f270bff488932245442bb685 /games/redeclipse
parent29c0030ea62db3f2917bd75b7343bbea404422a6 (diff)
downloadports-018b8d347922c12ca1f771a2f7c72ed567786751.tar.gz
ports-018b8d347922c12ca1f771a2f7c72ed567786751.zip
- Add support for vendor's optimized cflags
- Simplify data handling - it's no longer needed to symlink whole datadir tree in dotdir
Notes
Notes: svn path=/head/; revision=271953
Diffstat (limited to 'games/redeclipse')
-rw-r--r--games/redeclipse/Makefile16
-rw-r--r--games/redeclipse/files/bfclient.in17
-rw-r--r--games/redeclipse/files/bfserver.in17
-rw-r--r--games/redeclipse/files/pkg-message.in11
4 files changed, 11 insertions, 50 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index bfcd67a8edce..12bd4f92adde 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bloodfrontier
DISTVERSION= B2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Blood%20Frontier%20Beta%202
DISTNAME= ${PORTNAME}-${DISTVERSION}-linux
@@ -25,10 +25,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= libenet ${BINARIES}
MAKE_JOBS_SAFE= yes
-SUB_FILES= bfclient bfserver pkg-message
+SUB_FILES= bfclient bfserver
OPTIONS= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on
+ DEDICATED "Build dedicated server" on \
+ OPTIMIZED_CFLAGS "Enabled additional optimizations" on
.include <bsd.port.options.mk>
@@ -52,6 +53,11 @@ PLIST_FILES+= bin/bfserver libexec/bfserver
BINARIES+= server
.endif
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -fomit-frame-pointer
+CXXFLAGS+= -O3 -fomit-frame-pointer
+.endif
+
do-install:
.for f in ${BINARIES}
${INSTALL_SCRIPT} ${WRKDIR}/bf${f} ${PREFIX}/bin
@@ -66,8 +72,4 @@ post-install:
@${FIND} ${DATADIR} -type d | ${SORT} -r | \
${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
.include <bsd.port.mk>
diff --git a/games/redeclipse/files/bfclient.in b/games/redeclipse/files/bfclient.in
index 01d3b7ef4949..070440a1a1ca 100644
--- a/games/redeclipse/files/bfclient.in
+++ b/games/redeclipse/files/bfclient.in
@@ -1,18 +1,3 @@
#!/bin/sh
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.bloodfrontier, and create symlinks to the data files.
-
-if [ -d ~/.bloodfrontier ]
-then
- echo "Using existing ~/.bloodfrontier directory."
-else
- echo "Creating ~/.bloodfrontier directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
-fi
-
-cd ~/.bloodfrontier || exit 1
-exec %%PREFIX%%/libexec/bfclient "$@"
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/bfclient "$@"
diff --git a/games/redeclipse/files/bfserver.in b/games/redeclipse/files/bfserver.in
index 6f15e12a2bd0..ae98bc0bdd9a 100644
--- a/games/redeclipse/files/bfserver.in
+++ b/games/redeclipse/files/bfserver.in
@@ -1,18 +1,3 @@
#!/bin/sh
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.bloodfrontier, and create symlinks to the data files.
-
-if [ -d ~/.bloodfrontier ]
-then
- echo "Using existing ~/.bloodfrontier directory."
-else
- echo "Creating ~/.bloodfrontier directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
-fi
-
-cd ~/.bloodfrontier || exit 1
-exec %%PREFIX%%/libexec/bfserver "$@"
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/bfserver "$@"
diff --git a/games/redeclipse/files/pkg-message.in b/games/redeclipse/files/pkg-message.in
deleted file mode 100644
index 3bc3f84a8629..000000000000
--- a/games/redeclipse/files/pkg-message.in
+++ /dev/null
@@ -1,11 +0,0 @@
-###############################################################################
-
-1) First time, bloodfrontier creates a ~/.bloodfrontier directory with symlinks.
-2) Config files are in the ~/.bloodfrontier directory.
-3) If you want add new bindings into ~/.bloodfrontier/config.cfg, see
-
- %%DATADIR%%/data/keymap.cfg.
-
-4) Enjoy it ;)
-
-###############################################################################