aboutsummaryrefslogtreecommitdiff
path: root/games/redeclipse
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-03-15 11:51:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-03-15 11:51:06 +0000
commit19e2b6a6eb2412c2bc6e9c1203711234275f0e80 (patch)
treee55e1765d3f2fc582db249816aec9fba6ea0e0c2 /games/redeclipse
parent8d774333123e9a4edbcd7a92b253ffce0d6828a0 (diff)
downloadports-19e2b6a6eb2412c2bc6e9c1203711234275f0e80.tar.gz
ports-19e2b6a6eb2412c2bc6e9c1203711234275f0e80.zip
Improve style, consistency and fix minor issues in Cube-based ports
- Convert to option helpers - Drop unused libGLU dependency (except for games/cube) - Track direct dependency on libX11 (for XFetchBytes) - Drop redundant MKDIR before COPYTREE_* macros [1] - Wrap cd related commands with parentheses [1] - Wrap lines exceeding 80 characters - Bump PORTREVISION to pick up changes in dependencies, plist (assaultcube) and catch regressions early [1] - games/assaultcube: CLIENT uses openal/vorbisfile *instead* of SDL_mixer - games/assaultcube: drop unused gettext-tools dependency [1] - games/assaultcube: convert to PLIST_DIRS [1] - games/assaultcube: add patch for source/src/bot/bot_waypoint.cpp file to fix "invalid source encoding" warning [1] - games/{cube,bloodfrontier}: MASTER or SERVER don't need libX11 - games/redeclipse: tell how large the package is in IGNORE message - games/redeclipse: use PORTDATA to hold list of dirs for COPYTREE_SHARE Differential Revision: https://reviews.freebsd.org/D1831 PR: 197582 [1] PR: 197583 [2] Submitted by: lightside@gmx.com [1] Requested by: lightside@gmx.com [1] Reviewed by: amdmi3, lightside@gmx.com (maintainers) Approved by: maintainer timeout (1 month) [2] Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=381324
Diffstat (limited to 'games/redeclipse')
-rw-r--r--games/redeclipse/Makefile51
1 files changed, 22 insertions, 29 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index feea9477e184..e86c8c41d559 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= redeclipse
PORTVERSION= 1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION:C/^([0-9]+\.[0-9]+)\..*/\1/}
DISTNAME= ${PORTNAME}_${PORTVERSION}_nix
@@ -14,7 +14,7 @@ COMMENT= Single-player and multi-player first-person ego-shooter
LICENSE_COMB= multi
LICENSE= MIT ZLIB
-MANUAL_PACKAGE_BUILD= huge
+MANUAL_PACKAGE_BUILD= huge (734MiB)
USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
@@ -27,9 +27,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= libenet
-SUB_FILES= ${PORTNAME} ${PORTNAME}_server
+SUB_FILES= ${PLIST_FILES:Mbin/*:T}
-PORTDATA= *
+PORTDATA= game data
PORTDOCS= *
PLIST_DIRS= %%DATADIR%%/data/brush
@@ -39,7 +39,15 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT=CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
+CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
+CLIENT_ALL_TARGET= client
+CLIENT_PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.ico
DEDICATED_DESC= Build dedicated server
+DEDICATED_ALL_TARGET= server
+DEDICATED_PLIST_FILES= bin/${PORTNAME}_server libexec/${PORTNAME}_server
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -fomit-frame-pointer
+OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer
.include <bsd.port.options.mk>
@@ -48,12 +56,6 @@ BROKEN= does not build on sparc64
.endif
.if ${PORT_OPTIONS:MCLIENT}
-USE_GL= yes
-USE_SDL= image mixer sdl
-PLIST_FILES+= bin/${PORTNAME} libexec/${PORTNAME} share/pixmaps/${PORTNAME}.ico
-BINARIES+= ${PORTNAME}
-ALL_TARGET+= client
-
DESKTOP_ENTRIES="Red Eclipse" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
@@ -62,28 +64,19 @@ DESKTOP_ENTRIES="Red Eclipse" \
""
.endif
-.if ${PORT_OPTIONS:MDEDICATED}
-PLIST_FILES+= bin/${PORTNAME}_server libexec/${PORTNAME}_server
-BINARIES+= ${PORTNAME}_server
-ALL_TARGET+= server
-.endif
-
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -fomit-frame-pointer
-CXXFLAGS+= -O3 -fomit-frame-pointer
-.endif
-
do-install:
-.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${STAGEDIR}${PREFIX}/libexec
+.for f in ${PLIST_FILES:Mbin/*}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f:T} ${STAGEDIR}${PREFIX}/${f}
+.endfor
+.for f in ${PLIST_FILES:Mlibexec/*}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f:T} \
+ ${STAGEDIR}${PREFIX}/${f:H}
.endfor
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
- ${MKDIR} ${STAGEDIR}${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "game data" ${STAGEDIR}${DATADIR}/
.if ${PORT_OPTIONS:MCLIENT}
- ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
.endif
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>