aboutsummaryrefslogtreecommitdiff
path: root/games/reminiscence
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-06-11 08:05:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-06-11 08:05:12 +0000
commit99991e797dca4e1ae9baf871c4eebbf602b371ac (patch)
tree379df1db1b045a9b84bbe95f357d23de96fe0a86 /games/reminiscence
parentc14245c1cfc86e0be6988853b3c1aa440bb45234 (diff)
downloadports-99991e797dca4e1ae9baf871c4eebbf602b371ac.tar.gz
ports-99991e797dca4e1ae9baf871c4eebbf602b371ac.zip
- Update to 0.2.1
Notes
Notes: svn path=/head/; revision=275348
Diffstat (limited to 'games/reminiscence')
-rw-r--r--games/reminiscence/Makefile7
-rw-r--r--games/reminiscence/distinfo5
-rw-r--r--games/reminiscence/files/patch-Makefile18
-rw-r--r--games/reminiscence/files/patch-main.cpp14
-rw-r--r--games/reminiscence/files/patch-sys.h23
5 files changed, 28 insertions, 39 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index c1165062494f..74aa82395485 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= REminiscence
-PORTVERSION= 0.1.9
-PORTREVISION= 4
+PORTVERSION= 0.2.1
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
http://mirror.amdmi3.ru/distfiles/
@@ -26,10 +25,6 @@ SUB_FILES= pkg-message
PORTDOCS= README
post-patch:
- @${REINPLACE_CMD} -e '/^CXX =/ d' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e '/^CXXFLAGS:=/ d' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e '/^CXXFLAGS+=.*-W/ d' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|DATA|${DATADIR}/data|' ${WRKSRC}/main.cpp
do-install:
diff --git a/games/reminiscence/distinfo b/games/reminiscence/distinfo
index fc8476ac557f..c7b33c5407d3 100644
--- a/games/reminiscence/distinfo
+++ b/games/reminiscence/distinfo
@@ -1,3 +1,2 @@
-MD5 (REminiscence-0.1.9.tar.bz2) = 26bc8a0f2ef2ba53f61245ab6b2b2d6b
-SHA256 (REminiscence-0.1.9.tar.bz2) = c1054c764571f0f20a6fd310c01bfe0164c6f9b9b0345031e634a4c374843da2
-SIZE (REminiscence-0.1.9.tar.bz2) = 94438
+SHA256 (REminiscence-0.2.1.tar.bz2) = 3168ffb7cd29e72a150e22edc6f0891001288f4c89d7900cbac8864ce763c2bd
+SIZE (REminiscence-0.2.1.tar.bz2) = 101621
diff --git a/games/reminiscence/files/patch-Makefile b/games/reminiscence/files/patch-Makefile
new file mode 100644
index 000000000000..ae5ecfc02afb
--- /dev/null
+++ b/games/reminiscence/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 2011-03-10 20:47:57.000000000 +0300
++++ Makefile 2011-05-05 11:43:09.000000000 +0400
+@@ -1,12 +1,11 @@
+
+-SDL_CFLAGS = `sdl-config --cflags`
+-SDL_LIBS = `sdl-config --libs`
++SDL_CFLAGS = `${SDL_CONFIG} --cflags`
++SDL_LIBS = `${SDL_CONFIG} --libs`
+
+ DEFINES = -DBYPASS_PROTECTION
+ #DEFINES = -DBYPASS_PROTECTION -DENABLE_PASSWORD_MENU -DNDEBUG
+
+-CXX = g++
+-CXXFLAGS := -g -O -Wall -Wuninitialized -Wshadow -Wimplicit -Wundef -Wreorder -Wnon-virtual-dtor -Wno-multichar
++CXXFLAGS += -Wall -Wuninitialized -Wshadow -Wimplicit -Wundef -Wreorder -Wnon-virtual-dtor -Wno-multichar
+ CXXFLAGS += -MMD $(SDL_CFLAGS) -DUSE_ZLIB $(DEFINES)
+
+ SRCS = collision.cpp cutscene.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp menu.cpp \
diff --git a/games/reminiscence/files/patch-main.cpp b/games/reminiscence/files/patch-main.cpp
index ec8d2838091b..402034fb67af 100644
--- a/games/reminiscence/files/patch-main.cpp
+++ b/games/reminiscence/files/patch-main.cpp
@@ -1,14 +1,14 @@
---- main.cpp.orig Tue Aug 23 22:26:20 2005
-+++ main.cpp Sat Feb 11 07:53:56 2006
+--- main.cpp.orig 2011-03-10 23:37:01.000000000 +0300
++++ main.cpp 2011-05-05 11:40:07.000000000 +0400
@@ -19,6 +19,7 @@
- #include "file.h"
+ #include "fs.h"
#include "game.h"
#include "systemstub.h"
+#include <sys/stat.h>
- static const char *USAGE =
+ static const char *USAGE =
"REminiscence - Flashback Interpreter\n"
-@@ -59,8 +60,15 @@
+@@ -83,8 +84,15 @@
#undef main
int main(int argc, char *argv[]) {
@@ -22,10 +22,10 @@
const char *dataPath = "DATA";
- const char *savePath = ".";
+ const char *savePath = buf;
+ const char *levelNum = "0";
for (int i = 1; i < argc; ++i) {
bool opt = false;
- if (strlen(argv[i]) >= 2) {
-@@ -79,5 +87,6 @@
+@@ -111,5 +119,6 @@
g->run();
delete g;
delete stub;
diff --git a/games/reminiscence/files/patch-sys.h b/games/reminiscence/files/patch-sys.h
deleted file mode 100644
index d013c65590bf..000000000000
--- a/games/reminiscence/files/patch-sys.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- sys.h.orig 2007-03-17 00:45:52.000000000 +0300
-+++ sys.h 2010-02-02 20:23:49.000000000 +0300
-@@ -19,12 +19,14 @@
- #ifndef __SYS_H__
- #define __SYS_H__
-
--typedef unsigned char uint8;
--typedef signed char int8;
--typedef unsigned short uint16;
--typedef signed short int16;
--typedef unsigned long uint32;
--typedef signed long int32;
-+#include <stdint.h>
-+
-+typedef uint8_t uint8;
-+typedef int8_t int8;
-+typedef uint16_t uint16;
-+typedef int16_t int16;
-+typedef uint32_t uint32;
-+typedef int32_t int32;
-
- inline uint16 READ_BE_UINT16(const void *ptr) {
- const uint8 *b = (const uint8 *)ptr;