aboutsummaryrefslogtreecommitdiff
path: root/games/reminiscence
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-18 20:22:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-18 20:22:51 +0000
commita7c0db668e903e801c82ddfb4edf9adfb4d9231b (patch)
treecf2a50f7004113837af9e78eb6cde495bf671191 /games/reminiscence
parent11be6fc04b3c760e119d6f2ddfcc5e0a2f0bbd27 (diff)
downloadports-a7c0db668e903e801c82ddfb4edf9adfb4d9231b.tar.gz
ports-a7c0db668e903e801c82ddfb4edf9adfb4d9231b.zip
- Update to 0.4.5
Notes
Notes: svn path=/head/; revision=517923
Diffstat (limited to 'games/reminiscence')
-rw-r--r--games/reminiscence/Makefile2
-rw-r--r--games/reminiscence/distinfo6
-rw-r--r--games/reminiscence/files/patch-Makefile20
3 files changed, 18 insertions, 10 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index 66fb8cc28934..bcc9ed4fd51d 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= REminiscence
-PORTVERSION= 0.3.7
+PORTVERSION= 0.4.5
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
https://mirror.amdmi3.ru/distfiles/
diff --git a/games/reminiscence/distinfo b/games/reminiscence/distinfo
index 864f9010de5f..44334c4e6702 100644
--- a/games/reminiscence/distinfo
+++ b/games/reminiscence/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526309088
-SHA256 (REminiscence-0.3.7.tar.bz2) = 3e1b9d8e260e5aca086c4a95a833abb2918a2a81047df706770b8f7dcda1934f
-SIZE (REminiscence-0.3.7.tar.bz2) = 128780
+TIMESTAMP = 1573833925
+SHA256 (REminiscence-0.4.5.tar.bz2) = 108ec26b71539a0697eff97498c31a26a10278892649584531732a0df0472abf
+SIZE (REminiscence-0.4.5.tar.bz2) = 155599
diff --git a/games/reminiscence/files/patch-Makefile b/games/reminiscence/files/patch-Makefile
index 72a82eb8606f..99f0c59df713 100644
--- a/games/reminiscence/files/patch-Makefile
+++ b/games/reminiscence/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2017-11-01 12:18:57 UTC
+--- Makefile.orig 2019-10-28 14:14:22 UTC
+++ Makefile
-@@ -2,12 +2,13 @@
+@@ -2,19 +2,20 @@
SDL_CFLAGS := `sdl2-config --cflags`
SDL_LIBS := `sdl2-config --libs`
@@ -14,8 +14,16 @@
+TREMOR_LIBS := `pkg-config --libs vorbisidec`
+ZLIB_LIBS := -lz
--CXXFLAGS += -Wall -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
-+CXXFLAGS += -Wall -MMD $(SDL_CFLAGS) $(MODPLUG_CFLAGS) $(TREMOR_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
+-CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_STATIC_SCALER -DUSE_TREMOR -DUSE_ZLIB
++CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) $(MODPLUG_CFLAGS) $(TREMOR_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
- SRCS = collision.cpp cutscene.cpp dynlib.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp menu.cpp \
- mixer.cpp mod_player.cpp ogg_player.cpp piege.cpp resource.cpp resource_aba.cpp \
+ SRCS = collision.cpp cpc_player.cpp cutscene.cpp decode_mac.cpp dynlib.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp \
+ menu.cpp mixer.cpp mod_player.cpp ogg_player.cpp piege.cpp protection.cpp resource.cpp resource_aba.cpp \
+ resource_mac.cpp scaler.cpp screenshot.cpp seq_player.cpp \
+ sfx_player.cpp staticres.cpp systemstub_sdl.cpp unpack.cpp util.cpp video.cpp
+
+-SCALERS := scalers/scaler_nearest.cpp scalers/scaler_tv2x.cpp scalers/scaler_xbr.cpp
++#SCALERS := scalers/scaler_nearest.cpp scalers/scaler_tv2x.cpp scalers/scaler_xbr.cpp
+
+ OBJS = $(SRCS:.cpp=.o) $(SCALERS:.cpp=.o)
+ DEPS = $(SRCS:.cpp=.d) $(SCALERS:.cpp=.d)