aboutsummaryrefslogtreecommitdiff
path: root/games/reminiscence
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-03 00:45:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-03 00:45:11 +0000
commitdeb9e5e87e6442108082e10ace7df08e989275cb (patch)
tree14337f7b82892e9d31f348bdb413f022ead1cb0e /games/reminiscence
parent6ef53926e2aefc6946c5b7088d7ae4eea5b45ce4 (diff)
downloadports-deb9e5e87e6442108082e10ace7df08e989275cb.tar.gz
ports-deb9e5e87e6442108082e10ace7df08e989275cb.zip
- Fix on 64bit platforms
Notes
Notes: svn path=/head/; revision=249148
Diffstat (limited to 'games/reminiscence')
-rw-r--r--games/reminiscence/Makefile10
-rw-r--r--games/reminiscence/files/patch-sys.h23
2 files changed, 25 insertions, 8 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index 010d3321d9b5..c1165062494f 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -7,7 +7,7 @@
PORTNAME= REminiscence
PORTVERSION= 0.1.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
http://mirror.amdmi3.ru/distfiles/
@@ -45,10 +45,4 @@ post-install:
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != i386
-IGNORE= Doesn't work on !i386 (ERROR: Bad CRC for bank data 38!)
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/reminiscence/files/patch-sys.h b/games/reminiscence/files/patch-sys.h
new file mode 100644
index 000000000000..d013c65590bf
--- /dev/null
+++ b/games/reminiscence/files/patch-sys.h
@@ -0,0 +1,23 @@
+--- sys.h.orig 2007-03-17 00:45:52.000000000 +0300
++++ sys.h 2010-02-02 20:23:49.000000000 +0300
+@@ -19,12 +19,14 @@
+ #ifndef __SYS_H__
+ #define __SYS_H__
+
+-typedef unsigned char uint8;
+-typedef signed char int8;
+-typedef unsigned short uint16;
+-typedef signed short int16;
+-typedef unsigned long uint32;
+-typedef signed long int32;
++#include <stdint.h>
++
++typedef uint8_t uint8;
++typedef int8_t int8;
++typedef uint16_t uint16;
++typedef int16_t int16;
++typedef uint32_t uint32;
++typedef int32_t int32;
+
+ inline uint16 READ_BE_UINT16(const void *ptr) {
+ const uint8 *b = (const uint8 *)ptr;