aboutsummaryrefslogtreecommitdiff
path: root/games/renpy
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-01-01 18:10:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-01-01 18:10:05 +0000
commit2de71a2bf850aa18f745b19df2e71c9e6ca8a25d (patch)
treefd7b53928766226f82c9460f50240c2740bc1993 /games/renpy
parentaffdc5892cb07e66cdcefec3c144f7be932623c2 (diff)
downloadports-2de71a2bf850aa18f745b19df2e71c9e6ca8a25d.tar.gz
ports-2de71a2bf850aa18f745b19df2e71c9e6ca8a25d.zip
devel/renpy: update to 7.4.0
Notes
Notes: svn path=/head/; revision=559862
Diffstat (limited to 'games/renpy')
-rw-r--r--games/renpy/Makefile27
-rw-r--r--games/renpy/distinfo6
-rw-r--r--games/renpy/files/patch-system-fribidi14
3 files changed, 23 insertions, 24 deletions
diff --git a/games/renpy/Makefile b/games/renpy/Makefile
index 102a70a2429b..f624845f0294 100644
--- a/games/renpy/Makefile
+++ b/games/renpy/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= renpy
-PORTVERSION= 7.3.5
+PORTVERSION= 7.4.0
DISTVERSIONSUFFIX=-sdk
CATEGORIES= games devel
MASTER_SITES= https://www.renpy.org/dl/${PORTVERSION}/
@@ -11,6 +11,7 @@ COMMENT= Framework for developing visual-novel type games
LICENSE= APACHE20 BSD3CLAUSE DejaVu LGPL21+ MIT OFL11 ZLIB
LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
LICENSE_FILE_DejaVu= ${WRKSRC}/renpy/common/DejaVuSans.txt
LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
@@ -20,21 +21,22 @@ LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-12-31
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:devel/py-game_sdl2@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:devel/py-game_sdl2@${PY_FLAVOR}
LIB_DEPENDS= libfribidi.so:converters/fribidi \
libpng.so:graphics/png \
libavcodec.so:multimedia/ffmpeg \
libfreetype.so:print/freetype2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=${PORTVERSION}:devel/py-game_sdl2@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:devel/py-game_sdl2@${PY_FLAVOR}
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
-USES= gl python:2.7 sdl shebangfix tar:bz2
-USE_GL= glew
+USES= python:2.7 sdl shebangfix tar:bz2
USE_PYTHON= autoplist distutils cython
USE_SDL= sdl2
-EXCLUDE= gen 'module/*.py[co]' 'renpy/*.py[co]'
+EXCLUDE= fribidi-src gen 'module/*.py[co]' 'renpy/*.py[co]'
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
SHEBANG_FILES= renpy.py launcher/game/tkaskdir.py
TARGET_ORDER_OVERRIDE=610:fix-shebang
@@ -58,23 +60,16 @@ OPTIONS_DEFINE= DOCS DIST EXAMPLES TKINTER
DIST_DESC= Distribution runtimes for Windows, OS X, Linux
DIST_VARS= LICENSE+="ART20 PSFL" \
- PORTDATA+="lib renpy.app renpy.exe renpy.sh"
+ PORTDATA+="lib renpy.app renpy.exe renpy-32.exe renpy.sh"
EXAMPLES_VARS= PORTDATA+="the_question tutorial"
TKINTER_DESC= Install Tkinter to allow choosing Projects Directory
TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
-. for lic in FREETYPE LIBJPEG LIBPNG MSVCR90
-DIST_VARS+= LICENSE+=${lic}
-LICENSE_NAME_${lic}= ${lic} license
-LICENSE_FILE_${lic}= ${WRKSRC}/LICENSE.txt
-LICENSE_PERMS_${lic}= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-. endfor
-
post-extract:
@${FIND} ${WRKSRC}/lib ${WRKSRC}/renpy.app -type d -empty -delete
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ @${REINPLACE_CMD} -e 's,/usr/bin/python[[:>:]],${PYTHON_CMD},' \
${WRKSRC}/launcher/game/choose_directory.rpy
# Avoid having to add -I/usr/include -L/usr/lib
@${REINPLACE_CMD} '/library("z")/d' ${BUILD_WRKSRC}/${PYSETUP}
@@ -87,7 +82,7 @@ add-plist-post: add-empty-dirs
add-empty-dirs:
# Keep images directory in gui and templates, see renpy@d81ea29
${FIND} ${WRKSRC} -type d -empty \
- ! \( -name "saves" -or -name "pysdlsound" \) | \
+ ! \( -name "gen" -or -name "saves" -or -name "pysdlsound" \) | \
${SED} 's,^${WRKSRC},@dir ${DATADIR},' >>${TMPPLIST}
post-install:
diff --git a/games/renpy/distinfo b/games/renpy/distinfo
index 6d61d83c9702..9b9173a7926a 100644
--- a/games/renpy/distinfo
+++ b/games/renpy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1571355531
-SHA256 (renpy-7.3.5-sdk.tar.bz2) = dbbd087f2578d70dc1bc3912259f5794d563e3404068c96c15d7127853dec40d
-SIZE (renpy-7.3.5-sdk.tar.bz2) = 95049773
+TIMESTAMP = 1608265749
+SHA256 (renpy-7.4.0-sdk.tar.bz2) = fa3bd48308573dcfd5028882d1c71423c04efae6e6f3dbc9b8b520313cfc5790
+SIZE (renpy-7.4.0-sdk.tar.bz2) = 122958957
diff --git a/games/renpy/files/patch-system-fribidi b/games/renpy/files/patch-system-fribidi
index 0232db728876..56ed9a9b93ac 100644
--- a/games/renpy/files/patch-system-fribidi
+++ b/games/renpy/files/patch-system-fribidi
@@ -4,15 +4,19 @@ gen/_renpybidi.c:564:10: fatal error: 'fribidi.h' file not found
#include "fribidi.h"
^
---- module/renpybidicore.c.orig 2018-07-11 04:11:19 UTC
-+++ module/renpybidicore.c
-@@ -1,5 +1,5 @@
+--- module/renpybidicore.c.orig 2019-12-14 15:31:48.000000000 +0000
++++ module/renpybidicore.c 2021-01-01 15:45:23.115935083 +0000
+@@ -1,10 +1,6 @@
#include <Python.h>
+
+-#ifdef RENPY_BUILD
+ #include <fribidi.h>
+-#else
-#include <fribidi-src/lib/fribidi.h>
-+#include <fribidi.h>
+-#endif
+
#include <stdlib.h>
- #ifndef alloca
--- module/setup.py.orig 2018-07-11 04:29:32 UTC
+++ module/setup.py
@@ -92,6 +92,7 @@ has_avresample = library("avresample", optional=True)