aboutsummaryrefslogtreecommitdiff
path: root/games/robotfindskitten/Makefile
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2013-01-13 02:11:13 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2013-01-13 02:11:13 +0000
commitbceca206be2d9d40577cb889725fcf92e48a7421 (patch)
tree11c082dce7125dafd95063d5f7830c989d0f1d02 /games/robotfindskitten/Makefile
parentc9ce5adb2467ab20bb8005e441e002697aeebde2 (diff)
downloadports-bceca206be2d9d40577cb889725fcf92e48a7421.tar.gz
ports-bceca206be2d9d40577cb889725fcf92e48a7421.zip
Notes
Diffstat (limited to 'games/robotfindskitten/Makefile')
-rw-r--r--games/robotfindskitten/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/games/robotfindskitten/Makefile b/games/robotfindskitten/Makefile
index 1bcd54a99393..712d4ac96f83 100644
--- a/games/robotfindskitten/Makefile
+++ b/games/robotfindskitten/Makefile
@@ -1,13 +1,8 @@
-# Ports collection makefile for: robotfindskitten
-# Date created: Wed Dec 3, 2003
-# Whom: Ceri Davies (ceri@FreeBSD.org)
-#
+# Created by: Ceri Davies (ceri@FreeBSD.org)
# $FreeBSD$
-#
PORTNAME= robotfindskitten
-PORTVERSION= 1.7320508.406
-PORTREVISION= 1
+PORTVERSION= 2.7182818.701
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= http://robotfindskitten.org/download/POSIX/
@@ -15,14 +10,21 @@ MASTER_SITES= http://robotfindskitten.org/download/POSIX/
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Yet another zen simulation
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= YES
-USE_GNOME= glib12
-INFO= ${PORTNAME}
-PLIST_FILES= bin/robotfindskitten
MAN6= robotfindskitten.6
-post-extract:
- ${RM} ${WRKSRC}/doc/robotfindskitten.info
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/share/games/robotfindskitten,${DATADIR},' \
+ ${WRKSRC}/doc/robotfindskitten.6
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/robotfindskitten ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/nki/vanilla.nki ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/robotfindskitten.6 ${MANPREFIX}/man/man6
.include <bsd.port.mk>