aboutsummaryrefslogtreecommitdiff
path: root/games/rocksndiamonds-data
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-22 22:38:45 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-22 22:38:45 +0000
commit5401cc79e7a02cfdfd776de0336b25b0236af248 (patch)
treedbeec0cc2c36cb92c4facdaad4d78d64b598e83e /games/rocksndiamonds-data
parent2ed2a30779fb6156801d58a14fe08b6eeee2c0f5 (diff)
downloadports-5401cc79e7a02cfdfd776de0336b25b0236af248.tar.gz
ports-5401cc79e7a02cfdfd776de0336b25b0236af248.zip
- New port rocksndiamonds-data
- Additional Player Levels for Rocks'n'Diamonds and R'n'D jue Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=314972
Diffstat (limited to 'games/rocksndiamonds-data')
-rw-r--r--games/rocksndiamonds-data/Makefile136
-rw-r--r--games/rocksndiamonds-data/distinfo100
-rw-r--r--games/rocksndiamonds-data/files/pkg-deinstall.in18
-rw-r--r--games/rocksndiamonds-data/files/pkg-message.in22
-rw-r--r--games/rocksndiamonds-data/pkg-descr3
5 files changed, 279 insertions, 0 deletions
diff --git a/games/rocksndiamonds-data/Makefile b/games/rocksndiamonds-data/Makefile
new file mode 100644
index 000000000000..09b026509123
--- /dev/null
+++ b/games/rocksndiamonds-data/Makefile
@@ -0,0 +1,136 @@
+# Created by: nemysis <nemysis@gmx.ch>
+# $FreeBSD$
+
+PORTNAME= rocksndiamonds-data
+PORTVERSION= 20130322
+CATEGORIES= games
+MASTER_SITES+= http://www.artsoft.org/RELEASES/rocksndiamonds/levels/:levels \
+ http://www.artsoft.org/RELEASES/unix/rocksndiamonds/levels/:unix_levels \
+ http://www.bd-fans.com/Files/RnD/Levels/
+DISTFILES= ZeldaII-1.0.0.zip:levels \
+ Zelda-1.0.0.zip:levels \
+ Emerald_Mine_Club-2.1.1.7z:levels \
+ Snake_Bite-1.0.0.zip:levels \
+ BD2K3-1.0.0.zip:levels \
+ rockslevels-sp-1.0.tar.gz:unix_levels \
+ rockslevels-dx-1.0.tar.gz:unix_levels \
+ Boulder_Dash_Dream-1.0.0.zip:levels \
+ ${LEVELS_BD_FANS:S/$/.zip/} \
+ Tutorial_Alpha.zip \
+ Puzzles_v1.8.zip
+DIST_SUBDIR= rocksndiamonds
+EXTRACT_ONLY= #empty
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Additional Player Levels for Rocks'n'Diamonds and R'n'D jue
+
+EXTRACT_DEPENDS+=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
+ 7z:${PORTSDIR}/archivers/p7zip
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+SUB_FILES= pkg-message pkg-deinstall
+
+LEVELS_ARTSOFT= zelda zelda2 Emerald_Mine_Club Snake_Bite BD2K3 \
+ DX_Boulderdash Supaplex Boulder_Dash_Dream
+
+LEVELS_BD_FANS= 42_Steps Alans_Random_Levels Alexanders_Levels Arcade_Levels \
+ Be_a_bug Contest_Levels Danilo_Parantar_Serrano Danilo_Parantar_Serrano_2 \
+ Hard_Skills Haspeton Learning_Maths Little_Games \
+ Magic_CEs Manuel Manuels_Sokoban_Levels Master-Rocks Memory \
+ Mini_Levels_Ryan Missions Mixed_Levels Mixed_Levels_2 MultiRandomLevel \
+ My_Levels_of_Fun Negundo_World_2 Negundo_World_3 P98_Level_Pack_1 \
+ Pacman Random_Games Rocks_n_Diamonds_Fun Ryans_Random_Levels Slippery_Ground \
+ Space_Invaders Space_Invaders_2 Springlis_Levels Stinky Super_BD-Rock \
+ Super_Comic_Levels Venatir Veysi_Orak_2006 Warparound_Murphy
+
+OPTIONS_SINGLE= SYMLINK
+OPTIONS_SINGLE_SYMLINK= RnD RnD_jue
+
+OPTIONS_DEFAULT= RnD_jue
+
+RnD_DESC= Levels default for Rocks'n'Diamonds
+RnD_jue_DESC= Levels default for R'n'D jue
+
+PREFIX= /usr/local
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRnD}
+RUN_DEPENDS+= rocksndiamonds:${PORTSDIR}/games/rocksndiamonds
+DATADIR= ${PREFIX}/share/rocksndiamonds
+DATADIR1= ${PREFIX}/share/rnd_jue
+.endif
+
+.if ${PORT_OPTIONS:MRnD_jue}
+RUN_DEPENDS+= rnd_jue:${PORTSDIR}/games/rnd_jue
+DATADIR= ${PREFIX}/share/rnd_jue
+DATADIR1= ${PREFIX}/share/rocksndiamonds
+.endif
+
+post-extract-script:
+ ${MKDIR} ${WRKDIR}/${PORTNAME}
+ 7z x ${_DISTDIR}/Emerald_Mine_Club-2.1.1.7z -o${WRKDIR}/${PORTNAME}
+.for l in ZeldaII-1.0.0.zip Zelda-1.0.0.zip Snake_Bite-1.0.0.zip BD2K3-1.0.0.zip \
+ Boulder_Dash_Dream-1.0.0.zip
+ @${UNZIP_CMD} -qo -d ${WRKDIR}/${PORTNAME} ${_DISTDIR}/${l}
+.endfor
+
+.for l in rockslevels-sp-1.0.tar.gz rockslevels-dx-1.0.tar.gz
+ @${TAR} xfjp ${_DISTDIR}/${l} -C ${WRKDIR}/${PORTNAME}
+.endfor
+ @(cd ${WRKDIR}/${PORTNAME}/levels && ${MV} * .. && cd .. && ${RMDIR} levels)
+.for l in DX_Boulderdash Supaplex
+ @${FIND} ${WRKDIR}/${PORTNAME}/${l} -name '*.level' | ${XARGS} ${CHMOD} 644
+.endfor
+
+.for l in ${LEVELS_BD_FANS:S/$/.zip/} Puzzles_v1.8.zip
+ @${UNZIP_CMD} -qo -d ${WRKDIR}/${PORTNAME} ${_DISTDIR}/${l}
+.endfor
+ @${UNZIP_CMD} -qo -d ${WRKDIR}/${PORTNAME}/Tutorials ${_DISTDIR}/Tutorial_Alpha.zip
+ @(cd ${WRKDIR}/${PORTNAME}/Tutorials && ${MV} "Tutorial Alpha" rnd_tutorial_alpha)
+ @(cd ${WRKDIR}/${PORTNAME} && ${MV} "Alan's_Random_Levels" Alans_Random_Levels)
+ @(cd ${WRKDIR}/${PORTNAME} && ${MV} "Veysi Orak 2006" Veysi_Orak_2006)
+ @${RM} -f ${WRKDIR}/${PORTNAME}/Readme.txt
+
+do-install:
+ @(cd ${WRKDIR}/${PORTNAME} && ${COPYTREE_SHARE} \* ${DATADIR}/levels)
+
+post-install:
+# Dynamically generate part of the PLIST, because the Levels are large
+.for l in ${LEVELS_ARTSOFT}
+ @${FIND} ${DATADIR}/levels/${l}/ ! -type d | ${SED} 's|^${PREFIX}/||' >> ${TMPPLIST}
+ @${FIND} -ds ${DATADIR}/levels/${l}/ -type d | \
+ ${SED} -E -e 's,(.*),@unexec ${RMDIR} "\1" 2>/dev/null || true,' >> ${TMPPLIST}
+.endfor
+
+.for l in ${LEVELS_BD_FANS} Puzzles
+ @${FIND} ${DATADIR}/levels/${l}/ ! -type d | ${SED} 's|^${PREFIX}/||' >> ${TMPPLIST}
+ @${FIND} -ds ${DATADIR}/levels/${l}/ -type d | \
+ ${SED} -E -e 's,(.*),@unexec ${RMDIR} "\1" 2>/dev/null || true,' >> ${TMPPLIST}
+.endfor
+ @${FIND} ${DATADIR}/levels/Tutorials/rnd_tutorial_alpha/ ! -type d | ${SED} 's|^${PREFIX}/||' >> ${TMPPLIST}
+ @${FIND} -ds ${DATADIR}/levels/Tutorials/rnd_tutorial_alpha/ -type d | \
+ ${SED} -E -e 's,(.*),@unexec ${RMDIR} "\1" 2>/dev/null || true,' >> ${TMPPLIST}
+
+# Symlink Levels which can use Rocks'n'Diamonds and R'n'D jue
+.if exists(${PREFIX}/share/rocksndiamonds) && ${PORT_OPTIONS:MRnD_jue}
+.for l in ${LEVELS_ARTSOFT} ${LEVELS_BD_FANS} Puzzles
+ @${LN} -sf ${DATADIR}/levels/${l} ${PREFIX}/share/rocksndiamonds/levels
+.endfor
+ @${LN} -sf ${DATADIR}/levels/Tutorials/rnd_tutorial_alpha ${PREFIX}/share/rocksndiamonds/levels/Tutorials
+.endif
+
+.if exists(${PREFIX}/share/rnd_jue) && ${PORT_OPTIONS:MRnD}
+.for l in ${LEVELS_ARTSOFT} ${LEVELS_BD_FANS} Puzzles
+ @${LN} -sf ${DATADIR}/levels/${l} ${PREFIX}/share/rnd_jue/levels
+.endfor
+ @${LN} -sf ${DATADIR}/levels/Tutorials/rnd_tutorial_alpha ${PREFIX}/share/rnd_jue/levels/Tutorials
+.endif
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/rocksndiamonds-data/distinfo b/games/rocksndiamonds-data/distinfo
new file mode 100644
index 000000000000..c096f9443b2a
--- /dev/null
+++ b/games/rocksndiamonds-data/distinfo
@@ -0,0 +1,100 @@
+SHA256 (rocksndiamonds/ZeldaII-1.0.0.zip) = bec04b0448f18f1b796972cccef736ad250b782d08fad35d1387e5b9a05d3e32
+SIZE (rocksndiamonds/ZeldaII-1.0.0.zip) = 11542241
+SHA256 (rocksndiamonds/Zelda-1.0.0.zip) = 6c50778224d76a0c708eddcb2a505c5a38cc57092f05bee9c4d58e2bb519a5e1
+SIZE (rocksndiamonds/Zelda-1.0.0.zip) = 2175860
+SHA256 (rocksndiamonds/Emerald_Mine_Club-2.1.1.7z) = a9d69fe3bfb46ff5525e713dadadfb04022b18ab76d0a0f6628e469468ca9841
+SIZE (rocksndiamonds/Emerald_Mine_Club-2.1.1.7z) = 20992125
+SHA256 (rocksndiamonds/Snake_Bite-1.0.0.zip) = 6f6b573d89588f56cb3b326f3a42fb57277307bd709713dbef329885ac4d006d
+SIZE (rocksndiamonds/Snake_Bite-1.0.0.zip) = 6506066
+SHA256 (rocksndiamonds/BD2K3-1.0.0.zip) = 5fc5130c859e69d6907bff87e01ff2296d59f7376202a8aacc03e55f359fb351
+SIZE (rocksndiamonds/BD2K3-1.0.0.zip) = 4715324
+SHA256 (rocksndiamonds/rockslevels-sp-1.0.tar.gz) = 770d75a5926bb924c6787a6f95ee9f7af743b629ea14005ab0375b57eb488f25
+SIZE (rocksndiamonds/rockslevels-sp-1.0.tar.gz) = 373564
+SHA256 (rocksndiamonds/rockslevels-dx-1.0.tar.gz) = 23f1710710eef1dcd1c490670de16d2d58dc98f3fdd9a2df186bdca590e57579
+SIZE (rocksndiamonds/rockslevels-dx-1.0.tar.gz) = 211151
+SHA256 (rocksndiamonds/Boulder_Dash_Dream-1.0.0.zip) = 6f9dc48023830fbdc318d8f18013b5a7e84ab3c815ba566a4a2c46faeb65c969
+SIZE (rocksndiamonds/Boulder_Dash_Dream-1.0.0.zip) = 10923437
+SHA256 (rocksndiamonds/42_Steps.zip) = b0966ef2e10ed3d92440697ef69f7d8d4f19f03f1ba12cd06289c48c7055f7bf
+SIZE (rocksndiamonds/42_Steps.zip) = 11390
+SHA256 (rocksndiamonds/Alans_Random_Levels.zip) = 1842f94b0085d4e0b20beb043ce58950c504f46a9b6b76076b1ad86cd4938a96
+SIZE (rocksndiamonds/Alans_Random_Levels.zip) = 23430
+SHA256 (rocksndiamonds/Alexanders_Levels.zip) = 80e0afd45b5ff639c5119abb507cf1078f156b1749ce87e4a2aac078cfccdf82
+SIZE (rocksndiamonds/Alexanders_Levels.zip) = 3417
+SHA256 (rocksndiamonds/Arcade_Levels.zip) = dc3a2c99a92b33d4400b5dbafe3fccebec04ecd6fa6f8b798add35e982199811
+SIZE (rocksndiamonds/Arcade_Levels.zip) = 7147
+SHA256 (rocksndiamonds/Be_a_bug.zip) = 3d00e76e72c9a18fd8099862a234e9e0027a092498184235dd0cd5401a1e4f63
+SIZE (rocksndiamonds/Be_a_bug.zip) = 100635
+SHA256 (rocksndiamonds/Contest_Levels.zip) = bcdbfd15df042d2dcbd7f070a56200557907c0abf6793b291c61d01c917bef60
+SIZE (rocksndiamonds/Contest_Levels.zip) = 4169
+SHA256 (rocksndiamonds/Danilo_Parantar_Serrano.zip) = e542e0e96b8f5a2c8684de186b304d8f556ad1945cf77c4776033751744fd1b9
+SIZE (rocksndiamonds/Danilo_Parantar_Serrano.zip) = 11167
+SHA256 (rocksndiamonds/Danilo_Parantar_Serrano_2.zip) = 8a5edf23c7372d4f0a8b3b9839e784a48fafc9640b7609208835c722eafaa241
+SIZE (rocksndiamonds/Danilo_Parantar_Serrano_2.zip) = 10235
+SHA256 (rocksndiamonds/Hard_Skills.zip) = 75ec6c337c1f20965919e2a83c47050590a2bd891381d359cc09b087e1c15003
+SIZE (rocksndiamonds/Hard_Skills.zip) = 24312
+SHA256 (rocksndiamonds/Haspeton.zip) = 040ff43ea350db83cbf5d8fb4dea47aea9457f07265a21adf19c474e217000b0
+SIZE (rocksndiamonds/Haspeton.zip) = 1295
+SHA256 (rocksndiamonds/Learning_Maths.zip) = c310a044a50042b7d010a1ec2d1b456b2f1ac0852511a19ea00e55687ae3ca68
+SIZE (rocksndiamonds/Learning_Maths.zip) = 12450
+SHA256 (rocksndiamonds/Little_Games.zip) = 378d7ee0e15e7eea7c0c7b95a3442a658e10c7b1dd1026bc1ba47e912c176895
+SIZE (rocksndiamonds/Little_Games.zip) = 3001
+SHA256 (rocksndiamonds/Magic_CEs.zip) = 3706a7f5a9cc44592d05076f48648979b914a9a9b6d49a6ebd895d5c6ab4ac6e
+SIZE (rocksndiamonds/Magic_CEs.zip) = 23277
+SHA256 (rocksndiamonds/Manuel.zip) = b7b8d1d9d5bdb297c123dcbbd586dc75bf4318379ee17d3d8fe6216f50de3b90
+SIZE (rocksndiamonds/Manuel.zip) = 11586
+SHA256 (rocksndiamonds/Manuels_Sokoban_Levels.zip) = f66a0ab4bbd9654b7a885de954cd2c13ea1713bd57fa82246131ce10c574fee5
+SIZE (rocksndiamonds/Manuels_Sokoban_Levels.zip) = 6554
+SHA256 (rocksndiamonds/Master-Rocks.zip) = 566a22f824b3ccd268b4c9708b0d6082cc32dfb7fa15048a9d343b2c1f90f980
+SIZE (rocksndiamonds/Master-Rocks.zip) = 28297
+SHA256 (rocksndiamonds/Memory.zip) = 87f57e1d3eed95625f93fc733b2c8c3477bcf21d299a5722cf713a642ae04f6f
+SIZE (rocksndiamonds/Memory.zip) = 3718
+SHA256 (rocksndiamonds/Mini_Levels_Ryan.zip) = 48200c0bfa782aa828069f3aaaff693375724e2857ce25a09f95d46cf6c3f51c
+SIZE (rocksndiamonds/Mini_Levels_Ryan.zip) = 19601
+SHA256 (rocksndiamonds/Missions.zip) = c01860020eb8667f82832d08a5d5c0712429e76584fd7be9e8c0c9e8267ac45f
+SIZE (rocksndiamonds/Missions.zip) = 833276
+SHA256 (rocksndiamonds/Mixed_Levels.zip) = a6c78adff177ed57f0b1bb9d0d9043a4f01ef8b872167aee150352247014019a
+SIZE (rocksndiamonds/Mixed_Levels.zip) = 21042
+SHA256 (rocksndiamonds/Mixed_Levels_2.zip) = 8ad6404fc141278a8a637ef2cabe8e5b07e9d2519b7a853d419a6be4f53ebff6
+SIZE (rocksndiamonds/Mixed_Levels_2.zip) = 11097
+SHA256 (rocksndiamonds/MultiRandomLevel.zip) = 244df9713502d2d50cb41388a9d8bae6362fbfb5060012416552474959ba46e7
+SIZE (rocksndiamonds/MultiRandomLevel.zip) = 2642
+SHA256 (rocksndiamonds/My_Levels_of_Fun.zip) = 2d4ef33a091ba4cdbfc311191c05fccdb7b752f4934c1f326495e702e1d5ee5c
+SIZE (rocksndiamonds/My_Levels_of_Fun.zip) = 9120
+SHA256 (rocksndiamonds/Negundo_World_2.zip) = e2a7953dc337ca8b3fdb2b9d6c998bf02c813dda5b255cd597a2bf51e5ab5c20
+SIZE (rocksndiamonds/Negundo_World_2.zip) = 65220
+SHA256 (rocksndiamonds/Negundo_World_3.zip) = 49f18be72dfea2c7b81b2d3f84262c93f8e05b10cb9528302952605580df2d97
+SIZE (rocksndiamonds/Negundo_World_3.zip) = 86405
+SHA256 (rocksndiamonds/P98_Level_Pack_1.zip) = 01979d4733ff0278334779595d4f43b330bfe5b78ba112d39b40bfd75c0d76ed
+SIZE (rocksndiamonds/P98_Level_Pack_1.zip) = 605805
+SHA256 (rocksndiamonds/Pacman.zip) = 56c9a4767d50f73407223781121b3634136f69c09dff31932154f78c2ec8cbed
+SIZE (rocksndiamonds/Pacman.zip) = 405277
+SHA256 (rocksndiamonds/Random_Games.zip) = a4c72b3e3407d04424d23c0ba489a80fa1de4d122d023d2bcef535adee345777
+SIZE (rocksndiamonds/Random_Games.zip) = 8504
+SHA256 (rocksndiamonds/Rocks_n_Diamonds_Fun.zip) = f9c60f51e7426fd799cfc1ae023d9ee033d2fb0437575b406c1937765d2d91fd
+SIZE (rocksndiamonds/Rocks_n_Diamonds_Fun.zip) = 12332
+SHA256 (rocksndiamonds/Ryans_Random_Levels.zip) = 3fd5283f22fb8f6772de5c0585148793a1a9bcc2d18d1f96704b70b012ccb827
+SIZE (rocksndiamonds/Ryans_Random_Levels.zip) = 3760
+SHA256 (rocksndiamonds/Slippery_Ground.zip) = ddff6f02fc86cea9d3ce6a0757db13ab3741863419b49111703b66d69d23c58c
+SIZE (rocksndiamonds/Slippery_Ground.zip) = 8592
+SHA256 (rocksndiamonds/Space_Invaders.zip) = e3924c8d82c695734f6134a6543c27d91510e66ff913e183f5e855a97aa1004f
+SIZE (rocksndiamonds/Space_Invaders.zip) = 192065
+SHA256 (rocksndiamonds/Space_Invaders_2.zip) = 3d10c6bae8b2004e4d2d69eb31eacfba49689503d5898a9b3eff134cfd505deb
+SIZE (rocksndiamonds/Space_Invaders_2.zip) = 230351
+SHA256 (rocksndiamonds/Springlis_Levels.zip) = 467bef9a1fded7caf1c340f40231ed537a317f77d575326680cc24eb711a5ed5
+SIZE (rocksndiamonds/Springlis_Levels.zip) = 1847
+SHA256 (rocksndiamonds/Stinky.zip) = f9e3e108976c644d4c2a42379764c6bad1623ea68615c49ea34a63073a903a65
+SIZE (rocksndiamonds/Stinky.zip) = 4511
+SHA256 (rocksndiamonds/Super_BD-Rock.zip) = fcc1e99d8356d0c3ad345ba7abef23e36cd8c7aef7122952cfbf40803041b222
+SIZE (rocksndiamonds/Super_BD-Rock.zip) = 9591
+SHA256 (rocksndiamonds/Super_Comic_Levels.zip) = 14ece96546fdd339e186681994677780d6297b0cf47300a5c209cfec36e2e73e
+SIZE (rocksndiamonds/Super_Comic_Levels.zip) = 248862
+SHA256 (rocksndiamonds/Venatir.zip) = 53316ca5bbed11f43521cedb1e639fae5bbe6cb4d5345ff729ba47e72809fcfe
+SIZE (rocksndiamonds/Venatir.zip) = 7371
+SHA256 (rocksndiamonds/Veysi_Orak_2006.zip) = 901fd166cc9c9935f9c9b0638d77cb5bae5756553ac50c633242a5b14f48c60d
+SIZE (rocksndiamonds/Veysi_Orak_2006.zip) = 52817
+SHA256 (rocksndiamonds/Warparound_Murphy.zip) = bb3e01566f08b92d59aff821057d8f78b3fd96ae59dbb4eb6e239f6ac2da0535
+SIZE (rocksndiamonds/Warparound_Murphy.zip) = 4070
+SHA256 (rocksndiamonds/Tutorial_Alpha.zip) = 3e8ac984b7723290939281ad3fdaa1b10e9d1da6bb5439f302a8b755742d113e
+SIZE (rocksndiamonds/Tutorial_Alpha.zip) = 5931
+SHA256 (rocksndiamonds/Puzzles_v1.8.zip) = 6cde0cac0a13b174c21d4602ee20c6316d31dfd24d09356fa7c6858d62297a37
+SIZE (rocksndiamonds/Puzzles_v1.8.zip) = 12286
diff --git a/games/rocksndiamonds-data/files/pkg-deinstall.in b/games/rocksndiamonds-data/files/pkg-deinstall.in
new file mode 100644
index 000000000000..9c99792794ee
--- /dev/null
+++ b/games/rocksndiamonds-data/files/pkg-deinstall.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ set -x
+ find %%PREFIX%%/share/rocksndiamonds -type l -exec rm -- {} +
+ find %%PREFIX%%/share/rnd_jue -type l -exec rm -- {} +
+fi
+
+#if [ "$2" != "POST-DEINSTALL" ]; then
+# exit 0
+#fi
+
+#set -x
+#find %%PREFIX%%/share/rocksndiamonds -type l -exec rm -- {} +
+#find %%PREFIX%%/share/rnd_jue -type l -exec rm -- {} +
diff --git a/games/rocksndiamonds-data/files/pkg-message.in b/games/rocksndiamonds-data/files/pkg-message.in
new file mode 100644
index 000000000000..2906efeee91a
--- /dev/null
+++ b/games/rocksndiamonds-data/files/pkg-message.in
@@ -0,0 +1,22 @@
+===============================================================================
+
+Rocks'n'Diamonds data has been installed.
+
+These levels can use Rocks'n'Diamonds and R'n'D jue.
+
+In addition, you can search for additional extra Levels here:
+
+ http://www.bd-fans.com/RnD.html
+
+and other Sites and put it in:
+
+ ~/.rocksndiamonds/levels/yours_username
+ ~/.rnd_jue/levels/yours_username
+
+
+You could manually change Permissions these Levels with:
+
+ chmod 444 ~/.rocksndiamonds/levels
+ chmod 444 ~/.rnd_jue/levels
+
+===============================================================================
diff --git a/games/rocksndiamonds-data/pkg-descr b/games/rocksndiamonds-data/pkg-descr
new file mode 100644
index 000000000000..561a5d48688c
--- /dev/null
+++ b/games/rocksndiamonds-data/pkg-descr
@@ -0,0 +1,3 @@
+Additional Player Levels for Rocks'n'Diamonds and R'n'D jue.
+
+WWW: http://www.bd-fans.com/RnD.html