aboutsummaryrefslogtreecommitdiff
path: root/games/rocksndiamonds
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-09 20:06:36 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-09 20:06:36 +0000
commitd38cb980376375dc6ae656831fd9930b84ae2147 (patch)
tree85f32b3d214af745d2fab14f45c91673cf149774 /games/rocksndiamonds
parent91031bb7821aac2621101a1bbe0f87c6be3cf5c5 (diff)
downloadports-d38cb980376375dc6ae656831fd9930b84ae2147.tar.gz
ports-d38cb980376375dc6ae656831fd9930b84ae2147.zip
- Update MASTER_SITES
- Add LICENSE - Mark MAKE_JOBS_SAFE - Convert to optionsNG PR: ports/172004 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307249
Diffstat (limited to 'games/rocksndiamonds')
-rw-r--r--games/rocksndiamonds/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/games/rocksndiamonds/Makefile b/games/rocksndiamonds/Makefile
index f08c9b136c15..a9df3308bb64 100644
--- a/games/rocksndiamonds/Makefile
+++ b/games/rocksndiamonds/Makefile
@@ -1,28 +1,31 @@
-# New ports collection makefile for: rocksndiamonds
-# Date created: 27 May 1999
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rocksndiamonds
PORTVERSION= 3.3.0.1
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://www.artsoft.org/RELEASES/unix/rocksndiamonds/ \
- http://freebsd.unixfreunde.de/sources/
+MASTER_SITES= SF/${PORTNAME}.mirror \
+ http://www.artsoft.org/RELEASES/unix/rocksndiamonds/
MAINTAINER= ports@FreeBSD.org
COMMENT= Colorful Boulderdash'n'Emerald Mine'n'Sokoban'n'Stuff
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= SDL DOCS
+
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" MAKE="${GMAKE}" OPTIONS="${CFLAGS}" \
RO_GAME_DIR="${DATADIR}" RW_GAME_DIR="${DATADIR}/scores" \
X11_PATH="${LOCALBASE}"
+MAKE_JOBS_SAFE= yes
MAN1= rocksndiamonds.1
-.if defined(WITH_SDL)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSDL}
LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
USE_SDL= image mixer net sdl
ALL_TARGET= sdl
@@ -43,7 +46,7 @@ do-install:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DATADIR})
.endfor
@${CHMOD} 777 ${DATADIR}/scores
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docfile in ChangeLog CREDITS README
${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}