aboutsummaryrefslogtreecommitdiff
path: root/games/rottdc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-19 08:56:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-19 08:56:29 +0000
commit67676e1060716e4e1f01df7a49415050b126a921 (patch)
treedb1cba1bdd43f2467487031f7745ac37d976e076 /games/rottdc
parenta4e6d056f176908545a48adcf77042fc9fa62c3f (diff)
downloadports-67676e1060716e4e1f01df7a49415050b126a921.tar.gz
ports-67676e1060716e4e1f01df7a49415050b126a921.zip
Add rottdc 1.0.2,
This is a port of Apogee's 3D action title Rise of the Triad, originally released in 1994. This port duplicates the functionality of the original game on modern operating systems, including Linux, Win32, OSX and now FreeBSD. In order to run game you'll need original game data. PR: ports/63049 Submitted by: Igor Pokrovsky <tiamat@comset.net>
Notes
Notes: svn path=/head/; revision=101368
Diffstat (limited to 'games/rottdc')
-rw-r--r--games/rottdc/Makefile38
-rw-r--r--games/rottdc/distinfo1
-rw-r--r--games/rottdc/files/patch-Makefile35
-rw-r--r--games/rottdc/files/patch-develop.h11
-rw-r--r--games/rottdc/files/patch-modexlib.c11
-rw-r--r--games/rottdc/files/patch-rt__cfg.c18
-rw-r--r--games/rottdc/files/patch-rt__in.c22
-rw-r--r--games/rottdc/pkg-descr9
-rw-r--r--games/rottdc/pkg-message3
-rw-r--r--games/rottdc/pkg-plist5
10 files changed, 153 insertions, 0 deletions
diff --git a/games/rottdc/Makefile b/games/rottdc/Makefile
new file mode 100644
index 000000000000..34dedc08999f
--- /dev/null
+++ b/games/rottdc/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: rottdc
+# Date created: 18 Feb 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rottdc
+PORTVERSION= 1.0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sdl-dc
+DISTNAME= ${PORTNAME}-1.0-2
+
+MAINTAINER= tiamat@comset.net
+COMMENT= Apogee's Rise Of The Triad source port
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer
+USE_XLIB= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/rott
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rott ${PREFIX}/bin
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+.for i in cheats cmdline
+ ${INSTALL_DATA} ${WRKSRC}/${i}.txt ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/rottdc/distinfo b/games/rottdc/distinfo
new file mode 100644
index 000000000000..2701ebad8d3e
--- /dev/null
+++ b/games/rottdc/distinfo
@@ -0,0 +1 @@
+MD5 (rottdc-1.0-2.tar.bz2) = 22eb77e7536d85ad49a495acdcaf9ae5
diff --git a/games/rottdc/files/patch-Makefile b/games/rottdc/files/patch-Makefile
new file mode 100644
index 000000000000..37d19122011f
--- /dev/null
+++ b/games/rottdc/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig Wed Jan 1 12:23:03 2003
++++ Makefile Wed Feb 18 08:55:16 2004
+@@ -8,8 +8,8 @@
+ # the build process's behaviour, set it to "true" or "false" (w/o quotes).
+ #-----------------------------------------------------------------------------#
+ #cygwin := true
+-#cygwin := false
+-cygwin := autodetect
++cygwin := false
++#cygwin := autodetect
+
+ # you only need to set these for Cygwin at the moment.
+ SDL_INC_DIR = /cygdrive/c/SDL/include
+@@ -40,15 +40,15 @@
+ SDL_LDFLAGS := -L$(SDL_LIB_DIR) -lSDL
+ endif
+ else
+- SDL_CFLAGS := $(shell sdl-config --cflags)
+- SDL_LDFLAGS := $(shell sdl-config --libs)
+- EXTRACFLAGS += -DUSE_EXECINFO=1
++ SDL_CFLAGS := $(shell ${SDL_CONFIG} --cflags)
++ SDL_LDFLAGS := $(shell ${SDL_CONFIG} --libs)
++# EXTRACFLAGS += -DUSE_EXECINFO=1
+ endif
+
+
+-CC = gcc
+-CFLAGS = -g $(SDL_CFLAGS) -DUSE_SDL=1 -DPLATFORM_UNIX=1 -W -Wall -Wno-unused $(EXTRACFLAGS)
+-LDLIBS = $(SDL_LDFLAGS) -lSDL -lSDL_mixer $(EXTRALDFLAGS) -Wl,-E
++#CC = gcc
++CFLAGS += -g $(SDL_CFLAGS) -DUSE_SDL=1 -DPLATFORM_UNIX=1 -W -Wall -Wno-unused $(EXTRACFLAGS)
++LDLIBS = $(SDL_LDFLAGS) -lSDL_mixer $(EXTRALDFLAGS) -Wl,-E
+
+ all: rott
+
diff --git a/games/rottdc/files/patch-develop.h b/games/rottdc/files/patch-develop.h
new file mode 100644
index 000000000000..7fd2e2f60941
--- /dev/null
+++ b/games/rottdc/files/patch-develop.h
@@ -0,0 +1,11 @@
+--- develop.h.orig Wed Feb 18 09:00:17 2004
++++ develop.h Wed Feb 18 09:01:08 2004
+@@ -41,7 +41,7 @@
+
+ // Make sure only one of the following are on at one time
+ #define SHAREWARE 0
+-#define SUPERROTT 0
++#define SUPERROTT 1
+ #define SITELICENSE 0
+
+ // cute little dopefish thing, only works with special patch?
diff --git a/games/rottdc/files/patch-modexlib.c b/games/rottdc/files/patch-modexlib.c
new file mode 100644
index 000000000000..35e506f51937
--- /dev/null
+++ b/games/rottdc/files/patch-modexlib.c
@@ -0,0 +1,11 @@
+--- modexlib.c.orig Wed Feb 18 08:29:15 2004
++++ modexlib.c Wed Feb 18 08:29:58 2004
+@@ -418,7 +418,7 @@
+ Error ("Could not initialize SDL\n");
+ }
+
+- #if defined(PLATFORM_WIN32) || defined(PLATFORM_MACOSX)
++ #if defined(PLATFORM_WIN32) || defined(PLATFORM_MACOSX) || defined(PLATFORM_UNIX)
+ // FIXME: remove this. --ryan.
+ flags = SDL_FULLSCREEN;
+ SDL_WM_GrabInput(SDL_GRAB_ON);
diff --git a/games/rottdc/files/patch-rt__cfg.c b/games/rottdc/files/patch-rt__cfg.c
new file mode 100644
index 000000000000..3abd861fb689
--- /dev/null
+++ b/games/rottdc/files/patch-rt__cfg.c
@@ -0,0 +1,18 @@
+--- rt_cfg.c.orig Wed Feb 18 08:55:40 2004
++++ rt_cfg.c Wed Feb 18 08:57:03 2004
+@@ -1047,11 +1047,11 @@
+ byte * vendor;
+ char filename[ 128 ];
+ #if (SHAREWARE==1)
+- VENDORDOC=("VENDOR.DOC");
+- VENDORLUMP=("VENDOR");
++ const char *VENDORDOC=("VENDOR.DOC");
++ const char *VENDORLUMP=("VENDOR");
+ #else
+- VENDORDOC ("LICENSE.DOC");
+- VENDORLUMP ("LICENSE");
++ const char *VENDORDOC=("LICENSE.DOC");
++ const char *VENDORLUMP=("LICENSE");
+ #endif
+
+
diff --git a/games/rottdc/files/patch-rt__in.c b/games/rottdc/files/patch-rt__in.c
new file mode 100644
index 000000000000..30d3b4b7c4cb
--- /dev/null
+++ b/games/rottdc/files/patch-rt__in.c
@@ -0,0 +1,22 @@
+--- rt_in.c.orig Wed Feb 18 08:30:12 2004
++++ rt_in.c Wed Feb 18 08:54:20 2004
+@@ -665,14 +665,16 @@
+
+ {
+ int buttons = 0;
++#if USE_SDL
++ int bmask, i;
++ const static int tbl[] = {SDL_BUTTON_LEFT,SDL_BUTTON_RIGHT,SDL_BUTTON_MIDDLE,SDL_BUTTON_WHEELUP,SDL_BUTTON_WHEELDOWN};
++#endif
+
+ IN_PumpEvents();
+
+ #if USE_SDL
+ #if 1
+- int bmask = SDL_GetMouseState(NULL,NULL);
+- int i;
+- const static int tbl[] = {SDL_BUTTON_LEFT,SDL_BUTTON_RIGHT,SDL_BUTTON_MIDDLE,SDL_BUTTON_WHEELUP,SDL_BUTTON_WHEELDOWN};
++ bmask = SDL_GetMouseState(NULL,NULL);
+ for(i=0;i<sizeof(tbl);i++) {
+ if (bmask & SDL_BUTTON(tbl[i])) buttons|=1<<i;
+ }
diff --git a/games/rottdc/pkg-descr b/games/rottdc/pkg-descr
new file mode 100644
index 000000000000..b87a0471f59e
--- /dev/null
+++ b/games/rottdc/pkg-descr
@@ -0,0 +1,9 @@
+This is a port of Apogee's 3D action title Rise of the Triad, originally
+released in 1994. This port duplicates the functionality of the original
+game on modern operating systems, including Linux, Win32, OSX and now FreeBSD.
+In order to run game you'll need original game data.
+
+WWW: http://sdl-dc.sourceforge.net/
+
+- Igor Pokrovsky
+tiamat@comset.net
diff --git a/games/rottdc/pkg-message b/games/rottdc/pkg-message
new file mode 100644
index 000000000000..6de08df1527e
--- /dev/null
+++ b/games/rottdc/pkg-message
@@ -0,0 +1,3 @@
+******************************************************************
+* Note: Run 'rott' from directory, containing original game data *
+******************************************************************
diff --git a/games/rottdc/pkg-plist b/games/rottdc/pkg-plist
new file mode 100644
index 000000000000..02b3a0433813
--- /dev/null
+++ b/games/rottdc/pkg-plist
@@ -0,0 +1,5 @@
+bin/rott
+%%PORTDOCS%%%%DOCSDIR%%/cheats.txt
+%%PORTDOCS%%%%DOCSDIR%%/cmdline.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%