aboutsummaryrefslogtreecommitdiff
path: root/games/rtb
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-18 09:15:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-18 09:15:29 +0000
commit44164d263d05c3828de39803d6ad07259b076bb5 (patch)
treee4642dd44ccd7bbd59dbcb1b5af6630d004d054c /games/rtb
parenta8fef3569c3619b77c61b3b4b93ef773799eb964 (diff)
downloadports-44164d263d05c3828de39803d6ad07259b076bb5.tar.gz
ports-44164d263d05c3828de39803d6ad07259b076bb5.zip
Notes
Diffstat (limited to 'games/rtb')
-rw-r--r--games/rtb/Makefile30
-rw-r--r--games/rtb/distinfo4
-rw-r--r--games/rtb/files/patch-include::List.h29
-rw-r--r--games/rtb/files/patch-include::fdstream.h18
-rw-r--r--games/rtb/files/patch-rtb-team-framework::io::unixinstreambuf.cpp10
-rw-r--r--games/rtb/files/patch-rtb-team-framework::io::unixoutstreambuf.cpp10
-rw-r--r--games/rtb/files/patch-src::String.cc19
-rw-r--r--games/rtb/pkg-plist97
8 files changed, 80 insertions, 137 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 4826571ba5d9..aa2e27f93cb5 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= RealTimeBattle
-PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTVERSION= 1.0.8
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
@@ -18,9 +17,10 @@ COMMENT= Robot programming game for UNIX
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnometarget gtk20
-USE_GCC= 3.4
+USE_GCC= 3.4+
USE_PERL5= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
@@ -29,28 +29,22 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-rtb-dir=${PREFIX}/lib/${PORTNAME}
-CXXFLAGS+= -fpermissive
-
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
-LDFLAGS= -L${LOCALBASE}/lib -lintl
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
-.for file in include/Various.h src/ArenaBase.cc src/GeometricalObjects.cc \
- src/Options.cc src/Robot.cc src/StartTournamentWindow.cc \
- src/StatisticsWindow.cc src/Various.cc
- @${REINPLACE_CMD} -E -e 's|min[[:space:]]*\(|Min(|g ; \
- s|max[[:space:]]*\(|Max\(|g' ${WRKSRC}/${file}
+.for file in configure
+ @${REINPLACE_CMD} -e '/test/s| == | = |g ; \
+ s|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g ; \
+ s|\\$${top_builddir}/intl/libintl.a|-lintl|g' ${WRKSRC}/${file}
.endfor
-.for file in src/ArenaRealTime.cc
- @${REINPLACE_CMD} -E -e 's|\(int\*\)|int\*|g' ${WRKSRC}/${file}
+.for file in Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|Documentation||g' ${WRKSRC}/${file}
.endfor
-.for file in rtb-team-framework/createrobot.sh \
- rtb-team-framework/createrobotconf.sh
+.for file in team-framework/createrobot.sh \
+ team-framework/createrobotconf.sh
@${REINPLACE_CMD} -e 's| sed| gsed|g' ${WRKSRC}/${file}
.endfor
-.for file in Makefile.in
- @${REINPLACE_CMD} -e 's|intl Documentation||g' ${WRKSRC}/${file}
-.endfor
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/rtb/distinfo b/games/rtb/distinfo
index f61f5977773b..1f77fd8931b6 100644
--- a/games/rtb/distinfo
+++ b/games/rtb/distinfo
@@ -1,2 +1,2 @@
-MD5 (RealTimeBattle-1.0.7-Ext.tar.gz) = 748316e5902add936d2855478743c456
-SIZE (RealTimeBattle-1.0.7-Ext.tar.gz) = 1238215
+MD5 (RealTimeBattle-1.0.8-Ext.tar.bz2) = 5d4d7cfc0628f8e106bcfa052af94db8
+SIZE (RealTimeBattle-1.0.8-Ext.tar.bz2) = 1060840
diff --git a/games/rtb/files/patch-include::List.h b/games/rtb/files/patch-include::List.h
deleted file mode 100644
index 324c09e88897..000000000000
--- a/games/rtb/files/patch-include::List.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- include/List.h.orig Tue Sep 21 15:50:15 2004
-+++ include/List.h Tue Sep 21 17:22:32 2004
-@@ -96,7 +96,7 @@
- inline T*
- ListIterator<T>::operator() () const
- {
-- if ( listp == NULL ) Error(true, "NULL pointer", "ListIterator::operator()");
-+ if ( listp == NULL ) Error(true, (const String&)"NULL pointer", (const String&)"ListIterator::operator()");
-
- return listp->element;
- }
-@@ -105,7 +105,7 @@
- inline const ListIterator<T>&
- ListIterator<T>::operator++ (int)
- {
-- if ( listp == NULL ) Error(true, "NULL pointer", "ListIterator::operator++");
-+ if ( listp == NULL ) Error(true, (const String&)"NULL pointer", (const String&)"ListIterator::operator++");
- listp = listp->next;
- return *this;
- }
-@@ -114,7 +114,7 @@
- inline const ListIterator<T>&
- ListIterator<T>::operator-- (int)
- {
-- if ( listp == NULL ) Error(true, "NULL pointer", "ListIterator::operator--");
-+ if ( listp == NULL ) Error(true, (const String&)"NULL pointer", (const String&)"ListIterator::operator--");
- listp = listp->prev;
- return *this;
- }
diff --git a/games/rtb/files/patch-include::fdstream.h b/games/rtb/files/patch-include::fdstream.h
deleted file mode 100644
index bbcf4906a665..000000000000
--- a/games/rtb/files/patch-include::fdstream.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- include/fdstream.h.orig Thu Sep 18 02:35:57 2003
-+++ include/fdstream.h Sat Mar 13 02:07:54 2004
-@@ -28,9 +28,15 @@
- #ifndef BOOST_FDSTREAM_HPP
- #define BOOST_FDSTREAM_HPP
-
-+#if defined __GNUC__ && __GNUC__ < 3
-+#include <istream.h>
-+#include <ostream.h>
-+#include <streambuf.h>
-+#else
- #include <istream>
- #include <ostream>
- #include <streambuf>
-+#endif
- // for EOF:
- #include <cstdio>
- // for memmove():
diff --git a/games/rtb/files/patch-rtb-team-framework::io::unixinstreambuf.cpp b/games/rtb/files/patch-rtb-team-framework::io::unixinstreambuf.cpp
deleted file mode 100644
index b662b3d1a3e7..000000000000
--- a/games/rtb/files/patch-rtb-team-framework::io::unixinstreambuf.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- rtb-team-framework/io/unixinstreambuf.cpp.orig Wed Nov 3 05:09:04 2004
-+++ rtb-team-framework/io/unixinstreambuf.cpp Fri Dec 17 01:33:22 2004
-@@ -29,6 +29,7 @@
- #include "../exceptions/keynotfoundexception.h"
- #include "../exceptions/confignotloadedexception.h"
- #include <sstream>
-+#include <cerrno>
-
- /**
- * Namespace
diff --git a/games/rtb/files/patch-rtb-team-framework::io::unixoutstreambuf.cpp b/games/rtb/files/patch-rtb-team-framework::io::unixoutstreambuf.cpp
deleted file mode 100644
index 60791975dd82..000000000000
--- a/games/rtb/files/patch-rtb-team-framework::io::unixoutstreambuf.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- rtb-team-framework/io/unixoutstreambuf.cpp.orig Wed Nov 3 05:09:04 2004
-+++ rtb-team-framework/io/unixoutstreambuf.cpp Fri Dec 17 01:34:44 2004
-@@ -26,6 +26,7 @@
-
- #include "unixoutstreambuf.h"
- #include <sstream>
-+#include <cerrno>
-
- /**
- * Namespace
diff --git a/games/rtb/files/patch-src::String.cc b/games/rtb/files/patch-src::String.cc
deleted file mode 100644
index 6fa78030e0ba..000000000000
--- a/games/rtb/files/patch-src::String.cc
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/String.cc.orig Fri Nov 12 22:04:38 2004
-+++ src/String.cc Tue Jan 11 02:28:46 2005
-@@ -21,12 +21,13 @@
- #include <config.h>
- #endif
-
--#include <string.h>
-+#include <cstring>
- #include <iostream>
- //#include <strstream>
- #include <iomanip>
--#include <stdlib.h>
--#include <ctype.h>
-+#include <cstdio>
-+#include <cstdlib>
-+#include <cctype>
-
- using namespace std;
-
diff --git a/games/rtb/pkg-plist b/games/rtb/pkg-plist
index e2611112e104..03d0a77997c7 100644
--- a/games/rtb/pkg-plist
+++ b/games/rtb/pkg-plist
@@ -20,23 +20,37 @@ lib/RealTimeBattle/Arenas/Triangle.arena
lib/RealTimeBattle/Arenas/my_Star.arena
lib/RealTimeBattle/Arenas/my_Star2.arena
lib/RealTimeBattle/RealTimeBattle.xpm
-lib/RealTimeBattle/Robots/Brotfrucht-Robot1-TeamOne.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot1-TeamTwo.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot2-TeamOne.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot2-TeamTwo.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot3-TeamOne.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot3-TeamTwo.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot4-TeamOne.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot4-TeamTwo.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot5-TeamOne.robot
-lib/RealTimeBattle/Robots/Brotfrucht-Robot5-TeamTwo.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Blaubeere-Fruchtteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Erdbeere-Fruchtteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Gerstenbrot-Brotteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Heidelbeere-Fruchtteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Himbeere-Fruchtteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Mischbrot-Brotteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Roggenbrot-Brotteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Stachelbeere-Fruchtteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Toastbrot-Brotteam.robot
+lib/RealTimeBattle/Robots/Brotfrucht-Weizenbrot-Brotteam.robot
+lib/RealTimeBattle/Robots/Cobra-Adder-AnacondaLike.robot
+lib/RealTimeBattle/Robots/Cobra-Anaconda-AnacondaLike.robot
+lib/RealTimeBattle/Robots/Cobra-Boa-AnacondaLike.robot
+lib/RealTimeBattle/Robots/Cobra-Cobra-CobraLike.robot
+lib/RealTimeBattle/Robots/Cobra-CoralSnake-CobraLike.robot
+lib/RealTimeBattle/Robots/Cobra-Krait-CobraLike.robot
+lib/RealTimeBattle/Robots/Cobra-Mamba-CobraLike.robot
+lib/RealTimeBattle/Robots/Cobra-Python-AnacondaLike.robot
+lib/RealTimeBattle/Robots/Cobra-TigerSnake-CobraLike.robot
+lib/RealTimeBattle/Robots/Cobra-Viper-AnacondaLike.robot
+lib/RealTimeBattle/Robots/Columbus-Cabral-Portugal.robot
+lib/RealTimeBattle/Robots/Columbus-Cortez-Spain.robot
+lib/RealTimeBattle/Robots/Columbus-Pizarro-Spain.robot
+lib/RealTimeBattle/Robots/Columbus-Vasco_da_Gama-Portugal.robot
+lib/RealTimeBattle/Robots/Columbus-Vespucci-Spain.robot
+lib/RealTimeBattle/Robots/Columbus-Zarco-Portugal.robot
lib/RealTimeBattle/Robots/empty/Makefile.am
lib/RealTimeBattle/Robots/empty/empty.c
-lib/RealTimeBattle/Robots/empty-Robot1-TeamThree.robot
-lib/RealTimeBattle/Robots/empty-Robot2-TeamThree.robot
-lib/RealTimeBattle/Robots/empty-Robot3-TeamThree.robot
-lib/RealTimeBattle/Robots/empty-Robot4-TeamThree.robot
-lib/RealTimeBattle/Robots/empty-Robot5-TeamThree.robot
+lib/RealTimeBattle/Robots/empty-fool-TeamLazy.robot
+lib/RealTimeBattle/Robots/empty-idiot-TeamLazy.robot
+lib/RealTimeBattle/Robots/empty-lamer-TeamLazy.robot
lib/RealTimeBattle/Robots/empty.robot
lib/RealTimeBattle/Robots/jBot/JBot.java
lib/RealTimeBattle/Robots/jBot/JBotMain.java
@@ -47,11 +61,11 @@ lib/RealTimeBattle/Robots/jBot/jBot.robot.in
lib/RealTimeBattle/Robots/joypad_robot/Makefile.am
lib/RealTimeBattle/Robots/joypad_robot/README
lib/RealTimeBattle/Robots/joypad_robot/joypad_robot.c
-lib/RealTimeBattle/Robots/perl/Robot.pm
lib/RealTimeBattle/Robots/perl/perl.robot.in
lib/RealTimeBattle/Robots/perl-Skeleton/perl-Skeleton.robot.in
lib/RealTimeBattle/Robots/perl-Skeleton.robot
lib/RealTimeBattle/Robots/perl.robot
+lib/RealTimeBattle/Robots/raziel/raziel.py.robot.in
lib/RealTimeBattle/Robots/rotate_and_fire/Makefile.am
lib/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire.cc
lib/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire.h
@@ -61,21 +75,35 @@ lib/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire_signal.cc
lib/RealTimeBattle/Robots/rotate_and_fire_blocking.robot
lib/RealTimeBattle/Robots/rotate_and_fire_select.robot
lib/RealTimeBattle/Robots/rotate_and_fire_signal.robot
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot1-TeamOne.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot1-TeamTwo.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot2-TeamOne.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot2-TeamTwo.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot3-TeamOne.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot3-TeamTwo.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot4-TeamOne.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot4-TeamTwo.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot5-TeamOne.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Robot5-TeamTwo.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/empty-Robot1-TeamThree.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/empty-Robot2-TeamThree.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/empty-Robot3-TeamThree.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/empty-Robot4-TeamThree.conf
-lib/RealTimeBattle/Robots/rtb-team-framework/empty-Robot5-TeamThree.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Blaubeere-Fruchtteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Erdbeere-Fruchtteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Gerstenbrot-Brotteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Heidelbeere-Fruchtteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Himbeere-Fruchtteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Mischbrot-Brotteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Roggenbrot-Brotteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Stachelbeere-Fruchtteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Toastbrot-Brotteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Brotfrucht-Weizenbrot-Brotteam.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Adder-AnacondaLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Anaconda-AnacondaLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Boa-AnacondaLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Cobra-CobraLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-CoralSnake-CobraLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Krait-CobraLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Mamba-CobraLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Python-AnacondaLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-TigerSnake-CobraLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Cobra-Viper-AnacondaLike.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Cabral-Portugal.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Cortez-Spain.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Pizarro-Spain.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Vasco_da_Gama-Portugal.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Vespucci-Spain.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/Columbus-Zarco-Portugal.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/empty-fool-TeamLazy.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/empty-idiot-TeamLazy.conf
+lib/RealTimeBattle/Robots/rtb-team-framework/empty-lamer-TeamLazy.conf
lib/RealTimeBattle/Robots/rtb-team-framework/rtb-team
lib/RealTimeBattle/Robots/seek_and_destroy/Makefile.am
lib/RealTimeBattle/Robots/seek_and_destroy/seek_and_destroy.cc
@@ -116,18 +144,25 @@ lib/RealTimeBattle/tournament.txt
%%PORTDOCS%%%%DOCSDIR%%/toc.gif
%%PORTDOCS%%%%DOCSDIR%%/toc.png
share/locale/de/LC_MESSAGES/RealTimeBattle.mo
+share/locale/en@boldquot/LC_MESSAGES/RealTimeBattle.mo
+share/locale/en@quot/LC_MESSAGES/RealTimeBattle.mo
share/locale/es/LC_MESSAGES/RealTimeBattle.mo
share/locale/gl/LC_MESSAGES/RealTimeBattle.mo
share/locale/ja/LC_MESSAGES/RealTimeBattle.mo
share/locale/pl/LC_MESSAGES/RealTimeBattle.mo
share/locale/pt/LC_MESSAGES/RealTimeBattle.mo
share/locale/sv/LC_MESSAGES/RealTimeBattle.mo
+@unexec rmdir %D/share/locale/en@boldquot/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/en@boldquot 2>/dev/null || true
+@unexec rmdir %D/share/locale/en@quot/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/en@quot 2>/dev/null || true
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/RealTimeBattle/Robots/xt-bot
@dirrm lib/RealTimeBattle/Robots/thomas2
@dirrm lib/RealTimeBattle/Robots/seek_and_destroy
@dirrm lib/RealTimeBattle/Robots/rtb-team-framework
@dirrm lib/RealTimeBattle/Robots/rotate_and_fire
+@dirrm lib/RealTimeBattle/Robots/raziel
@dirrm lib/RealTimeBattle/Robots/perl-Skeleton
@dirrm lib/RealTimeBattle/Robots/perl
@dirrm lib/RealTimeBattle/Robots/joypad_robot