aboutsummaryrefslogtreecommitdiff
path: root/games/rubix
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:12:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:12:01 +0000
commit2044b063a82969a09bf3ec4cfeb667b49a52339b (patch)
tree043d6d77e1797958938b06da3d52670cac6fcdd0 /games/rubix
parent27956856a57266fb8ed57b29fe740a8a6a689e52 (diff)
downloadports-2044b063a82969a09bf3ec4cfeb667b49a52339b.tar.gz
ports-2044b063a82969a09bf3ec4cfeb667b49a52339b.zip
- Update to version 1.0.3
PR: 59751 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=94925
Diffstat (limited to 'games/rubix')
-rw-r--r--games/rubix/Makefile16
-rw-r--r--games/rubix/distinfo2
-rw-r--r--games/rubix/files/patch-aa50
-rw-r--r--games/rubix/files/patch-ab10
-rw-r--r--games/rubix/files/patch-ac17
-rw-r--r--games/rubix/files/patch-ad22
-rw-r--r--games/rubix/pkg-plist15
7 files changed, 17 insertions, 115 deletions
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index 73922741c987..ae4753d6acab 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -6,24 +6,28 @@
#
PORTNAME= rubix
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= games
MASTER_SITES= http://sed.free.fr/rubix/
MAINTAINER= ports@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" XINC="-I${X11BASE}/include" \
+ XLIB="-L${X11BASE}/lib -lX11"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rubix ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/rubix
- ${INSTALL_DATA} ${WRKSRC}/module.xm ${PREFIX}/share/rubix
.if !defined(NOPORTDOCS)
-.for file in AUTHORS BUGS INSTALL NOISE README TODO
- @${MKDIR} ${PREFIX}/share/doc/rubix
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/rubix
+.for file in AUTHORS BUGS INSTALL README TODO
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/games/rubix/distinfo b/games/rubix/distinfo
index def5c9c4f230..fc7a4c85f5d0 100644
--- a/games/rubix/distinfo
+++ b/games/rubix/distinfo
@@ -1 +1 @@
-MD5 (rubix-1.0.2.tar.gz) = c59d6e4ad830aa37f6c559c587c15cd8
+MD5 (rubix-1.0.3.tar.bz2) = 05a8721e409f7b7d18c994a6a86b2f25
diff --git a/games/rubix/files/patch-aa b/games/rubix/files/patch-aa
deleted file mode 100644
index 3322265f3228..000000000000
--- a/games/rubix/files/patch-aa
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.orig Tue Dec 7 00:19:16 1999
-+++ Makefile Sat Dec 23 13:31:45 2000
-@@ -11,35 +11,38 @@
- #
-
- #customize to fit your needs (it does not work for now).
--architecture=-DPC_ARCHI
-+#architecture=-DPC_ARCHI
-+module_path=-DMODULE_PATH=\"${PREFIX}/share/rubix\"
-
- #SOLARIS=-lsocket
-
--CC=gcc
--CFLAGS=-Wall -O3 -fomit-frame-pointer -ffast-math -Iplayer \
-- $(architecture)
-+CC?=gcc
-+CFLAGS+=-Iplayer \
-+ $(architecture) $(module_path)
- #CFLAGS=-Wall -g -ffast-math -Iplayer \
- # $(architecture)
--XINC=-I/usr/X11R6/include
--XLIB=-L/usr/X11R6/lib -lX11
-+XINC=-I${X11BASE}/include
-+XLIB=-L${X11BASE}/lib -lX11
-
- #the following should not be changed.
-
- OBJ=cube.o event.o fillpoly.o line.o main.o screen.o sound.o player/player.a
-
-+all: rubix
-+
- rubix : $(OBJ)
- $(CC) $(CFLAGS) -o $@ $^ -lm $(XLIB) $(SOLARIS)
- # strip rubix
-
- clean :
- rm -f *.o *~ core *.bak *.dat gmon.out
-- (cd player; make clean)
-+ (cd player; $(MAKE) clean)
-
- dep :
-- makedepend -Y *.c -s"#I like the GNU tools" -Iplayer
-+# makedepend -Y *.c -s"#I like the GNU tools" -Iplayer
-
- player/player.a : player/*.c player/*.h
-- (cd player; make)
-+ (cd player; $(MAKE))
-
- %.o : %.c
- $(CC) $(CFLAGS) $(XINC) -c -o $@ $<
diff --git a/games/rubix/files/patch-ab b/games/rubix/files/patch-ab
deleted file mode 100644
index 2606e58e9fc3..000000000000
--- a/games/rubix/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- event.c Thu Dec 2 12:50:06 1999
-+++ event.c.new Mon Dec 6 16:44:01 1999
-@@ -18,6 +18,7 @@
- #include <errno.h>
- #include <stdio.h>
- #include <X11/Xlib.h>
-+#include <string.h>
-
- #include "sound.h"
- #include "screen.h"
diff --git a/games/rubix/files/patch-ac b/games/rubix/files/patch-ac
deleted file mode 100644
index 08c596e3482b..000000000000
--- a/games/rubix/files/patch-ac
+++ /dev/null
@@ -1,17 +0,0 @@
---- player/Makefile.orig Fri Dec 3 02:35:44 1999
-+++ player/Makefile Sat Dec 23 13:35:18 2000
-@@ -4,10 +4,11 @@
- # * This is total free software.
- # */
-
--WITH_ASM=1
-+#WITH_ASM=1
-
--CC=gcc
--CFLAGS=-Wall -O3 -fomit-frame-pointer -ffast-math
-+CC?=gcc
-+INCS=-I${X11BASE}/include
-+CFLAGS+=$(INCS)
-
- OBJ=card.o mixer.o xm.o live_player.o wav.o
-
diff --git a/games/rubix/files/patch-ad b/games/rubix/files/patch-ad
deleted file mode 100644
index 18024606705b..000000000000
--- a/games/rubix/files/patch-ad
+++ /dev/null
@@ -1,22 +0,0 @@
---- main.c.orig Fri Dec 10 01:59:09 1999
-+++ main.c Sat Dec 23 13:37:46 2000
-@@ -54,6 +54,10 @@
- CUBE cube;
- int i;
- int rand=1;
-+ char full_module_file[4096];
-+ char *module_file = "module.xm";
-+ strcpy(full_module_file, MODULE_PATH "/");
-+ strcat(full_module_file, module_file);
-
- the_screen=&screen.buffer[0];
- d.buffer=screen.buffer;
-@@ -81,7 +85,7 @@
- }
-
- if (do_init_sound)
-- if (rubick_init_sound(&sound, "module.xm")==-1) {
-+ if (rubick_init_sound(&sound, full_module_file)==-1) {
- fprintf(stderr, "Error with initing the sound, sorry pal, no sound no game.\n(I fucked my head with"
- " an xm player, this is not for nothing !)\n");
- return 0;
diff --git a/games/rubix/pkg-plist b/games/rubix/pkg-plist
index fbf139f4a683..89f3e3df01ab 100644
--- a/games/rubix/pkg-plist
+++ b/games/rubix/pkg-plist
@@ -1,10 +1,7 @@
bin/rubix
-%%PORTDOCS%%share/doc/rubix/AUTHORS
-%%PORTDOCS%%share/doc/rubix/BUGS
-%%PORTDOCS%%share/doc/rubix/INSTALL
-%%PORTDOCS%%share/doc/rubix/NOISE
-%%PORTDOCS%%share/doc/rubix/README
-%%PORTDOCS%%share/doc/rubix/TODO
-share/rubix/module.xm
-@dirrm share/rubix
-%%PORTDOCS%%@dirrm share/doc/rubix
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%