aboutsummaryrefslogtreecommitdiff
path: root/games/rubix
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-19 20:57:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-19 20:57:43 +0000
commitbb2dcea4df840a7acf309b73f5a79c999143e45c (patch)
tree6954e4b09d1d254fab03baab8749df9f67a7fe7a /games/rubix
parentc9e8102d01a6a20aac264b80aaea9c6d3002c6a2 (diff)
downloadports-bb2dcea4df840a7acf309b73f5a79c999143e45c.tar.gz
ports-bb2dcea4df840a7acf309b73f5a79c999143e45c.zip
- Simplify
- Fix compiler requirements - Fix build on mips, mips64
Notes
Notes: svn path=/head/; revision=401973
Diffstat (limited to 'games/rubix')
-rw-r--r--games/rubix/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index ae7b6f5afa33..c1defcee06c7 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -10,29 +10,30 @@ MASTER_SITES= http://sed.free.fr/rubix/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
-USES= gmake tar:bzip2
+USES= compiler:nestedfct gmake tar:bzip2
USE_XORG= x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DENGLISH" \
XINC="-I${LOCALBASE}/include" XLIB="-L${LOCALBASE}/lib -lX11"
ALL_TARGET= ${PORTNAME}
-USE_GCC= any
-PORTDOCS= ${DOCFILES}
+PORTDOCS= AUTHORS BUGS INSTALL README TODO
PLIST_FILES= bin/rubix
-DOCFILES= AUTHORS BUGS INSTALL README TODO
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == mips || ${ARCH} == mips64) && ${COMPILER_TYPE} == gcc
+CFLAGS+= -fnested-functions
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rubix ${STAGEDIR}${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for file in ${DOCFILES}
+.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>