aboutsummaryrefslogtreecommitdiff
path: root/games/sauerbraten
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-06 18:19:46 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-06 18:19:46 +0000
commit7e3ab2862b49474fe190f4a7fdbd87c0d10a4786 (patch)
tree4a30a9a4ff9fe3aa6d13c8ed18d399661bc22991 /games/sauerbraten
parentc53d0cce7717d48409adbe2a6a8f0c48f040aeb7 (diff)
downloadports-7e3ab2862b49474fe190f4a7fdbd87c0d10a4786.tar.gz
ports-7e3ab2862b49474fe190f4a7fdbd87c0d10a4786.zip
- Use the correct way to check the default options on Makefile
PR: ports/105004 Submitted by: Dmitry Marakasov <amdmi3__at__mail.ru>
Notes
Notes: svn path=/head/; revision=176634
Diffstat (limited to 'games/sauerbraten')
-rw-r--r--games/sauerbraten/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/sauerbraten/Makefile b/games/sauerbraten/Makefile
index 2d7da99514b5..20e75a2c6318 100644
--- a/games/sauerbraten/Makefile
+++ b/games/sauerbraten/Makefile
@@ -34,7 +34,7 @@ SAUDATDIR= packages data
.include <bsd.port.pre.mk>
-.if !defined(WITH_CLIENT) && !defined(WITH_DEDICATED)
+.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED)
IGNORE= needs at least one executable (CLIENT or DEDICATED)
.endif
@@ -42,7 +42,7 @@ IGNORE= needs at least one executable (CLIENT or DEDICATED)
BROKEN= does not compile
.endif
-.if defined(WITH_CLIENT)
+.if !defined(WITHOUT_CLIENT)
USE_GL= yes
USE_SDL= image mixer sdl
ALL_TARGET+= client
@@ -52,7 +52,7 @@ SAUER_BIN+= client
PLIST_SUB+= CLIENT=""
.endif
-.if defined(WITH_DEDICATED)
+.if !defined(WITHOUT_DEDICATED)
ALL_TARGET+= server
PLIST_SUB+= DEDICATED=""
SAUER_BIN+= server