aboutsummaryrefslogtreecommitdiff
path: root/games/scid
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-27 16:04:55 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-27 16:04:55 +0000
commit0331527e398890db6b9e4ed6f02967ae7e292322 (patch)
tree30a2695c92cb709c46239d2bce96719cd033e094 /games/scid
parentdc72057538af4adff0c637eb382137a2764d6636 (diff)
downloadports-0331527e398890db6b9e4ed6f02967ae7e292322.tar.gz
ports-0331527e398890db6b9e4ed6f02967ae7e292322.zip
Update to 3.4 [1]
Use tcl/tk 8.4.x[1] Update Maintainers email address[1] Use Systems zlib PR: 47519 Submitted by: Friedrich Volkmann <volkmann@inode.at>
Notes
Notes: svn path=/head/; revision=74092
Diffstat (limited to 'games/scid')
-rw-r--r--games/scid/Makefile10
-rw-r--r--games/scid/distinfo2
-rw-r--r--games/scid/files/patch-Makefile49
-rw-r--r--games/scid/pkg-plist2
4 files changed, 48 insertions, 15 deletions
diff --git a/games/scid/Makefile b/games/scid/Makefile
index ac984a988829..3664423bcf57 100644
--- a/games/scid/Makefile
+++ b/games/scid/Makefile
@@ -7,16 +7,16 @@
#
PORTNAME= scid
-PORTVERSION= 3.3
-CATEGORIES= games databases tk83 tcl83
+PORTVERSION= 3.4
+CATEGORIES= games databases
MASTER_SITES= http://scid.sourceforge.net/download/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= volkmann@chello.at
+MAINTAINER= volkmann@inode.at
-LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
- tk83:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
+ tk84:${PORTSDIR}/x11-toolkits/tk84
USE_PYTHON= yes
USE_XLIB= yes
diff --git a/games/scid/distinfo b/games/scid/distinfo
index dba4fde50d46..09091786666b 100644
--- a/games/scid/distinfo
+++ b/games/scid/distinfo
@@ -1 +1 @@
-MD5 (scid-3.3.tar.gz) = 33832300379f946fe9e241b014a3dad0
+MD5 (scid-3.4.tar.gz) = 5d9935e17d73ef24c8c6a9441bafca9c
diff --git a/games/scid/files/patch-Makefile b/games/scid/files/patch-Makefile
index b876af48c5ef..e689cd32c9ef 100644
--- a/games/scid/files/patch-Makefile
+++ b/games/scid/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Fri Feb 22 11:39:00 2002
-+++ Makefile Mon Mar 4 23:02:42 2002
-@@ -8,11 +8,11 @@
+--- Makefile.orig Wed Jan 22 03:54:00 2003
++++ Makefile Mon Jan 27 17:02:06 2003
+@@ -9,11 +9,11 @@
# BINDIR: where the Scid programs are copied for "make install".
#
@@ -14,7 +14,7 @@
### TCL_VERSION: Set this according to the version of Tcl/Tk you have
# installed that you want Scid to use: 8.0, 8.1, 8.2, 8.3, etc.
-@@ -26,9 +26,9 @@
+@@ -27,9 +27,9 @@
#
# You have not run "./configure" yet. The default settings are:
#
@@ -27,20 +27,29 @@
### Here are other commonly used settings for the Tcl/Tk compiler options:
-@@ -50,9 +50,9 @@
+@@ -51,9 +51,9 @@
# Someone sent me these settings for FreeBSD with Tcl/Tk 8.0:
### FreeBSD:
-# TCL_INCLUDE = -I /usr/local/include/tcl8.0 -I /usr/local/include/tk8.0
-# TCL_LIBRARY = -L /usr/local/lib -ltcl80 -ldl
-# TK_LIBRARY = $(TCL_LIBRARY) -ltk80 -L /usr/X11/lib -lX11
-+TCL_INCLUDE = -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 -I${X11BASE}/include
-+TCL_LIBRARY = -L${LOCALBASE}/lib -ltcl83
-+TK_LIBRARY = $(TCL_LIBRARY) -ltk83 -L${X11BASE}/lib -lX11
++TCL_INCLUDE = -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 -I${X11BASE}/include
++TCL_LIBRARY = -L${LOCALBASE}/lib -ltcl84
++TK_LIBRARY = $(TCL_LIBRARY) -ltk84 -L${X11BASE}/lib -lX11
########################################
-@@ -79,7 +79,7 @@
+@@ -71,7 +71,7 @@
+ # to include the code in the src/zlib directory.
+ # The default is to use the system zlib library.
+ #
+-SCIDFLAGS = -DZLIB
++#SCIDFLAGS = -DZLIB
+
+ ### OPTIMIZE: Optimization options for C++ compiler.
+ # -O4 is the most optimization for g++. I have found -O2 to do
+@@ -80,7 +80,7 @@
# On some systems, adding "-fno-rtti" and "-fno-exceptions" produces
# smaller, faster programs since Scid does not use those C++ features.
#
@@ -49,3 +58,25 @@
### DEBUG: Defining the macro ASSERTIONS will turn on assertions, which
# helps to track bugs after modifications, but the programs will run
+@@ -135,15 +135,15 @@
+
+ ### ZLIBOBJS: object files in the zlib compression library.
+ #
+-ZLIBOBJS= src/zlib/adler32.o src/zlib/compress.o src/zlib/crc32.o \
+- src/zlib/gzio.o src/zlib/uncompr.o src/zlib/deflate.o src/zlib/trees.o \
+- src/zlib/zutil.o src/zlib/inflate.o src/zlib/infblock.o \
+- src/zlib/inftrees.o src/zlib/infcodes.o src/zlib/infutil.o \
+- src/zlib/inffast.o
++#ZLIBOBJS= src/zlib/adler32.o src/zlib/compress.o src/zlib/crc32.o \
++# src/zlib/gzio.o src/zlib/uncompr.o src/zlib/deflate.o src/zlib/trees.o \
++# src/zlib/zutil.o src/zlib/inflate.o src/zlib/infblock.o \
++# src/zlib/inftrees.o src/zlib/infcodes.o src/zlib/infutil.o \
++# src/zlib/inffast.o
+
+ ### ZLIB: Should be "-lz" if your system has zlib, "" otherwise.
+ #
+-ZLIB =
++ZLIB = -lz
+
+ ### OBJS: Will be "$(SCIDOBJS)", and also "$(ZLIBOBJS)" if they are
+ # needed on your system.
diff --git a/games/scid/pkg-plist b/games/scid/pkg-plist
index 5bb68364377a..48e872cdc858 100644
--- a/games/scid/pkg-plist
+++ b/games/scid/pkg-plist
@@ -8,8 +8,10 @@ bin/sc_remote
bin/sc_spell
bin/sc_tree
bin/scid
+bin/scidlet
bin/scidpgn
bin/scmerge
+bin/spliteco
bin/tcscid
bin/tkscid
share/scid/scid.eco