aboutsummaryrefslogtreecommitdiff
path: root/games/scid
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-12 15:47:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-12 15:47:11 +0000
commit2b6d2524bdaa96ad24030e8462776e3d42acfde2 (patch)
tree7d47cde920b8cf42065a944a1a08bad5c7a0844b /games/scid
parent237e610a595f024b0e7f23c885b9166a86ffef14 (diff)
downloadports-2b6d2524bdaa96ad24030e8462776e3d42acfde2.tar.gz
ports-2b6d2524bdaa96ad24030e8462776e3d42acfde2.zip
- Update to version 4.4 [1]
- Remove leading article from COMMENT - Fix build on 10.x by respecting CC and CXX - Support staging PR: ports/187357 [1] Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=347983
Diffstat (limited to 'games/scid')
-rw-r--r--games/scid/Makefile18
-rw-r--r--games/scid/distinfo4
-rw-r--r--games/scid/files/patch-Makefile.conf8
-rw-r--r--games/scid/files/patch-configure32
-rw-r--r--games/scid/pkg-plist1
5 files changed, 50 insertions, 13 deletions
diff --git a/games/scid/Makefile b/games/scid/Makefile
index f8c5bd62cd64..1cd8c579c69a 100644
--- a/games/scid/Makefile
+++ b/games/scid/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= scid
-PORTVERSION= 4.3
+PORTVERSION= 4.4
CATEGORIES= games databases
-MASTER_SITES= SF/${PORTNAME}/Scid/Scid%204.3/
+MASTER_SITES= SF/${PORTNAME}/Scid/Scid%204.4/
MAINTAINER= bsd@volki.at
-COMMENT= A free chess database application
+COMMENT= Free chess database application
HAS_CONFIGURE= yes
-USES= gmake tk:84,85
+USES= gmake tk:84,85,86
USE_BZIP2= yes
USE_PYTHON= yes
-USE_GMAKE= yes
TCL_LIBRARY= -L${LOCALBASE}/lib -ltcl${TCL_SHLIB_VER}
CONFIGURE_ARGS= \
BINDIR="${PREFIX}/bin" \
SHAREDIR="${PREFIX}/share/scid" \
+ THREADS="-pthread" \
TCL_VERSION="${TCL_VER}" \
TCL_INCLUDE="-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} -I${LOCALBASE}/include" \
TCL_LIBRARY="${TCL_LIBRARY}" \
@@ -29,7 +29,11 @@ CONFIGURE_ARGS= \
ALL_TARGET= all strip
-WRKSRC= ${WRKDIR}/${PORTNAME}
+post-configure:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|g; s|gcc|${CC}|g' \
+ -e '/engines/ s|SHAREDIR|DESTDIR\)$$\(&|g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/engines/phalanx-scid/makefile \
+ ${WRKSRC}/engines/togaII1.2.1a/src/Makefile
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/scid/distinfo b/games/scid/distinfo
index b5404e155028..9ca1abd39fea 100644
--- a/games/scid/distinfo
+++ b/games/scid/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scid-4.3.tar.bz2) = 3cc3405ef7d49adf633b26ec633173bf4e42aec0aeb93d857d84a34ec0c5657d
-SIZE (scid-4.3.tar.bz2) = 12029115
+SHA256 (scid-4.4.tar.bz2) = ba3b01440ed7f16396360aab10a0bfe8354721c05a0a4f9e0031a800b8d781f2
+SIZE (scid-4.4.tar.bz2) = 12403187
diff --git a/games/scid/files/patch-Makefile.conf b/games/scid/files/patch-Makefile.conf
index 209eb1efbdff..5d423cc0d5c1 100644
--- a/games/scid/files/patch-Makefile.conf
+++ b/games/scid/files/patch-Makefile.conf
@@ -1,11 +1,11 @@
---- Makefile.conf.orig 2011-02-15 19:01:57.000000000 +0100
-+++ Makefile.conf 2012-02-04 12:19:08.000000000 +0100
-@@ -300,7 +300,7 @@
+--- Makefile.conf.orig 2013-03-28 18:51:58.000000000 +0100
++++ Makefile.conf 2014-03-07 19:34:39.000000000 +0100
+@@ -302,7 +302,7 @@
### To make the executable files smaller: type "make strip".
#
-strip:
-+strip: $(EXECS)
++strip: $(EXECS)
strip $(EXECS)
### To compress scid and executables with gzexe: type "make gzexe".
diff --git a/games/scid/files/patch-configure b/games/scid/files/patch-configure
new file mode 100644
index 000000000000..34a53f77053c
--- /dev/null
+++ b/games/scid/files/patch-configure
@@ -0,0 +1,32 @@
+--- configure.orig 2013-03-28 18:51:54.000000000 +0100
++++ configure 2014-03-07 20:03:28.000000000 +0100
+@@ -13,21 +13,17 @@
+ # tclsh program with a version number in the file name is found, the
+ # default program to execute is just tclsh.
+ # The backslashes at the end of these lines are needed: \
+-# tclsh=tclsh8.5;
+-
+-# This shell script code did not work for me in Linux so it is
+-# commented out for now; the configure script will just run in
+-# tclsh even if there is a more recent version.
+-## for tclver in 80 8.0 81 8.1 82 8.2 83 8.3 84 8.4 85 8.5; do \
+-## IFS=:; \
+-## for dir in $PATH; do \
+-## if [ -x $dir/tclsh$tclver ]; then tclsh=$dir/tclsh$tclver; fi; \
+-## done; \
+-## done
++tclsh=tclsh8.6; \
++for tclver in 80 8.0 81 8.1 82 8.2 83 8.3 84 8.4 85 8.5 86 8.6; do \
++ IFS=:; \
++ for dir in $PATH; do \
++ if [ -x $dir/tclsh$tclver ]; then tclsh=$dir/tclsh$tclver; fi; \
++ done; \
++done
+
+ # Now execute this script using the best tclsh version found:
+ # The backslash at the end of this line is needed: \
+-exec tclsh "$0" ${1+"$@"}
++exec $tclsh "$0" ${1+"$@"}
+
+ # Default values for Makefile settings:
+ #
diff --git a/games/scid/pkg-plist b/games/scid/pkg-plist
index ea62d39a84ac..a8cff0a8b24f 100644
--- a/games/scid/pkg-plist
+++ b/games/scid/pkg-plist
@@ -16,6 +16,7 @@ bin/spf2spi
bin/spliteco
bin/tcscid
bin/tkscid
+%%DATADIR%%/scid.gif
%%DATADIR%%/books/Elo2400.bin
%%DATADIR%%/books/Performance.bin
%%DATADIR%%/books/gm2600.bin