aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm-tools/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/scummvm-tools/Makefile
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
- adopt optionsNG for games
- trim historical headers and trim comments - some Makefile cleanup Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=319495
Diffstat (limited to 'games/scummvm-tools/Makefile')
-rw-r--r--games/scummvm-tools/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index 51f9c8c2f3aa..50a8f3485564 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scummvm-tools
-# Date created: 28 May 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= scummvm-tools
DISTVERSION= 1.0.0rc1
@@ -33,11 +29,13 @@ MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CXXFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
-OPTIONS= WX "Build wxWidgets GUI" On
+OPTIONS_DEFINE= WXGTK
+OPTIONS_DEFAULT= WXGTK
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if defined(WITH_WX)
+.if ${PORT_OPTIONS:MWXGTK}
USE_WX= 2.4+
WX_CONFIG= ${LOCALBASE}/bin/wxgtk2-2.8-config
WX_COMP= wx:lib:build
@@ -48,7 +46,7 @@ PLIST_SUB= WX="@comment "
.endif
post-patch:
-.if defined(WITH_WX)
+.if ${PORT_OPTIONS:MWXGTK}
@${REINPLACE_CMD} -e 's,wx-config,${WX_CONFIG},' ${WRKSRC}/Makefile
.else
@${REINPLACE_CMD} -e '/tools_gui$$(EXEEXT)$$/d' ${WRKSRC}/Makefile
@@ -66,7 +64,7 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif