aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2013-09-27 10:02:03 +0000
committerLars Engels <lme@FreeBSD.org>2013-09-27 10:02:03 +0000
commitd94ea62681c09b55d2c38e839eba084755697781 (patch)
tree5b178c3ab5028f95d74b2033c73323f3096b049a /games/scummvm
parenta9435cccace3de681a55b427ab0b24628918fbb8 (diff)
downloadports-d94ea62681c09b55d2c38e839eba084755697781.tar.gz
ports-d94ea62681c09b55d2c38e839eba084755697781.zip
Notes
Diffstat (limited to 'games/scummvm')
-rw-r--r--games/scummvm/Makefile73
-rw-r--r--games/scummvm/pkg-plist29
2 files changed, 48 insertions, 54 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index a53aed0d34ea..91069344cc87 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -11,13 +11,11 @@ MAINTAINER= lme@FreeBSD.org
COMMENT= Interpreter for several adventure games
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
HAS_CONFIGURE= yes
USE_SDL= sdl
-
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --with-sdl-prefix=${LOCALBASE} \
+CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE} \
--disable-alsa \
--with-zlib-prefix=/usr \
--disable-debug \
@@ -25,38 +23,11 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--disable-tremor
LDFLAGS+= ${PTHREAD_LIBS}
-OPTIONS_DEFINE= VORBIS MP3 FLAC FLUIDSYNTH MT32EMU
+OPTIONS_DEFINE= VORBIS MP3 PNG FLAC FLUIDSYNTH MT32EMU
FLUIDSYNTH_DESC= FluidSynth MIDI synthesizer
MT32EMU_DESC= MT-32 emulator
-OPTIONS_DEFAULT= VORBIS MP3 MT32EMU
-
-MAN6= scummvm.6
-
-PORTDOCS= AUTHORS NEWS README TODO COPYRIGHT
-ENGINEDATA= drascula.dat \
- hugo.dat \
- kyra.dat \
- lure.dat \
- queen.tbl \
- sky.cpt \
- teenagent.dat \
- toon.dat
-
-DESKTOP_ENTRIES="ScummVM" \
- "ScummVM - Run classic adventure games" \
- "${DATADIR}/scummvm.svg" \
- "scummvm" \
- "Game;AdventureGame;" \
- false
-
-PLIST_FILES= bin/scummvm \
- %%DATADIR%%/scummvm.svg \
- %%DATADIR%%/scummmodern.zip \
- %%DATADIR%%/translations.dat \
- $(ENGINEDATA:S/^/%%DATADIR%%\//)
-PLIST_DIRS= %%DATADIR%%
+OPTIONS_DEFAULT= VORBIS MP3 PNG MT32EMU
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
@@ -64,8 +35,8 @@ BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= ogg:${PORTSDIR}/audio/libogg \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libogg.so:${PORTSDIR}/audio/libogg \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
.else
@@ -73,21 +44,28 @@ CONFIGURE_ARGS+=--disable-vorbis
.endif
.if ${PORT_OPTIONS:MMP3}
-LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= libmad.so:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+=--with-mad-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+=--disable-mad
.endif
+.if ${PORT_OPTIONS:MPNG}
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+=--with-png-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-png
+.endif
+
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+=--with-flac-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+=--disable-flac
.endif
.if ${PORT_OPTIONS:MFLUIDSYNTH}
-LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
CONFIGURE_ARGS+=--with-fluidsynth-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+=--disable-fluidsynth
@@ -97,21 +75,8 @@ CONFIGURE_ARGS+=--disable-fluidsynth
CONFIGURE_ARGS+=--disable-mt32emu
.endif
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/dists/scummvm.6 ${MAN6PREFIX}/man/man6
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/icons/scummvm.svg ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/gui/themes/scummmodern.zip ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/gui/themes/translations.dat ${DATADIR}
-.for i in ${ENGINEDATA}
- @${INSTALL_DATA} ${WRKSRC}/dists/engine-data/${i} ${DATADIR}
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+post-install:
+ ${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dists/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}/
.include <bsd.port.mk>
diff --git a/games/scummvm/pkg-plist b/games/scummvm/pkg-plist
new file mode 100644
index 000000000000..01f4a621871a
--- /dev/null
+++ b/games/scummvm/pkg-plist
@@ -0,0 +1,29 @@
+bin/scummvm
+share/applications/scummvm.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.BSD
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.FREEFONT
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.LGPL
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/man/man6/scummvm.6
+share/pixmaps/scummvm.xpm
+%%DATADIR%%/drascula.dat
+%%DATADIR%%/hugo.dat
+%%DATADIR%%/kyra.dat
+%%DATADIR%%/lure.dat
+%%DATADIR%%/pred.dic
+%%DATADIR%%/queen.tbl
+%%DATADIR%%/scummclassic.zip
+%%DATADIR%%/scummmodern.zip
+%%DATADIR%%/sky.cpt
+%%DATADIR%%/teenagent.dat
+%%DATADIR%%/toon.dat
+%%DATADIR%%/translations.dat
+@dirrmtry %%DATADIR%%
+@dirrmtry share/man/man6
+@dirrmtry share/man
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry share/applications