aboutsummaryrefslogtreecommitdiff
path: root/games/sdlsand
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 14:10:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 14:10:20 +0000
commit113296853a52ccf74c1bd1ea0163e12e7fa9b261 (patch)
treeeb56c216af45fd783482e3b28575edf399d8755b /games/sdlsand
parent9aaa6e83bcaceb213b3b949ca1813c85e471fae6 (diff)
downloadports-113296853a52ccf74c1bd1ea0163e12e7fa9b261.tar.gz
ports-113296853a52ccf74c1bd1ea0163e12e7fa9b261.zip
Notes
Diffstat (limited to 'games/sdlsand')
-rw-r--r--games/sdlsand/Makefile3
-rw-r--r--games/sdlsand/files/patch-CmdLine.cpp10
2 files changed, 12 insertions, 1 deletions
diff --git a/games/sdlsand/Makefile b/games/sdlsand/Makefile
index d9f648f8f966..3abab8957947 100644
--- a/games/sdlsand/Makefile
+++ b/games/sdlsand/Makefile
@@ -10,7 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Simulation of falling sand and other materials
-USES= zip
+USES= dos2unix zip
+DOS2UNIX_FILES= CmdLine.cpp
USE_SDL= sdl
WRKSRC= ${WRKDIR}/SDL\ Sand/SDL\ Sand
diff --git a/games/sdlsand/files/patch-CmdLine.cpp b/games/sdlsand/files/patch-CmdLine.cpp
new file mode 100644
index 000000000000..15dc3d3e10d0
--- /dev/null
+++ b/games/sdlsand/files/patch-CmdLine.cpp
@@ -0,0 +1,10 @@
+--- CmdLine.cpp.orig 2015-03-27 03:02:22.542305000 +0300
++++ CmdLine.cpp 2015-03-27 03:02:46.761263000 +0300
+@@ -32,6 +32,7 @@
+ // if you're using MFC, you'll need to un-comment this line
+ // #include "stdafx.h"
+
++#include <string.h>
+ #include "CmdLine.h"
+
+ /*------------------------------------------------------