aboutsummaryrefslogtreecommitdiff
path: root/games/seabattle
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-03-27 12:08:01 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-03-27 12:08:01 +0000
commit35acff6856b910694501471327fa94a145d15b94 (patch)
tree79490bc3db47502d36077bd36d2e63ae1958304e /games/seabattle
parent15e29a46140490366ad23d2b9861511785e961ab (diff)
downloadports-35acff6856b910694501471327fa94a145d15b94.tar.gz
ports-35acff6856b910694501471327fa94a145d15b94.zip
Import seabattle port. This version comes with sound support.
PR: 4820 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=10329
Diffstat (limited to 'games/seabattle')
-rw-r--r--games/seabattle/Makefile25
-rw-r--r--games/seabattle/distinfo1
-rw-r--r--games/seabattle/files/patch-aa28
-rw-r--r--games/seabattle/files/patch-ab19
-rw-r--r--games/seabattle/files/patch-ac55
-rw-r--r--games/seabattle/files/patch-ad35
-rw-r--r--games/seabattle/pkg-comment1
-rw-r--r--games/seabattle/pkg-descr20
-rw-r--r--games/seabattle/pkg-plist10
9 files changed, 194 insertions, 0 deletions
diff --git a/games/seabattle/Makefile b/games/seabattle/Makefile
new file mode 100644
index 000000000000..27a4a96cd4fa
--- /dev/null
+++ b/games/seabattle/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: seabattle
+# Version required: 1.0
+# Date created: 6 June 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= seabattle-1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/strategy
+
+MAINTAINER= andy@icc.surw.chel.su
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/seabattle ${PREFIX}/bin/seabattle
+ @ ${MKDIR} ${PREFIX}/share/seabattle
+.for file in hit1 hit2 miss1 miss2 opening sunkit
+ @ ${INSTALL_DATA} ${WRKSRC}/${file}.au ${PREFIX}/share/seabattle/${file}.au
+.endfor
+ @ ${MKDIR} ${PREFIX}/share/doc/seabattle
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/seabattle/readme.txt
+
+.include <bsd.port.mk>
diff --git a/games/seabattle/distinfo b/games/seabattle/distinfo
new file mode 100644
index 000000000000..4045d539ff0b
--- /dev/null
+++ b/games/seabattle/distinfo
@@ -0,0 +1 @@
+MD5 (seabattle-1.0.tar.gz) = 83bb01f5494de99ef712f7e283217c45
diff --git a/games/seabattle/files/patch-aa b/games/seabattle/files/patch-aa
new file mode 100644
index 000000000000..7142b4443387
--- /dev/null
+++ b/games/seabattle/files/patch-aa
@@ -0,0 +1,28 @@
+*** Makefile Tue May 13 17:53:34 1997
+--- /home/andy/tmp/wrk/Makefile Mon Jun 30 14:43:45 1997
+***************
+*** 17,28 ****
+ #C_OPTS =
+ #L_OPTS = -lcurses
+
+! #On Linux, uncomment the following
+ #
+! PLATFORM = Linux
+! C_OPTS = -O2 -Wall
+ L_OPTS = -lncurses
+-
+
+ #For Dos/Windows DJGPP (you need the curses lib)
+ #PLATFORM = DOS_DJGPP
+--- 17,27 ----
+ #C_OPTS =
+ #L_OPTS = -lcurses
+
+! #On FreeBSD/Linux, uncomment the following
+ #
+! PLATFORM = FreeBSD/Linux
+! C_OPTS = ${CFLAGS} -DPREFIX=\"${PREFIX}\"
+ L_OPTS = -lncurses
+
+ #For Dos/Windows DJGPP (you need the curses lib)
+ #PLATFORM = DOS_DJGPP
diff --git a/games/seabattle/files/patch-ab b/games/seabattle/files/patch-ab
new file mode 100644
index 000000000000..c64ebe467406
--- /dev/null
+++ b/games/seabattle/files/patch-ab
@@ -0,0 +1,19 @@
+*** batt.h Tue May 13 19:58:17 1997
+--- /home/andy/tmp/wrk/batt.h Mon Jun 30 14:41:02 1997
+***************
+*** 2,8 ****
+ * batt.h Part of the SEABATTLE game by Vince Weaver *
+ ************************************************************************/
+
+! #include <curses.h> /* Slang support is good for rxvt in linux */
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+--- 2,8 ----
+ * batt.h Part of the SEABATTLE game by Vince Weaver *
+ ************************************************************************/
+
+! #include <ncurses.h> /* Slang support is good for rxvt in linux */
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
diff --git a/games/seabattle/files/patch-ac b/games/seabattle/files/patch-ac
new file mode 100644
index 000000000000..d10e66458e99
--- /dev/null
+++ b/games/seabattle/files/patch-ac
@@ -0,0 +1,55 @@
+*** bdb.c Tue May 13 19:49:59 1997
+--- /home/andy/tmp/wrk/bdb.c Mon Jun 30 14:41:23 1997
+***************
+*** 325,332 ****
+ char names[10][100],text[100];
+ int ch,scores[10],i;
+ /* If not there, create one */
+! if( (fff=fopen("hiscore.sea","r+"))==NULL ){
+! if ( (fff=fopen("hiscore.sea","a+"))!=NULL) {
+ fprintf(fff,"Vince\n50\nMarie\n55\nJohn\n56\n");
+ fprintf(fff,"Gus\n57\nLizann\n58\nKevin\n59\n");
+ fprintf(fff,"Hal\n60\nHairold\n61\nChipper\n62\nBob\n63\n");
+--- 325,332 ----
+ char names[10][100],text[100];
+ int ch,scores[10],i;
+ /* If not there, create one */
+! if( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","r+"))==NULL ){
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","a+"))!=NULL) {
+ fprintf(fff,"Vince\n50\nMarie\n55\nJohn\n56\n");
+ fprintf(fff,"Gus\n57\nLizann\n58\nKevin\n59\n");
+ fprintf(fff,"Hal\n60\nHairold\n61\nChipper\n62\nBob\n63\n");
+***************
+*** 335,341 ****
+ }
+ else fclose(fff);
+
+! if ( (fff=fopen("hiscore.sea","r"))!=NULL) {
+ for(i=0;i<10;i++)
+ fscanf(fff,"%s%i",names[i],&scores[i]);
+ fclose(fff);
+--- 335,341 ----
+ }
+ else fclose(fff);
+
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","r"))!=NULL) {
+ for(i=0;i<10;i++)
+ fscanf(fff,"%s%i",names[i],&scores[i]);
+ fclose(fff);
+***************
+*** 355,361 ****
+ set_color(C_WHITE,C_BOLD);
+ sprintf(text,"%s got a new High Score, #%i",name,i+1);
+ printxy(20,1,text);
+! if ( (fff=fopen("hiscore.sea","w+"))!=NULL) {
+ for(i=0;i<10;i++) fprintf(fff,"%s\n%i",names[i],scores[i]);
+ fclose(fff);
+ }
+--- 355,361 ----
+ set_color(C_WHITE,C_BOLD);
+ sprintf(text,"%s got a new High Score, #%i",name,i+1);
+ printxy(20,1,text);
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","w+"))!=NULL) {
+ for(i=0;i<10;i++) fprintf(fff,"%s\n%i",names[i],scores[i]);
+ fclose(fff);
+ }
diff --git a/games/seabattle/files/patch-ad b/games/seabattle/files/patch-ad
new file mode 100644
index 000000000000..9af20bc7223f
--- /dev/null
+++ b/games/seabattle/files/patch-ad
@@ -0,0 +1,35 @@
+*** binp.c Tue May 13 17:51:00 1997
+--- /home/andy/tmp/wrk/binp.c Mon Jun 30 14:41:38 1997
+***************
+*** 129,143 ****
+ /* Incomplete as of yet */
+ if (which_one==1)
+ if (sound_device)
+! if(rand()%2) system("cat hit1.au > /dev/audio ");
+! else system("cat hit2.au > /dev/audio ");
+ else beep();
+ if (which_one==2)
+ if (sound_device)
+! if(rand()%2) system("cat miss1.au > /dev/audio ");
+! else system("cat miss2.au > /dev/audio ");
+ if (which_one==3)
+! if (sound_device) system("cat sunkit.au > /dev/audio ");
+ else beep();
+ }
+
+--- 129,143 ----
+ /* Incomplete as of yet */
+ if (which_one==1)
+ if (sound_device)
+! if(rand()%2) system("cat " PREFIX "/share/seabattle/hit1.au > /dev/audio ");
+! else system("cat " PREFIX "/share/seabattle/hit2.au > /dev/audio ");
+ else beep();
+ if (which_one==2)
+ if (sound_device)
+! if(rand()%2) system("cat " PREFIX "/share/seabattle/miss1.au > /dev/audio ");
+! else system("cat " PREFIX "/share/seabattle/miss2.au > /dev/audio ");
+ if (which_one==3)
+! if (sound_device) system("cat " PREFIX "/share/seabattle/sunkit.au > /dev/audio ");
+ else beep();
+ }
+
diff --git a/games/seabattle/pkg-comment b/games/seabattle/pkg-comment
new file mode 100644
index 000000000000..42de8abc650d
--- /dev/null
+++ b/games/seabattle/pkg-comment
@@ -0,0 +1 @@
+A curses based battleship type game
diff --git a/games/seabattle/pkg-descr b/games/seabattle/pkg-descr
new file mode 100644
index 000000000000..0021aa8dc3c1
--- /dev/null
+++ b/games/seabattle/pkg-descr
@@ -0,0 +1,20 @@
+
+ .|'''| '||'''|, || || '||`
+ || || || || || ||
+ `|'''|, .|''|, '''|. ||;;;; '''|. ''||'' ''||'' || .|''|,
+ . || ||..|| .|''|| || || .|''|| || || || ||..||
+ |...|' `|... `|..||. .||...|' `|..||. `|..' `|..' .||. `|...
+
+ version 1.0 -- 14 May 1997
+
+ A Game By Vince Weaver -- Who cannot draw ASCII ships
+ weave@eng.umd.edu http://www.glue.umd.edu/~weave
+ Another Amazing Project for ENEE114
+
+ Send any bug reports, comments, or anything else to
+ Vince Weaver, weave@eng.umd.edu
+
+ Check out other VMW Software productions at
+ http://www.glue.umd.edu/~weave/vmwprod
+
+ Sea Battle -- A VMW Software Production ----------------------------
diff --git a/games/seabattle/pkg-plist b/games/seabattle/pkg-plist
new file mode 100644
index 000000000000..fec87f9b89ae
--- /dev/null
+++ b/games/seabattle/pkg-plist
@@ -0,0 +1,10 @@
+bin/seabattle
+share/seabattle/hit1.au
+share/seabattle/hit2.au
+share/seabattle/miss1.au
+share/seabattle/miss2.au
+share/seabattle/opening.au
+share/seabattle/sunkit.au
+share/doc/seabattle/readme.txt
+@dirrm share/seabattle
+@dirrm share/doc/seabattle