aboutsummaryrefslogtreecommitdiff
path: root/games/seabattle
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-05-30 11:45:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-05-30 11:45:14 +0000
commit62f31df64c3a534775a7563a7e5f5b3d77eca66a (patch)
tree55d6fb1d8040a536932bd5e411ee960652beb08e /games/seabattle
parentca5f52a23f2efdf7e967906408e8d3d1fa7b0783 (diff)
downloadports-62f31df64c3a534775a7563a7e5f5b3d77eca66a.tar.gz
ports-62f31df64c3a534775a7563a7e5f5b3d77eca66a.zip
Notes
Diffstat (limited to 'games/seabattle')
-rw-r--r--games/seabattle/Makefile22
-rw-r--r--games/seabattle/files/patch-batt.c11
-rw-r--r--games/seabattle/pkg-plist16
3 files changed, 29 insertions, 20 deletions
diff --git a/games/seabattle/Makefile b/games/seabattle/Makefile
index 3373f9d000cd..83d8d077c1eb 100644
--- a/games/seabattle/Makefile
+++ b/games/seabattle/Makefile
@@ -1,28 +1,28 @@
-# New ports collection makefile for: seabattle
-# Date created: 6 June 1997
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= seabattle
PORTVERSION= 1.0
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+MASTER_SITES= SUNSITE \
http://www.deater.net/weave/vmwprod/
MASTER_SITE_SUBDIR= games/strategy
MAINTAINER= ports@FreeBSD.org
-COMMENT= A curses based battleship type game
+COMMENT= Curses based battleship type game
+
+PORTDOCS= readme.txt
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/seabattle ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/seabattle
- ${INSTALL_DATA} ${WRKSRC}/*.au ${PREFIX}/share/seabattle
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/seabattle
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/seabattle
+ ${INSTALL_DATA} ${WRKSRC}/*.au ${DATADIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/seabattle/files/patch-batt.c b/games/seabattle/files/patch-batt.c
new file mode 100644
index 000000000000..2a489dd45311
--- /dev/null
+++ b/games/seabattle/files/patch-batt.c
@@ -0,0 +1,11 @@
+--- ./batt.c.orig 1997-05-13 15:45:51.000000000 +0000
++++ ./batt.c 2013-05-28 08:46:50.000000000 +0000
+@@ -13,7 +13,7 @@
+ int salvo_play=0; /* paramaters uncluttered*/
+ int first_time=0;
+
+-int main(int argc, char *argv)
++int main(int argc, char **argv)
+ {
+ MAIN_THINGY *main_thing;
+
diff --git a/games/seabattle/pkg-plist b/games/seabattle/pkg-plist
index 04bee92aae45..cd158d374fd3 100644
--- a/games/seabattle/pkg-plist
+++ b/games/seabattle/pkg-plist
@@ -1,10 +1,8 @@
bin/seabattle
-%%PORTDOCS%%share/doc/seabattle/readme.txt
-share/seabattle/hit1.au
-share/seabattle/hit2.au
-share/seabattle/miss1.au
-share/seabattle/miss2.au
-share/seabattle/opening.au
-share/seabattle/sunkit.au
-@dirrm share/seabattle
-%%PORTDOCS%%@dirrm share/doc/seabattle
+%%DATADIR%%/hit1.au
+%%DATADIR%%/hit2.au
+%%DATADIR%%/miss1.au
+%%DATADIR%%/miss2.au
+%%DATADIR%%/opening.au
+%%DATADIR%%/sunkit.au
+@dirrm %%DATADIR%%