aboutsummaryrefslogtreecommitdiff
path: root/games/searchandrescue
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-02 05:57:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-02 05:57:25 +0000
commitc948d3e2c97ae94b36719b705a0eaf0e8cb0a4d1 (patch)
tree96e1fd9bb9549eaf64e0810c389eca07ef272ac3 /games/searchandrescue
parent9f2dd540235d876039a6602d6d209451037be984 (diff)
downloadports-c948d3e2c97ae94b36719b705a0eaf0e8cb0a4d1.tar.gz
ports-c948d3e2c97ae94b36719b705a0eaf0e8cb0a4d1.zip
games/searchandrescue: Fix build on 12.0-CURRENT
Respect CPPFLAGS and stop doing weird things like defining __cplusplus in the build itself. In file included from <built-in>:388: <command line>:8:9: warning: '__cplusplus' macro redefined [-Wmacro-redefined] #define __cplusplus 1 ^ <built-in>:384:9: note: previous definition is here #define __cplusplus 201402L ^ In file included from disk.cpp:1: In file included from /usr/include/c++/v1/stdio.h:102: /usr/include/c++/v1/__config:327:20: error: cannot combine with previous 'char16_t' declaration specifier typedef __char16_t char16_t; ^ /usr/include/c++/v1/__config:328:20: error: cannot combine with previous 'char32_t' declaration specifier typedef __char32_t char32_t; ^ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/SearchAndRescue-1.4.0_6.log While here - Add license - Add missing dependencies
Notes
Notes: svn path=/head/; revision=476220
Diffstat (limited to 'games/searchandrescue')
-rw-r--r--games/searchandrescue/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/searchandrescue/Makefile b/games/searchandrescue/Makefile
index c2f4859749a5..bbafde09d9b7 100644
--- a/games/searchandrescue/Makefile
+++ b/games/searchandrescue/Makefile
@@ -3,18 +3,21 @@
PORTNAME= SearchAndRescue
PORTVERSION= 1.4.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME:tl}/Program/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= Flight simulator in which the player rescues people
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
RUN_DEPENDS= ${LOCALBASE}/share/searchandrescue/human.ini:games/searchandrescue-data
USE_SDL= mixer
-USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
-USE_GL= glu
+USE_XORG= ice sm x11 xau xdmcp xext xmu xpm xxf86vm
+USE_GL= gl glu
WRKSRC= ${WRKDIR}/${PORTNAME:tl}_${PORTVERSION}
PLIST_FILES= bin/${PORTNAME} \
@@ -30,6 +33,7 @@ post-patch:
-e 's,/usr/local,${LOCALBASE},g' \
-e 's,/usr/X11R6,${LOCALBASE},g' \
-e '/^CFLAGS = /s,=,= ${CFLAGS},g' \
+ -e '/^CPPFLAGS = /s, = .*, = ${CPPFLAGS},g' \
-e '/^CC = /s, = .*, = ${CC},' \
-e '/^CPP = /s, = .*, = ${CXX},' \
-e 's,-O6,,' \