aboutsummaryrefslogtreecommitdiff
path: root/games/shaaft
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 10:42:42 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 10:42:42 +0000
commit74b9ba3341d402abfc19af586c71c899e51b84b1 (patch)
tree0c804433cc464c704e8af7d78bca926d39deee5d /games/shaaft
parent4be0849487124c611e34d9c64644828c49344c80 (diff)
downloadports-74b9ba3341d402abfc19af586c71c899e51b84b1.tar.gz
ports-74b9ba3341d402abfc19af586c71c899e51b84b1.zip
- Fix build with clang
- Add DESKTOP_ENTRIES PR: ports/184813 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=336995
Diffstat (limited to 'games/shaaft')
-rw-r--r--games/shaaft/Makefile11
-rw-r--r--games/shaaft/files/patch-ResourceManager.cpp10
-rw-r--r--games/shaaft/files/patch-Value.hpp12
3 files changed, 30 insertions, 3 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 60ee2eee983f..4c72d351512a 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shaaft
PORTVERSION= 0.5.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= SF/criticalmass/OldFiles
DISTNAME= Shaaft-${PORTVERSION}
@@ -18,16 +18,21 @@ CONFLICTS= criticalmass-*
USE_BZIP2= yes
USE_SDL= mixer image sdl
USE_GL= yes
+USE_GCC= any
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-optimize
+
+CPPFLAGS+= $$(libpng-config --I_opts)
+LDFLAGS+= $$(libpng-config --L_opts)
+
DATADIR= ${PREFIX}/share/Shaaft
PLIST_FILES= bin/Packer bin/shaaft %%DATADIR%%/resource.dat \
man/man6/shaaft.6.gz
PLIST_DIRS= %%DATADIR%%
+DESKTOP_ENTRIES="Shaaft" "" "" "${PORTNAME}" "" ""
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
diff --git a/games/shaaft/files/patch-ResourceManager.cpp b/games/shaaft/files/patch-ResourceManager.cpp
new file mode 100644
index 000000000000..8414bfca04d4
--- /dev/null
+++ b/games/shaaft/files/patch-ResourceManager.cpp
@@ -0,0 +1,10 @@
+--- utils/ResourceManager.cpp.orig
++++ utils/ResourceManager.cpp
+@@ -13,6 +13,7 @@
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
+ #include <unistd.h>
++#include <cstring>
+ #include <iomanip>
+ #include <dirent.h>
+ #include <sys/types.h>
diff --git a/games/shaaft/files/patch-Value.hpp b/games/shaaft/files/patch-Value.hpp
new file mode 100644
index 000000000000..38c7fa726b3f
--- /dev/null
+++ b/games/shaaft/files/patch-Value.hpp
@@ -0,0 +1,12 @@
+--- utils/Value.hpp.orig 2013-11-30 21:16:05.000000000 +0900
++++ utils/Value.hpp 2013-11-30 21:16:35.000000000 +0900
+@@ -15,7 +15,8 @@
+ #ifndef _Value_hpp_
+ #define _Value_hpp_
+
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
+ #include <string>
+
+ #include <Trace.hpp>