aboutsummaryrefslogtreecommitdiff
path: root/games/shootingstar
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /games/shootingstar
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'games/shootingstar')
-rw-r--r--games/shootingstar/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/shootingstar/Makefile b/games/shootingstar/Makefile
index 92e798a916ac..588667190450 100644
--- a/games/shootingstar/Makefile
+++ b/games/shootingstar/Makefile
@@ -20,8 +20,8 @@ USE_GMAKE= yes
USE_GL= gl
USE_SDL= sdl mixer image
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>