aboutsummaryrefslogtreecommitdiff
path: root/games/ski
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-18 16:02:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-18 16:02:31 +0000
commitc729cef42cfbe5dc1a11df66af3ccb6176a4682a (patch)
tree11154b0f221456992d65df8e7768815ebf14ef11 /games/ski
parentb44a3949398804841d8a4e386a5adc112a224ae6 (diff)
- Remove PKGNAMEPREFIX, is stand alone application
- Rename from games/py-ski to games/ski - Update to 6.7 - Change master sites, add icon - Take maintainership - Add license (BSD3CLAUSE) - Change USE_PYTHON=yes to USE_PYTHON_RUN=yes - Support STAGEDIR - Change PLIST_FILE - Add DOCS and Option - Fix the usage of 'python' to get rid of the implicit lang/python dependency - Add files/ski.desktop PR: ports/185134 Submitted by: nemysis (self) Reviewed by: maintainer timeout (22 days)
Notes
Notes: svn path=/head/; revision=344917
Diffstat (limited to 'games/ski')
-rw-r--r--games/ski/Makefile43
-rw-r--r--games/ski/distinfo4
-rw-r--r--games/ski/pkg-descr11
3 files changed, 58 insertions, 0 deletions
diff --git a/games/ski/Makefile b/games/ski/Makefile
new file mode 100644
index 000000000000..e3a047c6a856
--- /dev/null
+++ b/games/ski/Makefile
@@ -0,0 +1,43 @@
+# Created by: janos.mohacsi@bsd.hu
+# $FreeBSD$
+
+PORTNAME= ski
+PORTVERSION= 6.7
+CATEGORIES= games python
+MASTER_SITES= http://catb.org/~esr/ski/
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Skiing simulation with curses interface in python
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${PREFIX}/man/man6/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/ski/distinfo b/games/ski/distinfo
new file mode 100644
index 000000000000..00de68070b7c
--- /dev/null
+++ b/games/ski/distinfo
@@ -0,0 +1,4 @@
+SHA256 (ski-6.7.tar.gz) = 7346f12fcb645e9fe3bd934c552af5e6a0ac149c84642a244d0ebd0405e6cf36
+SIZE (ski-6.7.tar.gz) = 12175
+SHA256 (ski.png) = 084423df9c6b37cad54bc4ac0eb0382dcb9f1efb8294e1f25bb49c7d0cc8aa33
+SIZE (ski.png) = 4314
diff --git a/games/ski/pkg-descr b/games/ski/pkg-descr
new file mode 100644
index 000000000000..b8aa9f112b37
--- /dev/null
+++ b/games/ski/pkg-descr
@@ -0,0 +1,11 @@
+Imagine you are skiing down an infinite slope, facing such hazards as
+trees, ice, bare ground, and the man-eating Yeti! Unfortunately, you have
+put your jet-powered skis on backwards, so you can't see ahead where you
+are going; only behind where you have been. However, you can turn to
+either side, jump or hop through the air, teleport through hyperspace,
+launch nuclear ICBMs, and cast spells to call the Fire Demon. And since
+the hazards occur in patches, you can skillfully outmaneuver them. A fun
+and very silly game that proves you don't need fancy graphical user
+interfaces to have a good time.
+
+WWW: http://catb.org/~esr/ski/