aboutsummaryrefslogtreecommitdiff
path: root/games/slade
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-03-01 15:56:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-03-01 15:56:22 +0000
commit26a50ad18950256713773cef5b8cc5bc6745e5fb (patch)
treea6dc4a67f21d3b69487ae71793c09c9b70d1760d /games/slade
parent2ad81ba92d4c420b70c8b537d481c6f49c38d621 (diff)
downloadports-26a50ad18950256713773cef5b8cc5bc6745e5fb.tar.gz
ports-26a50ad18950256713773cef5b8cc5bc6745e5fb.zip
- Update to the official release version 3.1.1
- Make MIDI playback via FluidSynth optional - Rename patches to chase new source structure Reported by: portscout
Notes
Notes: svn path=/head/; revision=409875
Diffstat (limited to 'games/slade')
-rw-r--r--games/slade/Makefile15
-rw-r--r--games/slade/distinfo4
-rw-r--r--games/slade/files/patch-src_CMakeLists.txt4
-rw-r--r--games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.cpp (renamed from games/slade/files/patch-src_AudioEntryPanel.cpp)52
-rw-r--r--games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.h (renamed from games/slade/files/patch-src_AudioEntryPanel.h)4
5 files changed, 43 insertions, 36 deletions
diff --git a/games/slade/Makefile b/games/slade/Makefile
index d13775ae1fdf..6bd87524d004 100644
--- a/games/slade/Makefile
+++ b/games/slade/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= slade
-DISTVERSION= 3.1.1_b3
+PORTVERSION= 3.1.1
CATEGORIES= games
MAINTAINER= danfe@FreeBSD.org
COMMENT= Modern editor for Doom-engine based games and source ports
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
- libsfml-system.so:${PORTSDIR}/devel/sfml \
+LIB_DEPENDS= libsfml-system.so:${PORTSDIR}/devel/sfml \
libftgl.so:${PORTSDIR}/graphics/ftgl \
libfreeimage.so:${PORTSDIR}/graphics/freeimage
@@ -24,8 +23,16 @@ USE_CXXSTD= c++11
PLIST_FILES= bin/slade share/slade3/slade.pk3
+OPTIONS_DEFINE= FLUIDSYNTH
+OPTIONS_DEFAULT= FLUIDSYNTH
+
+FLUIDSYNTH_DESC= MIDI playback support via FluidSynth
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
+FLUIDSYNTH_CMAKE_OFF= -DNO_FLUIDSYNTH:BOOL=ON
+
post-patch:
- @${REINPLACE_CMD} -e 's,"alsa","oss",' ${WRKSRC}/src/MIDIPlayer.cpp
+ @${REINPLACE_CMD} -e 's,"alsa","oss",' \
+ ${WRKSRC}/src/Audio/MIDIPlayer.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/games/slade/distinfo b/games/slade/distinfo
index 89d8eb42f172..532a8629ff09 100644
--- a/games/slade/distinfo
+++ b/games/slade/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sirjuddington-SLADE-3.1.1_b3_GH0.tar.gz) = e91c43484ee1cf916053e368112bb3b7f494d3ee93e48c7185f488461cd69fd8
-SIZE (sirjuddington-SLADE-3.1.1_b3_GH0.tar.gz) = 4395605
+SHA256 (sirjuddington-SLADE-3.1.1_GH0.tar.gz) = da7efc529823772b561a2405dbbc8b59467f3dfc98b9d753af9b1836d3a97529
+SIZE (sirjuddington-SLADE-3.1.1_GH0.tar.gz) = 4368790
diff --git a/games/slade/files/patch-src_CMakeLists.txt b/games/slade/files/patch-src_CMakeLists.txt
index 3286e7c8ba00..3f08cb8597b4 100644
--- a/games/slade/files/patch-src_CMakeLists.txt
+++ b/games/slade/files/patch-src_CMakeLists.txt
@@ -19,9 +19,9 @@
if(NOT ${GLEW_FOUND})
message(SEND_ERROR "GLEW required.")
endif()
--include_directories(${FREEIMAGE_INCLUDE_DIR} ${SFML_INCLUDE_DIR} ${FTGL_INCLUDE_DIR} ${FREETYPE_INCLUDE_DIRS} ${GLEW_INCLUDE_PATH} ${GTK2_INCLUDE_DIRS} . ./dumb)
+-include_directories(${FREEIMAGE_INCLUDE_DIR} ${SFML_INCLUDE_DIR} ${FTGL_INCLUDE_DIR} ${FREETYPE_INCLUDE_DIRS} ${GLEW_INCLUDE_PATH} ${GTK2_INCLUDE_DIRS} . ./External/dumb ./Application)
+# Put local `dumb' directory first to avoid conflict with `audio/dumb' port
-+include_directories(dumb ${FREEIMAGE_INCLUDE_DIR} ${SFML_INCLUDE_DIR} ${FTGL_INCLUDE_DIR} ${FREETYPE_INCLUDE_DIRS} ${GLEW_INCLUDE_PATH} ${GTK2_INCLUDE_DIRS} .)
++include_directories(External/dumb ${FREEIMAGE_INCLUDE_DIR} ${SFML_INCLUDE_DIR} ${FTGL_INCLUDE_DIR} ${FREETYPE_INCLUDE_DIRS} ${GLEW_INCLUDE_PATH} ${GTK2_INCLUDE_DIRS} . Application)
if (NOT NO_FLUIDSYNTH)
include_directories(${FLUIDSYNTH_INCLUDE_DIR})
diff --git a/games/slade/files/patch-src_AudioEntryPanel.cpp b/games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.cpp
index 21c0cc36bacb..432fec246577 100644
--- a/games/slade/files/patch-src_AudioEntryPanel.cpp
+++ b/games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.cpp
@@ -1,6 +1,6 @@
---- src/AudioEntryPanel.cpp.orig 2015-12-12 08:41:35 UTC
-+++ src/AudioEntryPanel.cpp
-@@ -89,15 +89,17 @@ AudioEntryPanel::AudioEntryPanel(wxWindo
+--- src/MainEditor/UI/EntryPanel/AudioEntryPanel.cpp.orig 2016-02-28 02:57:06 UTC
++++ src/MainEditor/UI/EntryPanel/AudioEntryPanel.cpp
+@@ -100,15 +100,17 @@ AudioEntryPanel::AudioEntryPanel(wxWindo
LOG_MESSAGE(3, "Windows Media Player installed, using wxMediaCtrl");
media_ctrl = new wxMediaCtrl(this, -1);
}
@@ -20,14 +20,14 @@
if (media_ctrl) sizer_main->Add(media_ctrl, 0);
#endif
sizer_main->Add(sizer_gb, 0, wxALIGN_CENTER);
-@@ -144,13 +146,17 @@ AudioEntryPanel::AudioEntryPanel(wxWindo
- sound.setVolume(snd_volume);
- music.setVolume(snd_volume);
+@@ -155,13 +157,17 @@ AudioEntryPanel::AudioEntryPanel(wxWindo
+ sound->setVolume(snd_volume);
+ music->setVolume(snd_volume);
theMIDIPlayer->setVolume(snd_volume);
+#if wxUSE_MEDIACTRL
if (media_ctrl) media_ctrl->SetVolume(snd_volume*0.01);
+#endif
- mod.setVolume(snd_volume);
+ mod->setVolume(snd_volume);
//theGMEPlayer->setVolume(snd_volume);
//theOPLPlayer->setVolume(snd_volume);
@@ -38,7 +38,7 @@
toolbar->Show(false);
// Bind events
-@@ -497,6 +503,7 @@ bool AudioEntryPanel::openMod(MemChunk&
+@@ -513,6 +519,7 @@ bool AudioEntryPanel::openMod(MemChunk&
*******************************************************************/
bool AudioEntryPanel::openMedia(string filename)
{
@@ -46,7 +46,7 @@
// Attempt to open with wxMediaCtrl
if (media_ctrl && media_ctrl->Load(filename))
{
-@@ -511,6 +518,7 @@ bool AudioEntryPanel::openMedia(string f
+@@ -527,6 +534,7 @@ bool AudioEntryPanel::openMedia(string f
return true;
}
@@ -54,8 +54,8 @@
return false;
}
-@@ -533,8 +541,10 @@ void AudioEntryPanel::startStream()
- mod.play(); break;
+@@ -549,8 +557,10 @@ void AudioEntryPanel::startStream()
+ mod->play(); break;
case AUTYPE_MIDI:
theMIDIPlayer->play(); break;
+#if wxUSE_MEDIACTRL
@@ -65,8 +65,8 @@
}
}
-@@ -553,8 +563,10 @@ void AudioEntryPanel::stopStream()
- mod.pause(); break;
+@@ -569,8 +579,10 @@ void AudioEntryPanel::stopStream()
+ mod->pause(); break;
case AUTYPE_MIDI:
theMIDIPlayer->pause(); break;
+#if wxUSE_MEDIACTRL
@@ -76,8 +76,8 @@
}
}
-@@ -574,8 +586,10 @@ void AudioEntryPanel::resetStream()
- mod.stop(); break;
+@@ -590,8 +602,10 @@ void AudioEntryPanel::resetStream()
+ mod->stop(); break;
case AUTYPE_MIDI:
theMIDIPlayer->stop(); break;
+#if wxUSE_MEDIACTRL
@@ -87,8 +87,8 @@
}
}
-@@ -757,8 +771,10 @@ void AudioEntryPanel::onTimer(wxTimerEve
- pos = mod.getPlayingOffset().asMilliseconds(); break;
+@@ -773,8 +787,10 @@ void AudioEntryPanel::onTimer(wxTimerEve
+ pos = mod->getPlayingOffset().asMilliseconds(); break;
case AUTYPE_MIDI:
pos = theMIDIPlayer->getPosition(); break;
+#if wxUSE_MEDIACTRL
@@ -98,18 +98,18 @@
}
// Set slider
-@@ -769,7 +785,9 @@ void AudioEntryPanel::onTimer(wxTimerEve
- (audio_type == AUTYPE_SOUND && sound.getStatus() == sf::Sound::Stopped) ||
- (audio_type == AUTYPE_MUSIC && music.getStatus() == sf::Sound::Stopped) ||
- (audio_type == AUTYPE_MOD && mod.getStatus() == sf::Sound::Stopped) ||
+@@ -785,7 +801,9 @@ void AudioEntryPanel::onTimer(wxTimerEve
+ (audio_type == AUTYPE_SOUND && sound->getStatus() == sf::Sound::Stopped) ||
+ (audio_type == AUTYPE_MUSIC && music->getStatus() == sf::Sound::Stopped) ||
+ (audio_type == AUTYPE_MOD && mod->getStatus() == sf::Sound::Stopped) ||
+#if wxUSE_MEDIACTRL
(audio_type == AUTYPE_MEDIA && media_ctrl && media_ctrl->GetState() == wxMEDIASTATE_STOPPED) ||
+#endif
(audio_type == AUTYPE_MIDI && theMIDIPlayer && !theMIDIPlayer->isPlaying()))
{
timer_seek->Stop();
-@@ -793,8 +811,10 @@ void AudioEntryPanel::onSliderSeekChange
- mod.setPlayingOffset(sf::milliseconds(slider_seek->GetValue())); break;
+@@ -809,8 +827,10 @@ void AudioEntryPanel::onSliderSeekChange
+ mod->setPlayingOffset(sf::milliseconds(slider_seek->GetValue())); break;
case AUTYPE_MIDI:
theMIDIPlayer->setPosition(slider_seek->GetValue()); break;
+#if wxUSE_MEDIACTRL
@@ -119,8 +119,8 @@
}
}
-@@ -813,8 +833,10 @@ void AudioEntryPanel::onSliderVolumeChan
- music.setVolume(snd_volume); break;
+@@ -829,8 +849,10 @@ void AudioEntryPanel::onSliderVolumeChan
+ music->setVolume(snd_volume); break;
case AUTYPE_MIDI:
theMIDIPlayer->setVolume(snd_volume); break;
+#if wxUSE_MEDIACTRL
@@ -128,5 +128,5 @@
if (media_ctrl) media_ctrl->SetVolume(snd_volume*0.01); break;
+#endif
case AUTYPE_MOD:
- mod.setVolume(snd_volume); break;
+ mod->setVolume(snd_volume); break;
}
diff --git a/games/slade/files/patch-src_AudioEntryPanel.h b/games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.h
index c5af7e8e0928..d71451a61c82 100644
--- a/games/slade/files/patch-src_AudioEntryPanel.h
+++ b/games/slade/files/patch-src_MainEditor_UI_EntryPanel_AudioEntryPanel.h
@@ -1,5 +1,5 @@
---- src/AudioEntryPanel.h.orig 2015-12-12 08:41:35 UTC
-+++ src/AudioEntryPanel.h
+--- src/MainEditor/UI/EntryPanel/AudioEntryPanel.h.orig 2015-12-12 08:41:35 UTC
++++ src/MainEditor/UI/EntryPanel/AudioEntryPanel.h
@@ -27,7 +27,9 @@ private:
wxSlider* slider_seek;
wxSlider* slider_volume;