aboutsummaryrefslogtreecommitdiff
path: root/games/sopwith/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-08-04 10:14:39 +0000
committerMark Pulford <markp@FreeBSD.org>2002-08-04 10:14:39 +0000
commit453f23b05a09986685253a3febd77863817555c0 (patch)
tree8952e4c1c89f4bb546ff01b735e98e08ac932a31 /games/sopwith/Makefile
parent1fc66763482634c417343c66ba2e3e0a1be106b2 (diff)
downloadports-453f23b05a09986685253a3febd77863817555c0.tar.gz
ports-453f23b05a09986685253a3febd77863817555c0.zip
Notes
Diffstat (limited to 'games/sopwith/Makefile')
-rw-r--r--games/sopwith/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/sopwith/Makefile b/games/sopwith/Makefile
new file mode 100644
index 000000000000..f52bb58669d8
--- /dev/null
+++ b/games/sopwith/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sopwith
+# Date created: 1 July 2002
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sopwith
+PORTVERSION= 1.4.0
+CATEGORIES= games
+MASTER_SITES= http://fraggle.despayre.org:81/stuffage/sopwith/
+DISTNAME= sdl_${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= edwin@mavetju.org
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/sdl11-config:${PORTSDIR}/devel/sdl12
+
+USE_GTK= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG=${PREFIX}/bin/sdl11-config
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^extern void getmode.*//' \
+ ${WRKSRC}/src/swtitle.h
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for F in FAQ doc/license.txt doc/keys.txt doc/origdoc.txt
+ ${INSTALL_DATA} ${WRKSRC}/${F} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>