aboutsummaryrefslogtreecommitdiff
path: root/games/spacezero
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 11:35:07 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 11:35:07 +0000
commitc1f7acfd3c9d8999334cd0c66435c7897a1a96d9 (patch)
tree2c7dbca18c2322ebc6562f6dde1334b45abf402e /games/spacezero
parent58183ca86720c0f4e0dcc8fbd94a2cd98d109728 (diff)
downloadports-c1f7acfd3c9d8999334cd0c66435c7897a1a96d9.tar.gz
ports-c1f7acfd3c9d8999334cd0c66435c7897a1a96d9.zip
Fix build with -fno-common
While here add dependencies reported as missing by make stage-qa.
Notes
Notes: svn path=/head/; revision=549576
Diffstat (limited to 'games/spacezero')
-rw-r--r--games/spacezero/Makefile7
-rw-r--r--games/spacezero/files/patch-include_snow.h11
-rw-r--r--games/spacezero/files/patch-src_snow.c10
-rw-r--r--games/spacezero/files/patch-src_spacecomm.c11
4 files changed, 37 insertions, 2 deletions
diff --git a/games/spacezero/Makefile b/games/spacezero/Makefile
index cd644912b93f..0fbe1d5da48d 100644
--- a/games/spacezero/Makefile
+++ b/games/spacezero/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spacezero
PORTVERSION= 0.86.00
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION:R}/
@@ -12,10 +13,12 @@ COMMENT= 2D Real Time Strategy space combat game
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
USES= openal:al,alut gnome pkgconfig xorg
-USE_GNOME= gtk20
+USE_GNOME= gtk20 cairo gdkpixbuf2
USE_XORG= x11
MAKE_ARGS= DATADIR="${DATADIR}" \
INSTALL_DATA_DIR="${DATADIR}"
diff --git a/games/spacezero/files/patch-include_snow.h b/games/spacezero/files/patch-include_snow.h
new file mode 100644
index 000000000000..56723a1180f8
--- /dev/null
+++ b/games/spacezero/files/patch-include_snow.h
@@ -0,0 +1,11 @@
+--- include/snow.h.orig 2013-12-18 11:52:33 UTC
++++ include/snow.h
+@@ -29,7 +29,7 @@
+ #include "objects.h"
+
+
+-struct Flake *flakes;
++extern struct Flake *flakes;
+
+ struct Flake{
+ float x,y;
diff --git a/games/spacezero/files/patch-src_snow.c b/games/spacezero/files/patch-src_snow.c
new file mode 100644
index 000000000000..a8a418176912
--- /dev/null
+++ b/games/spacezero/files/patch-src_snow.c
@@ -0,0 +1,10 @@
+--- src/snow.c.orig 2013-12-18 11:50:44 UTC
++++ src/snow.c
+@@ -38,6 +38,7 @@
+
+ #define NFLAKES 1000
+
++struct Flake *flakes;
+
+ void CreateSnow(int w,int h){
+ int i;
diff --git a/games/spacezero/files/patch-src_spacecomm.c b/games/spacezero/files/patch-src_spacecomm.c
new file mode 100644
index 000000000000..e775c188336d
--- /dev/null
+++ b/games/spacezero/files/patch-src_spacecomm.c
@@ -0,0 +1,11 @@
+--- src/spacecomm.c.orig 2013-12-18 18:53:03 UTC
++++ src/spacecomm.c
+@@ -63,7 +63,7 @@ SENDOBJUNMOD0
+ #define SENDORDERS 1
+
+ extern struct HeadObjList listheadobjs;
+-struct TextMessageList listheadtext;
++extern struct TextMessageList listheadtext;
+ extern struct CharListHead gameloglist; /* list of all game messages */
+ extern struct Window windowgamelog;
+ extern struct Habitat habitat;