aboutsummaryrefslogtreecommitdiff
path: root/games/species
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:50:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:50:05 +0000
commit7b470756d2ebba45fb5b76e9397b6ccc74d33d3a (patch)
tree5fbd7b00516b642ca992a77eddef85f6531bcd3b /games/species
parenteab3437cdb612058db7491fdb97d0feb29a7a3fb (diff)
downloadports-7b470756d2ebba45fb5b76e9397b6ccc74d33d3a.tar.gz
ports-7b470756d2ebba45fb5b76e9397b6ccc74d33d3a.zip
- FIx build with clang
- Support CXXFLAGS properly - Support COPYTREE_SHARE - Add LICENSE PR: 185332 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=340297
Diffstat (limited to 'games/species')
-rw-r--r--games/species/Makefile14
-rw-r--r--games/species/files/patch-Makefile8
-rw-r--r--games/species/files/patch-main.cpp6
3 files changed, 19 insertions, 9 deletions
diff --git a/games/species/Makefile b/games/species/Makefile
index b99743456699..123b8fd502b8 100644
--- a/games/species/Makefile
+++ b/games/species/Makefile
@@ -3,14 +3,16 @@
PORTNAME= species
PORTVERSION= 1.2d
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alepulver
+MASTER_SITES= LOCAL/alepulver
DISTNAME= redcoder
MAINTAINER= ports@FreeBSD.org
COMMENT= Corewars evolver - generates warriors using genetic algorithms
+LICENSE= GPLv1 # (or later)
+
USE_BZIP2= yes
USES= gmake dos2unix
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -25,11 +27,17 @@ VISITOOL_ALL_TARGET= all visitool
.include <bsd.port.options.mk>
+.if empty(PORT_OPTIONS:MVISITOOL)
+MAKE_ENV+= WX_CONFIG="${TRUE}"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${INSTALL_DATA} koen.* species.ini *.rc ${STAGEDIR}${DATADIR}
- cd ${WRKSRC} && ${CP} -r bench evolver_hill wilfiz ${STAGEDIR}${DATADIR}
+.for i in bench evolver_hill wilfiz
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${DATADIR})
+.endfor
.if ${PORT_OPTIONS:MVISITOOL}
${INSTALL_PROGRAM} ${WRKSRC}/visitool ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-visitool
.endif
diff --git a/games/species/files/patch-Makefile b/games/species/files/patch-Makefile
index 8bb63db5c344..c98c0f58487f 100644
--- a/games/species/files/patch-Makefile
+++ b/games/species/files/patch-Makefile
@@ -1,6 +1,6 @@
--- ./Makefile.orig Sun Feb 22 03:54:24 2004
+++ ./Makefile Wed Jan 16 18:29:09 2008
-@@ -1,8 +1,8 @@
+@@ -1,22 +1,22 @@
# makefile for species
-CC = gcc
@@ -10,9 +10,11 @@
+CPP = $(CXX)
+LD = $(CXX)
- OPT = -O4
+-OPT = -O4
++#OPT = -O4
DBG =
-@@ -11,12 +11,12 @@
+ # Recommended extra options for gcc:
+ #OPT += -fomit-frame-pointer -fforce-addr -finline-functions -funroll-loops
#OPT += -mcpu=i686 -march=i686
#DBG += -W -Wall -pedantic -ansi
diff --git a/games/species/files/patch-main.cpp b/games/species/files/patch-main.cpp
index b2f8bcbdd5c8..8b3059f0dafc 100644
--- a/games/species/files/patch-main.cpp
+++ b/games/species/files/patch-main.cpp
@@ -1,11 +1,11 @@
---- ./main.cpp.orig 2013-11-10 23:14:27.000000000 -0200
-+++ ./main.cpp 2013-11-10 23:14:37.000000000 -0200
+--- main.cpp.orig
++++ main.cpp
@@ -29,7 +29,7 @@
/***** main program entry point ********************/
-int main(int /*argc*/,char /***args*/) {
-+int main(int /*argc*/,char ** /*args*/) {
++int main(int /*argc*/,char **/*args*/) {
CKingdom kingdom;
#ifndef _WIN32