aboutsummaryrefslogtreecommitdiff
path: root/games/spring
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /games/spring
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412346
Diffstat (limited to 'games/spring')
-rw-r--r--games/spring/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index be891c1d9583..d5c947b6ef92 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -13,12 +13,12 @@ COMMENT= Project aiming to create a new and versatile RTS Engine
LICENSE= GPLv2
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libboost_thread.so:${PORTSDIR}/devel/boost-libs \
- libIL.so:${PORTSDIR}/graphics/devil \
- libogg.so:${PORTSDIR}/audio/libogg \
- libvorbis.so:${PORTSDIR}/audio/libvorbis
-BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libboost_thread.so:devel/boost-libs \
+ libIL.so:graphics/devil \
+ libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis
+BUILD_DEPENDS= 7z:archivers/p7zip
# XXX: it should be possible to build it on i386, investigate
# (currently link fails on undefined reference to __sync_fetch_and_add_8)
@@ -67,16 +67,16 @@ PR_DOWNLOADER_DESC= Map and game downloader
MANPAGES_CMAKE_ON= -DCREATE_MAN_PAGES:BOOL=true -DMANDIR:STRING="man"
MANPAGES_CMAKE_OFF= -DCREATE_MAN_PAGES:BOOL=false
-MANPAGES_BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip \
- asciidoc:${PORTSDIR}/textproc/asciidoc \
- xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
- bash:${PORTSDIR}/shells/bash
+MANPAGES_BUILD_DEPENDS= 7z:archivers/p7zip \
+ asciidoc:textproc/asciidoc \
+ xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl \
+ bash:shells/bash
MANPAGES_DOCS_ON= -DUSERDOCS_PLAIN:BOOL=true
MANPAGES_DOCS_OFF= -DUSERDOCS_PLAIN:BOOL=false
CXXFLAGS+= -Wno-deprecated # Too much noise
-PR_DOWNLOADER_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl
+PR_DOWNLOADER_LIB_DEPENDS=libcurl.so:ftp/curl
.include <bsd.port.pre.mk>