aboutsummaryrefslogtreecommitdiff
path: root/games/spring
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /games/spring
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'games/spring')
-rw-r--r--games/spring/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 2cbff5488613..6fa916bc6910 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -33,7 +33,7 @@ USE_LDCONFIG= yes
LLD_UNSAFE= yes
DOS2UNIX_GLOB= *.h *.hpp *.cpp
-USES= cmake compiler:c++11-lib dos2unix openal:al tar:lzma
+USES= cmake:insource compiler:c++11-lib dos2unix openal:al tar:lzma
USES+= desktop-file-utils shared-mime-info
CMAKE_ARGS= -DDATADIR:STRING="share/${PORTNAME}" \
-DAI_TYPES:STRING="NATIVE" \