aboutsummaryrefslogtreecommitdiff
path: root/games/spring
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-13 20:59:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-13 20:59:07 +0000
commitc794bd9e4be392193ff6ebcace59c35f4e87aa58 (patch)
tree296fc5839057b467d05d7593c4c67af372af6dea /games/spring
parentcc84c7c26bdf0fdfad0b6ab17b7f55f2c147e2ae (diff)
downloadports-c794bd9e4be392193ff6ebcace59c35f4e87aa58.tar.gz
ports-c794bd9e4be392193ff6ebcace59c35f4e87aa58.zip
- Bring back ONLY_FOR_ARCHS which was lost in the last update
- Mark BROKEN on pre-10.x
Notes
Notes: svn path=/head/; revision=386267
Diffstat (limited to 'games/spring')
-rw-r--r--games/spring/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 0bdda9641a01..0b3807956a2e 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -20,6 +20,11 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libvorbis.so:${PORTSDIR}/audio/libvorbis
BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+# XXX: it should be possible to build it on i386, investigate
+# (currently link fails on undefined reference to __sync_fetch_and_add_8)
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math and amd64 atomic ops
+
USE_SDL= sdl2
USE_GL= gl glu glew
USE_XORG= x11 xcursor
@@ -74,7 +79,11 @@ PR_DOWNLOADER_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl
check test xregression-test: build
${MAKE} -C ${WRKSRC} check
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+BROKEN= does not build (lack of proper c++11 support)
+.endif
.if defined(WITH_SYNC_DEBUG)
CFLAGS= # empty
@@ -111,4 +120,4 @@ post-patch:
pre-build:
cd ${WRKSRC} && ${MAKE} generateVersionFiles
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>