aboutsummaryrefslogtreecommitdiff
path: root/games/springlobby
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-01 14:46:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-01 14:46:28 +0000
commit01004500da9e52e7ec399ae7a0a0d2fa50fca465 (patch)
tree0a45b432fd624a69ab214ae1bbd939739647c1d6 /games/springlobby
parent7d2745f83381383e70bdaac59ece67f81eaf2385 (diff)
downloadports-01004500da9e52e7ec399ae7a0a0d2fa50fca465.tar.gz
ports-01004500da9e52e7ec399ae7a0a0d2fa50fca465.zip
Notes
Diffstat (limited to 'games/springlobby')
-rw-r--r--games/springlobby/Makefile27
-rw-r--r--games/springlobby/distinfo6
-rw-r--r--games/springlobby/files/patch-CMakeLists.txt29
-rw-r--r--games/springlobby/files/patch-cmake-package_config.cmake21
-rw-r--r--games/springlobby/pkg-plist6
5 files changed, 70 insertions, 19 deletions
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index e6f6ebe4b9af..ff582c2ee8ad 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= springlobby
-PORTVERSION= 0.29
-PORTREVISION= 1
+PORTVERSION= 0.61
CATEGORIES= games net
MASTER_SITES= http://www.springlobby.info/tarballs/ \
http://mirror.amdmi3.ru/distfiles/
@@ -16,16 +15,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform lobby client for the Spring RTS project
RUN_DEPENDS= spring:${PORTSDIR}/games/spring
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
USE_WX= 2.8+
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-
PORTDOCS= *
OPTIONS= TORRENT "Support automatic content downloads via torrent" on \
@@ -37,26 +34,26 @@ OPTIONS= TORRENT "Support automatic content downloads via torrent" on \
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CMAKE_ARGS+= -DOPTION_TRANSLATION_SUPPORT:BOOL=OFF
PLIST_SUB+= NLS="@comment "
.endif
.if !defined(WITHOUT_TORRENT)
-LIB_DEPENDS+= torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
+LIB_DEPENDS+= torrent-rasterbar.5:${PORTSDIR}/net-p2p/rblibtorrent-devel
.else
-CONFIGURE_ARGS+=--disable-torrent-system
+CMAKE_ARGS+= -DOPTION_TORRENT_SYSTEM:BOOL=OFF
.endif
.if !defined(WITHOUT_SOUND)
-USE_SDL+= sdl mixer
+USE_OPENAL= al
.else
-CONFIGURE_ARGS+=--disable-sound
+CMAKE_ARGS+= -DOPTION_SOUND:BOOL=OFF
.endif
-.if defined(NOPORTDOCS)
post-patch:
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docDATA||' \
- ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install.*FILES.*share\/doc/ d' \
+ ${WRKSRC}/CMakeLists.txt
.endif
.include <bsd.port.mk>
diff --git a/games/springlobby/distinfo b/games/springlobby/distinfo
index a2ceb97646eb..f096a80851ad 100644
--- a/games/springlobby/distinfo
+++ b/games/springlobby/distinfo
@@ -1,3 +1,3 @@
-MD5 (springlobby-0.29.tar.bz2) = a828e6fa09fb00007369d0ccb63c48cc
-SHA256 (springlobby-0.29.tar.bz2) = b2af3416e69a39a95dd99036ead04768ad5f724ca7af9548733cc29f2c8b2074
-SIZE (springlobby-0.29.tar.bz2) = 1807494
+MD5 (springlobby-0.61.tar.bz2) = 2307d8035ca9e0ae74145e2fe920e6db
+SHA256 (springlobby-0.61.tar.bz2) = 210e9e2cb4e769557c1f1ef4a692217e19850a65d5f29d8f4ab1ddc43ad9cdd5
+SIZE (springlobby-0.61.tar.bz2) = 1637977
diff --git a/games/springlobby/files/patch-CMakeLists.txt b/games/springlobby/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5156536d9117
--- /dev/null
+++ b/games/springlobby/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2010-01-26 22:06:42.000000000 +0300
++++ CMakeLists.txt 2010-01-31 05:34:06.000000000 +0300
+@@ -89,7 +89,6 @@
+ # Did we find wxWidgets ? This condition will fail for as long as the internal Vars do not point to the proper wxWidgets Configuration.
+ IF(wxWidgets_FOUND)
+ # Include wxWidgets macros
+- INCLUDE(${wxWidgets_USE_FILE})
+ IF(MSVC)
+ INCLUDE_DIRECTORIES( ${wxWidgets_ROOT_DIR}/include/msvc )
+ ENDIF(MSVC)
+@@ -97,6 +96,9 @@
+ SET(wxWidgets_RC_DIR ${wxWidgets_ROOT_DIR}/include)
+ ENDIF(MINGW)
+ INCLUDE_DIRECTORIES( ${wxWidgets_INCLUDE_DIRS} )
++ STRING(REGEX REPLACE ";" ";-D" wxWidgets_DEFINITIONS "${wxWidgets_DEFINITIONS}")
++ SET(wxWidgets_DEFINITIONS "-D${wxWidgets_DEFINITIONS}")
++ ADD_DEFINITIONS( ${wxWidgets_DEFINITIONS} )
+ ELSE(wxWidgets_FOUND)
+ # For Convenience. If we cannot continue, inform the User.
+ MESSAGE( FATAL_ERROR "wxWidgets library not found! Please install the package to continue")
+@@ -117,7 +119,7 @@
+
+ Add_Subdirectory( ${springlobby_SOURCE_DIR}/src/sound/alure )
+ INCLUDE_DIRECTORIES( ${springlobby_SOURCE_DIR}/src/sound/alure/include )
+- LINK_LIBRARIES( ${OPENAL_LIBRARY} ${springlobby_BINARY_DIR}/src/sound/alure/libalure.a )
++ LINK_LIBRARIES( ${OPENAL_LIBRARY} alure )
+ ELSE ( OPTION_SOUND )
+ # Disable sound.
+ ADD_DEFINITIONS( -DDISABLE_SOUND )
diff --git a/games/springlobby/files/patch-cmake-package_config.cmake b/games/springlobby/files/patch-cmake-package_config.cmake
new file mode 100644
index 000000000000..b058a735f8eb
--- /dev/null
+++ b/games/springlobby/files/patch-cmake-package_config.cmake
@@ -0,0 +1,21 @@
+--- cmake/package_config.cmake.orig 2010-01-26 22:06:42.000000000 +0300
++++ cmake/package_config.cmake 2010-01-31 05:26:15.000000000 +0300
+@@ -30,11 +30,6 @@
+ SET(CPACK_CMAKE_GENERATOR "Unix Makefiles")
+ SET(CPACK_GENERATOR "TBZ2;TGZ")
+ SET(CPACK_PACKAGE_FILE_NAME "springlobby-${SPRINGLOBBY_REV}")
+- IF( EXISTS ${springlobby_BINARY_DIR}/config.h )
+- INSTALL(FILES
+- ${springlobby_BINARY_DIR}/config.h
+- DESTINATION . OPTIONAL)
+- ENDIF( EXISTS ${springlobby_BINARY_DIR}/config.h )
+ ENDIF (WIN32)
+ SET(CPACK_INSTALL_CMAKE_PROJECTS "${CMAKE_BINARY_DIR};${CMAKE_PROJECT_NAME};ALL;/")
+ # SET(CPACK_OUTPUT_CONFIG_FILE "/home/andy/vtk/CMake-bin/CPackConfig.cmake")
+@@ -65,4 +60,4 @@
+ "^${springlobby_SOURCE_DIR}/m4/"
+ "^${springlobby_SOURCE_DIR}/obj/"
+ )
+-INCLUDE(CPack)
+\ No newline at end of file
++INCLUDE(CPack)
diff --git a/games/springlobby/pkg-plist b/games/springlobby/pkg-plist
index 5c29d2da361c..074b87928eed 100644
--- a/games/springlobby/pkg-plist
+++ b/games/springlobby/pkg-plist
@@ -1,6 +1,7 @@
bin/springlobby
bin/springsettings
share/applications/springlobby.desktop
+share/icons/hicolor/scalable/apps/springlobby.svg
%%NLS%%share/locale/ar/LC_MESSAGES/springlobby.mo
%%NLS%%share/locale/cs/LC_MESSAGES/springlobby.mo
%%NLS%%share/locale/da/LC_MESSAGES/springlobby.mo
@@ -20,5 +21,8 @@ share/applications/springlobby.desktop
%%NLS%%share/locale/zh_CN/LC_MESSAGES/springlobby.mo
%%NLS%%@dirrmtry share/locale/en_US/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/en_US
-share/pixmaps/springlobby.svg
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrmtry share/applications