aboutsummaryrefslogtreecommitdiff
path: root/games/stepmania-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-22 04:55:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-22 04:55:14 +0000
commit97f6c838b0c80b922f6269bad020440dec747e6a (patch)
tree3663fc07ef43e8448f01f4a110c5afda1fec7504 /games/stepmania-devel
parent08487bceb94f2e7039a2724161a82c0de4866f10 (diff)
downloadports-97f6c838b0c80b922f6269bad020440dec747e6a.tar.gz
ports-97f6c838b0c80b922f6269bad020440dec747e6a.zip
Notes
Diffstat (limited to 'games/stepmania-devel')
-rw-r--r--games/stepmania-devel/Makefile57
-rw-r--r--games/stepmania-devel/distinfo4
-rw-r--r--games/stepmania-devel/files/patch-StepmaniaCore.cmake44
-rw-r--r--games/stepmania-devel/files/patch-extern__CMakeLists.txt14
-rw-r--r--games/stepmania-devel/files/patch-src__CMakeData-arch.cmake11
-rw-r--r--games/stepmania-devel/files/patch-src__CMakeLists.txt19
-rw-r--r--games/stepmania-devel/pkg-plist25
7 files changed, 133 insertions, 41 deletions
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 46a5188ceb2e..005da38d8620 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stepmania
-PORTVERSION= 5.0.9
+PORTVERSION= 5.0.10
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= games
@@ -19,49 +19,39 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
USE_GITHUB= yes
-USES= autoreconf gmake iconv jpeg pathfix perl5 pkgconfig shebangfix
+USES= cmake:outsource iconv jpeg pathfix perl5 pkgconfig shebangfix
+SHEBANG_FILES= Utils/*.pl extern/zlib/zlib2ansi
USE_XORG= x11 xrandr xtst
USE_GL= glew
USE_PERL5= build
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-system-pcre \
- ${ICONV_CONFIGURE_ARG}
+CMAKE_ARGS= -DHAVE__MKDIR:BOOL=OFF
INSTALLS_ICONS= yes
-SHEBANG_FILES= Utils/*.pl \
- extern/zlib/zlib2ansi
-CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= ALSA DOCS FFMPEG GTK2 JACK MAD PULSEAUDIO VORBIS
+OPTIONS_DEFINE= ALSA DOCS FFMPEG GTK2 JACK MAD PULSEAUDIO VAAPI VORBIS
OPTIONS_DEFAULT= GTK2 MAD VORBIS
OPTIONS_SUB= yes
ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
-ALSA_CONFIGURE_ENV_OFF= ac_cv_lib_asound_snd_ctl_open=no
+ALSA_CMAKE_OFF= -DWITH_ALSA:BOOL=OFF
+FFMEPG_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-FFMPEG_CONFIGURE_ON= --with-system-ffmpeg
-FFMPEG_CONFIGURE_WITH= ffmpeg
+FFMPEG_CMAKE_ON= -DWITH_SYSTEM_FFMPEG:BOOL=ON
+FFMPEG_CMAKE_OFF= -DWITH_FFMPEG:BOOL=OFF
GTK2_USE= gnome=gtk20
-GTK2_CONFIGURE_ENABLE= gtk2
+GTK2_CMAKE_ON= -DWITH_GTK2:BOOL=ON
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
-JACK_CONFIGURE_WITH= jack
+JACK_CONFIGURE_OFF= -DWITH_JACK:BOOL=OFF
MAD_LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad
-MAD_CONFIGURE_WITH= mp3
+MAD_CMAKE_OFF= -DWITH_MP3:BOOL=OFF
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
-PULSEAUDIO_CONFIGURE_ENV_OFF= ac_cv_lib_pulse_pa_stream_new=no
+PULSEAUDIO_CMAKE_OFF= -DWITH_PULSE:BOOL=OFF
+VAAPI_LIB_DEPENDS= libva.so:${PORTSDIR}/multimedia/libva
+VAAPI_CMAKE_OFF= -DVA_FOUND:BOOL=OFF
VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
-VORBIS_CONFIGURE_WITH= vorbis
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^\(x86_64\)|amd64*\|\1| ; \
- s|-lpthread|-pthread|' ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e \
- 's|XLIBS+="-l|XLIBS="$$XLIBS -l|' ${WRKSRC}/autoconf/m4/x11.m4
- @${REINPLACE_CMD} -e \
- 's|-rdynamic|-Wl,-export-dynamic| ; \
- s|-finline-limit=300||' ${WRKSRC}/src/Makefile.am
+VORBIS_CMAKE_OFF= -DWITH_OGG:BOOL=OFF
pre-build:
@${MKDIR} ${WRKDIR}/wrappers
@@ -79,25 +69,24 @@ do-install:
${STAGEDIR}${PREFIX}/bin)
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/stepmania
.for i in Announcers BGAnimations BackgroundEffects BackgroundTransitions \
- Characters Courses Data NoteSkins Scripts Themes
+ Characters Courses Data NoteSkins Scripts Songs Themes
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} \
${STAGEDIR}${PREFIX}/lib/stepmania)
.endfor
- (cd ${WRKSRC}/src && ${INSTALL_PROGRAM} stepmania \
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} stepmania \
${STAGEDIR}${PREFIX}/lib/stepmania)
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/stepmania/Songs
(cd ${WRKSRC} && ${INSTALL_DATA} stepmania.desktop \
${STAGEDIR}${PREFIX}/share/applications)
@(cd ${WRKSRC} && ${COPYTREE_SHARE} icons \
${STAGEDIR}${PREFIX}/share)
+post-install-GTK2-on:
+ (cd ${WRKSRC} && ${INSTALL_LIB} GtkModule.so \
+ ${STAGEDIR}${PREFIX}/lib/stepmania)
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/Docs && ${COPYTREE_SHARE} . \
${STAGEDIR}${DOCSDIR} "! -name Licenses.txt")
-post-install-GTK2-on:
- (cd ${WRKSRC}/src && ${INSTALL_LIB} GtkModule.so \
- ${STAGEDIR}${PREFIX}/lib/stepmania)
-
.include <bsd.port.mk>
diff --git a/games/stepmania-devel/distinfo b/games/stepmania-devel/distinfo
index 8b5055eda098..bfc897703bd1 100644
--- a/games/stepmania-devel/distinfo
+++ b/games/stepmania-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stepmania-stepmania-v5.0.9_GH0.tar.gz) = 9f0566e36a578d499f6cbbb4e32b4d762182a991f6bc37df762c433976a80142
-SIZE (stepmania-stepmania-v5.0.9_GH0.tar.gz) = 197144798
+SHA256 (stepmania-stepmania-v5.0.10_GH0.tar.gz) = 8c6d375da82fede5752442c39254b76d3013102bb6f73f2fa8053f8e6fff0b70
+SIZE (stepmania-stepmania-v5.0.10_GH0.tar.gz) = 176559619
diff --git a/games/stepmania-devel/files/patch-StepmaniaCore.cmake b/games/stepmania-devel/files/patch-StepmaniaCore.cmake
new file mode 100644
index 000000000000..e0458c4d61a1
--- /dev/null
+++ b/games/stepmania-devel/files/patch-StepmaniaCore.cmake
@@ -0,0 +1,44 @@
+--- StepmaniaCore.cmake.orig 2015-10-30 15:55:52.000000000 +0900
++++ StepmaniaCore.cmake 2015-11-09 01:49:26.062972000 +0900
+@@ -308,7 +308,7 @@
+ MAC_FRAME_OPENGL
+ MAC_FRAME_QUICKTIME
+ )
+-elseif(LINUX)
++else()
+ if(WITH_GTK2)
+ find_package("GTK2" 2.0)
+ if (${GTK2_FOUND})
+@@ -350,26 +350,32 @@
+ set(HAX_XRANDR FALSE)
+ endif()
+
++ if(WITH_PULSE)
+ find_package(PulseAudio)
+ if (PULSEAUDIO_FOUND)
+ set(HAS_PULSE TRUE)
+ else()
+ set(HAS_PULSE FALSE)
+ endif()
++ endif()
+
++ if(WITH_ALSA)
+ find_package(ALSA)
+ if (ALSA_FOUND)
+ set(HAS_ALSA TRUE)
+ else()
+ set(HAS_ALSA FALSE)
+ endif()
++ endif()
+
++ if(WITH_JACK)
+ find_package(JACK)
+ if (JACK_FOUND)
+ set(HAS_JACK TRUE)
+ else()
+ set(HAS_JACK FALSE)
+ endif()
++ endif()
+
+ find_package(OSS)
+ if (OSS_FOUND)
diff --git a/games/stepmania-devel/files/patch-extern__CMakeLists.txt b/games/stepmania-devel/files/patch-extern__CMakeLists.txt
new file mode 100644
index 000000000000..189ecb8caf0b
--- /dev/null
+++ b/games/stepmania-devel/files/patch-extern__CMakeLists.txt
@@ -0,0 +1,14 @@
+--- extern/CMakeLists.txt.orig 2015-10-30 06:55:52 UTC
++++ extern/CMakeLists.txt
+@@ -1,5 +1,4 @@
+ include(CMakeProject-lua.cmake)
+-include(CMakeProject-glew.cmake)
+ include(CMakeProject-json.cmake)
+ if (APPLE OR MSVC)
+ include(CMakeProject-mad.cmake)
+@@ -16,5 +15,4 @@ if (NOT SYSTEM_PCRE_FOUND)
+ endif()
+ include(CMakeProject-tomcrypt.cmake)
+ include(CMakeProject-tommath.cmake)
+-include(CMakeProject-png.cmake)
+
diff --git a/games/stepmania-devel/files/patch-src__CMakeData-arch.cmake b/games/stepmania-devel/files/patch-src__CMakeData-arch.cmake
new file mode 100644
index 000000000000..cc243a981158
--- /dev/null
+++ b/games/stepmania-devel/files/patch-src__CMakeData-arch.cmake
@@ -0,0 +1,11 @@
+--- src/CMakeData-arch.cmake.orig 2015-10-30 06:55:52 UTC
++++ src/CMakeData-arch.cmake
+@@ -243,7 +243,7 @@ else()
+ list(APPEND SMDATA_ARCH_LOADING_HPP
+ "arch/LoadingWindow/LoadingWindow_MacOSX.h"
+ )
+- elseif(LINUX)
++ else()
+ if (GTK2_FOUND)
+ list(APPEND SMDATA_ARCH_LOADING_SRC
+ "arch/LoadingWindow/LoadingWindow_Gtk.cpp"
diff --git a/games/stepmania-devel/files/patch-src__CMakeLists.txt b/games/stepmania-devel/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..003da125319d
--- /dev/null
+++ b/games/stepmania-devel/files/patch-src__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- src/CMakeLists.txt.orig 2015-10-30 06:55:52 UTC
++++ src/CMakeLists.txt
+@@ -328,7 +328,7 @@ list(APPEND SMDATA_LINK_LIB
+ "zlib"
+ "jsoncpp"
+ "png"
+- "glew"
++ "GLEW"
+ "jpeg"
+ )
+
+@@ -521,7 +521,6 @@ list(APPEND SM_INCLUDE_DIRS
+ )
+ if(NOT APPLE)
+ list(APPEND SM_INCLUDE_DIRS
+- "${SM_EXTERN_DIR}/glew-1.5.8/include"
+ "${SM_EXTERN_DIR}/jsoncpp/include"
+ "${SM_EXTERN_DIR}/zlib"
+ )
diff --git a/games/stepmania-devel/pkg-plist b/games/stepmania-devel/pkg-plist
index baaa4b0cd75a..39a03e910419 100644
--- a/games/stepmania-devel/pkg-plist
+++ b/games/stepmania-devel/pkg-plist
@@ -1594,6 +1594,21 @@ lib/stepmania/NoteSkins/techno/default/metrics.ini
lib/stepmania/Scripts/32log.lua
lib/stepmania/Scripts/extend_table.lua
lib/stepmania/Scripts/unavailable_functions.lua
+lib/stepmania/Songs/StepMania 5/Goin' Under/Goin' Under.ogg
+lib/stepmania/Songs/StepMania 5/Goin' Under/Goin' Under.sm
+lib/stepmania/Songs/StepMania 5/Goin' Under/Goin' Under.ssc
+lib/stepmania/Songs/StepMania 5/Goin' Under/bg.png
+lib/stepmania/Songs/StepMania 5/Goin' Under/bn.png
+lib/stepmania/Songs/StepMania 5/MechaTribe Assault/Mecha-Tribe Assault.ogg
+lib/stepmania/Songs/StepMania 5/MechaTribe Assault/Mecha-Tribe Assault.ssc
+lib/stepmania/Songs/StepMania 5/MechaTribe Assault/mechatribeassaultbg.png
+lib/stepmania/Songs/StepMania 5/MechaTribe Assault/mechatribeassaultbn.png
+lib/stepmania/Songs/StepMania 5/MechaTribe Assault/wyde cd-tital.png
+lib/stepmania/Songs/StepMania 5/Springtime/Kommisar - Springtime.mp3
+lib/stepmania/Songs/StepMania 5/Springtime/Springtime.ssc
+lib/stepmania/Songs/StepMania 5/Springtime/spring.png
+lib/stepmania/Songs/StepMania 5/Springtime/springbn.png
+lib/stepmania/Songs/instructions.txt
lib/stepmania/Themes/_Installer/Languages/de.ini
lib/stepmania/Themes/_Installer/Languages/en.ini
lib/stepmania/Themes/_Installer/Languages/es.ini
@@ -1781,10 +1796,10 @@ lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji 9-stroke] 8x8 (double
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji 9] 8x8 (doubleres).png
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis1-stroke] 32x32 (doubleres).png
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis1] 32x32 (doubleres).png
-lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis2-stroke] 32x106 (doubleres).png
-lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis2] 32x106 (doubleres).png
-lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-regular-stroke] 32x61 (doubleres).png
-lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-regular] 32x61 (doubleres).png
+lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis2-stroke] 63x54 (doubleres).png
+lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-jis2] 63x54 (doubleres).png
+lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-regular-stroke] 48x41 (doubleres).png
+lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [kanji-regular] 48x41 (doubleres).png
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [main-stroke] 16x16 (doubleres).png
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [main] 16x16 (doubleres).png
lib/stepmania/Themes/_fallback/Fonts/_japanese 24px [symbol-stroke] 26x3 (doubleres).png
@@ -2850,6 +2865,7 @@ share/applications/stepmania.desktop
%%PORTDOCS%%%%DOCSDIR%%/Themerdocs/moremsg.txt
%%PORTDOCS%%%%DOCSDIR%%/Themerdocs/recommended_practices.txt
%%PORTDOCS%%%%DOCSDIR%%/Themerdocs/sm-ssc_themeguide.txt
+%%PORTDOCS%%%%DOCSDIR%%/Userdocs/Keymaps_ini_format.md
%%PORTDOCS%%%%DOCSDIR%%/Userdocs/bgchanges_format.txt
%%PORTDOCS%%%%DOCSDIR%%/Userdocs/sm5_beginner.txt
%%PORTDOCS%%%%DOCSDIR%%/credits.txt
@@ -2883,4 +2899,3 @@ share/icons/hicolor/64x64/apps/stepmania-ssc.png
share/icons/hicolor/72x72/apps/stepmania-ssc.png
share/icons/hicolor/96x96/apps/stepmania-ssc.png
share/icons/hicolor/scalable/apps/stepmania-ssc.svg
-@dir lib/stepmania/Songs