aboutsummaryrefslogtreecommitdiff
path: root/games/stockfish
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-12-21 19:23:45 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-12-21 19:23:45 +0000
commit4d401c32f0f020db67a60223b665c66f01851ae7 (patch)
treedb888c0c80fa10d5c37dc3e571d5e4b9a9bf512d /games/stockfish
parent79f177c3cccfaeb8c48ca1196b43ed649b59c609 (diff)
downloadports-4d401c32f0f020db67a60223b665c66f01851ae7.tar.gz
ports-4d401c32f0f020db67a60223b665c66f01851ae7.zip
games/stockfish: update to 10
Add LDFLAGS+= -fuse-ld=lld so the port builds regardless of the linker differences between FreeBSD releases. Not much in the release notes: http://blog.stockfishchess.org/post/180691011237/stockfish-10 SF 10 improves by about 50 ELO in self-play compared to SF 9. PR: 234035 Submitted by: execve@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=488019
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile5
-rw-r--r--games/stockfish/distinfo6
-rw-r--r--games/stockfish/files/patch-Makefile30
3 files changed, 24 insertions, 17 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index b976770ac089..215b9253780d 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= stockfish
-DISTVERSION= 9
-PORTREVISION= 1
+DISTVERSION= 10
DISTVERSIONSUFFIX= -src
CATEGORIES= games
MASTER_SITES= http://stockfish.s3.amazonaws.com/
@@ -28,6 +27,8 @@ MYARCH= ${ARCH}
MYCC= ${CHOSEN_COMPILER_TYPE}
TGTBLD= build
+LDFLAGS+= -fuse-ld=lld
+
PLIST_FILES= bin/stockfish
PORTDOCS= Readme.md
diff --git a/games/stockfish/distinfo b/games/stockfish/distinfo
index f2cc0364f512..3f3b19298961 100644
--- a/games/stockfish/distinfo
+++ b/games/stockfish/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1519331941
-SHA256 (stockfish-9-src.zip) = ba2e72d6973479c8c839c7f4a095d121829ebe8df39b71ebf291c84e5cb3e36e
-SIZE (stockfish-9-src.zip) = 171925
+TIMESTAMP = 1545156168
+SHA256 (stockfish-10-src.zip) = 29bd01e7407098aa9e851b82f6ea4bf2b46d26e9075a48a269cb1e40c582a073
+SIZE (stockfish-10-src.zip) = 174377
diff --git a/games/stockfish/files/patch-Makefile b/games/stockfish/files/patch-Makefile
index 48558c8086fa..6f772ec1fba8 100644
--- a/games/stockfish/files/patch-Makefile
+++ b/games/stockfish/files/patch-Makefile
@@ -1,15 +1,21 @@
---- Makefile.orig 2018-02-22 21:13:38 UTC
+--- Makefile.orig 2018-11-29 14:45:26 UTC
+++ Makefile
-@@ -205,10 +205,12 @@ ifeq ($(COMP),clang)
- CXX=clang++
- CXXFLAGS += -pedantic -Wextra -Wshadow
- ifneq ($(KERNEL),Darwin)
-+ifneq ($(KERNEL),FreeBSD)
- ifneq ($(KERNEL),OpenBSD)
- LDFLAGS += -latomic
+@@ -29,7 +29,7 @@ EXE = stockfish
endif
- endif
-+endif
- ifeq ($(ARCH),armv7)
- ifeq ($(OS),Android)
+ ### Installation dir definitions
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+ BINDIR = $(PREFIX)/bin
+
+ ### Built-in benchmark for pgo-builds
+@@ -211,7 +211,9 @@ ifeq ($(COMP),clang)
+
+ ifneq ($(KERNEL),Darwin)
+ ifneq ($(KERNEL),OpenBSD)
++ ifneq ($(KERNEL),FreeBSD)
+ LDFLAGS += -latomic
++ endif
+ endif
+ endif
+