aboutsummaryrefslogtreecommitdiff
path: root/games/stockfish
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2017-11-23 21:16:45 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2017-11-23 21:16:45 +0000
commit814fb65311f05d93ed5a138d9d8c474df6317c86 (patch)
treed38786abf51d7d7e022f3d1141a2ea3188ec87dc /games/stockfish
parent3a99e08e201fb030a7759df4ab03ddb1a5d0c338 (diff)
downloadports-814fb65311f05d93ed5a138d9d8c474df6317c86.tar.gz
ports-814fb65311f05d93ed5a138d9d8c474df6317c86.zip
Notes
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile23
-rw-r--r--games/stockfish/distinfo7
-rw-r--r--games/stockfish/files/patch-Makefile18
3 files changed, 27 insertions, 21 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index b39647f80c76..242c37937233 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -2,14 +2,11 @@
# $FreeBSD$
PORTNAME= stockfish
-PORTVERSION= 5
+PORTVERSION= 8
CATEGORIES= games
-MASTER_SITES= http://stockfish.s3.amazonaws.com/:src \
- http://cl.ly/3x333m0G173F/download/:book \
- http://www.execve.net/sf/:book
+MASTER_SITES= http://stockfish.s3.amazonaws.com/:src
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.zip:src \
- ${PORTNAME}-231-book.zip:book
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.zip:src
MAINTAINER= execve@gmail.com
COMMENT= Open source chess engine
@@ -24,25 +21,20 @@ BROKEN_mips64= Fails to build: cannot detect architecture
USES= compiler gmake zip
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-BOOKDIR= .
MYARCH= ${ARCH}
MYCC= ${COMPILER_TYPE}
TGTBLD= build
PLIST_FILES= bin/stockfish
-PORTDATA= Book.bin
-PORTDOCS= Readme.md polyglot.ini
+PORTDATA=
+PORTDOCS= Readme.md
-OPTIONS_DEFINE= DOCS POPCNT PROFILE
+OPTIONS_DEFINE= DOCS POPCNT
POPCNT_DESC= Use the POPCNT instruction
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPROFILE}
-TGTBLD= profile-build
-.endif
-
.if ${PORT_OPTIONS:MPOPCNT} && ${ARCH} != amd64
BROKEN= POPCNT compiles only on amd64
.endif
@@ -69,12 +61,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/${BOOKDIR}/${PORTDATA} ${STAGEDIR}${DATADIR}
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Readme.md ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/polyglot.ini ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/stockfish/distinfo b/games/stockfish/distinfo
index 4a404e28a863..f6d3e325c588 100644
--- a/games/stockfish/distinfo
+++ b/games/stockfish/distinfo
@@ -1,4 +1,3 @@
-SHA256 (stockfish-5-src.zip) = 071f5f9cc5c461e42462c3bc2f65ea96b8ca3de5048b927f82c609017c9392c2
-SIZE (stockfish-5-src.zip) = 319574
-SHA256 (stockfish-231-book.zip) = 07ee06bcd3fe1c5e0d90a2d0aede8bac2dd31d52fb4e1c9bc477bb5a8939e414
-SIZE (stockfish-231-book.zip) = 3479786
+TIMESTAMP = 1499583495
+SHA256 (stockfish-8-src.zip) = 7bad36f21f649ab24f6d7786bbb1b74b3e4037f165f32e3d42d1ae19c8874ce9
+SIZE (stockfish-8-src.zip) = 159017
diff --git a/games/stockfish/files/patch-Makefile b/games/stockfish/files/patch-Makefile
new file mode 100644
index 000000000000..ae49ffef9ec3
--- /dev/null
+++ b/games/stockfish/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 2017-07-09 16:40:08 UTC
++++ Makefile
+@@ -149,7 +149,6 @@ endif
+
+ ifeq ($(COMP),gcc)
+ comp=gcc
+- CXX=g++
+ CXXFLAGS += -pedantic -Wextra -Wshadow
+
+ ifeq ($(ARCH),armv7)
+@@ -198,7 +197,6 @@ endif
+
+ ifeq ($(COMP),clang)
+ comp=clang
+- CXX=clang++
+ CXXFLAGS += -pedantic -Wextra -Wshadow
+
+ ifeq ($(ARCH),armv7)