aboutsummaryrefslogtreecommitdiff
path: root/games/stockfish
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-24 07:48:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-24 07:48:16 +0000
commitbade7f6a6eae332353a0a2017d109a335bacc7b5 (patch)
tree81c9a191d2a8012263e0ea23f2edae1a379e2112 /games/stockfish
parenta56121587f803ece93264489f7cd08b447b94c3f (diff)
downloadports-bade7f6a6eae332353a0a2017d109a335bacc7b5.tar.gz
ports-bade7f6a6eae332353a0a2017d109a335bacc7b5.zip
games/stockfish: Update to 9
Additional port changes: * Changed to DISTVERSION * Added DISTVERSIONSUFFIX * Removed DISTNAME/DISTFILES * Added LICENSE_FILE * Removed WRKSRC * Added NO_WRKSUBDIR * Added WRKSRC_SUBDIR * Removed the blank PORTDATA * Updated the path in do-install-DOCS-on PR: 226129 Submitted by: m.ne@gmx.net Approved by: Gautam Mani <execve@gmail.com>, tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=462773
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile14
-rw-r--r--games/stockfish/distinfo6
-rw-r--r--games/stockfish/files/patch-Makefile25
3 files changed, 21 insertions, 24 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index 9dbb38e84117..46b68b24ea78 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= stockfish
-PORTVERSION= 8
+DISTVERSION= 9
+DISTVERSIONSUFFIX= -src
CATEGORIES= games
-MASTER_SITES= http://stockfish.s3.amazonaws.com/:src
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.zip:src
+MASTER_SITES= http://stockfish.s3.amazonaws.com/
MAINTAINER= execve@gmail.com
COMMENT= Open source chess engine
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../Copying.txt
NOT_FOR_ARCHS= sparc64
BROKEN_aarch64= Fails to build: cannot detect architecture
@@ -21,13 +21,13 @@ BROKEN_mips64= Fails to build: cannot detect architecture
USES= compiler gmake zip
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+NO_WRKSUBDIR= yes
+WRKSRC_SUBDIR= src
MYARCH= ${ARCH}
MYCC= ${COMPILER_TYPE}
TGTBLD= build
PLIST_FILES= bin/stockfish
-PORTDATA=
PORTDOCS= Readme.md
OPTIONS_DEFINE= DOCS POPCNT
@@ -65,6 +65,6 @@ do-install:
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Readme.md ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../Readme.md ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/stockfish/distinfo b/games/stockfish/distinfo
index f6d3e325c588..f2cc0364f512 100644
--- a/games/stockfish/distinfo
+++ b/games/stockfish/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499583495
-SHA256 (stockfish-8-src.zip) = 7bad36f21f649ab24f6d7786bbb1b74b3e4037f165f32e3d42d1ae19c8874ce9
-SIZE (stockfish-8-src.zip) = 159017
+TIMESTAMP = 1519331941
+SHA256 (stockfish-9-src.zip) = ba2e72d6973479c8c839c7f4a095d121829ebe8df39b71ebf291c84e5cb3e36e
+SIZE (stockfish-9-src.zip) = 171925
diff --git a/games/stockfish/files/patch-Makefile b/games/stockfish/files/patch-Makefile
index ae49ffef9ec3..48558c8086fa 100644
--- a/games/stockfish/files/patch-Makefile
+++ b/games/stockfish/files/patch-Makefile
@@ -1,18 +1,15 @@
---- Makefile.orig 2017-07-09 16:40:08 UTC
+--- Makefile.orig 2018-02-22 21:13:38 UTC
+++ Makefile
-@@ -149,7 +149,6 @@ endif
-
- ifeq ($(COMP),gcc)
- comp=gcc
-- CXX=g++
- CXXFLAGS += -pedantic -Wextra -Wshadow
-
- ifeq ($(ARCH),armv7)
-@@ -198,7 +197,6 @@ endif
-
- ifeq ($(COMP),clang)
- comp=clang
-- CXX=clang++
+@@ -205,10 +205,12 @@ ifeq ($(COMP),clang)
+ CXX=clang++
CXXFLAGS += -pedantic -Wextra -Wshadow
+ ifneq ($(KERNEL),Darwin)
++ifneq ($(KERNEL),FreeBSD)
+ ifneq ($(KERNEL),OpenBSD)
+ LDFLAGS += -latomic
+ endif
+ endif
++endif
ifeq ($(ARCH),armv7)
+ ifeq ($(OS),Android)