aboutsummaryrefslogtreecommitdiff
path: root/games/stockfish
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-09-24 17:17:03 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-09-24 17:17:03 +0000
commitecc0a454ba0591e518ef5126677b65278406f9e5 (patch)
treee838e9db0d50d691eab19863f09c1615c92fdca6 /games/stockfish
parent0dc07ee37adbacfbbd1ace6781e5a01c194cebac (diff)
downloadports-ecc0a454ba0591e518ef5126677b65278406f9e5.tar.gz
ports-ecc0a454ba0591e518ef5126677b65278406f9e5.zip
Notes
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile42
-rw-r--r--games/stockfish/distinfo2
-rw-r--r--games/stockfish/pkg-descr7
-rw-r--r--games/stockfish/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
new file mode 100644
index 000000000000..2531279c02c9
--- /dev/null
+++ b/games/stockfish/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: stockfish
+# Date created: Apr 21 2011
+# Whom: Gautam Mani <execve@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stockfish
+PORTVERSION= 2.1.1
+CATEGORIES= games
+MASTER_SITES= http://f.cl.ly/items/3E1y252w3q0R3C050k01/
+DISTNAME= stockfish-211-ja
+
+MAINTAINER= execve@gmail.com
+COMMENT= Open source chess engine
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_GMAKE= yes
+MYARCH= ${ARCH}
+
+ALL_TARGET= build ARCH=${MYARCH}
+
+.include <bsd.port.pre.mk>
+
+# workaround the ARCH usage in the stockfish Makefile
+.if ${MYARCH} == "i386"
+MYARCH= x86-32
+ALL_TARGET= build ARCH=${MYARCH}
+.endif
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${PREFIX}/bin/stockfish
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Readme.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/polyglot.ini ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/stockfish/distinfo b/games/stockfish/distinfo
new file mode 100644
index 000000000000..9370ee11f24b
--- /dev/null
+++ b/games/stockfish/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stockfish-211-ja.zip) = bbc01a873183d213903260e4262fbee3cc79f51c62a601fce6b66a405b13d93a
+SIZE (stockfish-211-ja.zip) = 2623630
diff --git a/games/stockfish/pkg-descr b/games/stockfish/pkg-descr
new file mode 100644
index 000000000000..662d4c45f276
--- /dev/null
+++ b/games/stockfish/pkg-descr
@@ -0,0 +1,7 @@
+Stockfish is an open-source UCI chess engine based on Glaurung.
+Stockfish is an alpha-beta searcher and uses a bitboard representation.
+
+Stockfish is free and uses the GPL license. You can download, read,
+and modify the source code.
+
+WWW: http://www.stockfishchess.com/
diff --git a/games/stockfish/pkg-plist b/games/stockfish/pkg-plist
new file mode 100644
index 000000000000..f963cd541a13
--- /dev/null
+++ b/games/stockfish/pkg-plist
@@ -0,0 +1,4 @@
+bin/stockfish
+%%DOCSDIR%%/Readme.txt
+%%DOCSDIR%%/polyglot.ini
+@dirrm %%DOCSDIR%%