aboutsummaryrefslogtreecommitdiff
path: root/games/stonesoup
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2018-09-24 04:21:08 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2018-09-24 04:21:08 +0000
commit195f0b43ad52634f806ad684e0c9a29055175888 (patch)
tree1d5b869c9c324560344173d1a010e84c174068a6 /games/stonesoup
parentbd76d416957fadc7083a657774719c56e564c6d9 (diff)
downloadports-195f0b43ad52634f806ad684e0c9a29055175888.tar.gz
ports-195f0b43ad52634f806ad684e0c9a29055175888.zip
Notes
Diffstat (limited to 'games/stonesoup')
-rw-r--r--games/stonesoup/Makefile3
-rw-r--r--games/stonesoup/distinfo6
-rw-r--r--games/stonesoup/files/patch-initfile.cc20
-rw-r--r--games/stonesoup/files/patch-wiz-you.cc15
4 files changed, 25 insertions, 19 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index f8481efbba8f..b4e10a818a74 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stonesoup
-PORTVERSION= 0.22.0
+PORTVERSION= 0.22.1
CATEGORIES= games
MAINTAINER= lifanov@FreeBSD.org
@@ -55,6 +55,7 @@ LUA_DESC= Bindings for LUA user scripts
SDL_CONFLICTS= ${PORTNAME}-[0-9]*
SDL_USE= sdl=sdl2,image2,mixer2 gl=gl,glu
+SDL_USES= gl
SDL_USES_OFF= ncurses
SDL_MAKE_ARGS= TILES=y SOUND=y
SDL_BUILD_DEPENDS= \
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index 98d99a53ba7d..3acda66d5f2e 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534118359
-SHA256 (crawl-crawl-0.22.0_GH0.tar.gz) = cdffb393955e67f2aded9194f6dcd6875ed2e2dce2a5cac1ad950d699456f242
-SIZE (crawl-crawl-0.22.0_GH0.tar.gz) = 12337662
+TIMESTAMP = 1537762805
+SHA256 (crawl-crawl-0.22.1_GH0.tar.gz) = 15217cd5cb0ae4c8fbae7343712c17d57cc770bde21fd6daa0e968780e477bab
+SIZE (crawl-crawl-0.22.1_GH0.tar.gz) = 12355516
diff --git a/games/stonesoup/files/patch-initfile.cc b/games/stonesoup/files/patch-initfile.cc
new file mode 100644
index 000000000000..66f12961e168
--- /dev/null
+++ b/games/stonesoup/files/patch-initfile.cc
@@ -0,0 +1,20 @@
+--- initfile.cc.orig 2018-09-24 03:59:12 UTC
++++ initfile.cc
+@@ -4225,7 +4225,7 @@ static void _bones_rewrite(const string
+ if (dups)
+ cout << ", " << dups << " duplicates removed";
+ cout << "\n";
+- unlink(filename.c_str());
++ unlink_u(filename.c_str());
+ _write_bones(filename, out);
+ }
+ else
+@@ -4241,7 +4241,7 @@ static void _bones_merge(const vector<st
+ out.insert(out.end(), ghosts.begin(), ghosts.end());
+ }
+ if (file_exists(out_name))
+- unlink(out_name.c_str());
++ unlink_u(out_name.c_str());
+ if (out.size() == 0)
+ cout << "Writing empty bones file";
+ else
diff --git a/games/stonesoup/files/patch-wiz-you.cc b/games/stonesoup/files/patch-wiz-you.cc
deleted file mode 100644
index 41a6ec97dc41..000000000000
--- a/games/stonesoup/files/patch-wiz-you.cc
+++ /dev/null
@@ -1,15 +0,0 @@
---- wiz-you.cc.orig 2016-06-29 18:11:14 UTC
-+++ wiz-you.cc
-@@ -1126,6 +1126,7 @@ void wizard_join_religion()
- }
- }
-
-+#ifdef WIZARD
- void wizard_xom_acts()
- {
- char specs[80];
-@@ -1158,3 +1159,4 @@ void wizard_xom_acts()
- dprf("Okay, Xom is doing '%s'.", xom_effect_to_name(event).c_str());
- xom_take_action(event, severity);
- }
-+#endif