aboutsummaryrefslogtreecommitdiff
path: root/games/stransball2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 01:13:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 01:13:22 +0000
commit5ec2e54d7ca2f1715467814435584c757013dff8 (patch)
treec03cbf1cfe1945a76ab3d887df97012f28b2c099 /games/stransball2
parentd68b9eb10215bea90efaafb758bd17db90283dd9 (diff)
downloadports-5ec2e54d7ca2f1715467814435584c757013dff8.tar.gz
ports-5ec2e54d7ca2f1715467814435584c757013dff8.zip
- Support staging
- Convert USE_GMAKE to USES - Use new LIB_DEPENDS syntax - Fix DOS2UNIX to not corrupt unrelated files
Notes
Notes: svn path=/head/; revision=337115
Diffstat (limited to 'games/stransball2')
-rw-r--r--games/stransball2/Makefile27
-rw-r--r--games/stransball2/pkg-plist57
2 files changed, 11 insertions, 73 deletions
diff --git a/games/stransball2/Makefile b/games/stransball2/Makefile
index 83f476008466..ccc1887d2bb6 100644
--- a/games/stransball2/Makefile
+++ b/games/stransball2/Makefile
@@ -12,19 +12,20 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:C/\.//}-linux
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A sequel to Transball and Transball 2 THRUST-type games
-LIB_DEPENDS= SGE:${PORTSDIR}/devel/sdl_sge
+LIB_DEPENDS= libSGE.so:${PORTSDIR}/devel/sdl_sge
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake dos2unix
+DOS2UNIX_FILES= sources/main.cpp
USE_SDL= sdl image mixer sound
-USE_DOS2UNIX= yes
BUILD_WRKSRC= ${WRKSRC}/sources
-PORTDOCS= readme.txt
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
+PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-extract:
@${RM} -f ${WRKSRC}/sound/WS_FTP.LOG
@@ -36,15 +37,9 @@ post-patch:
s|"maps"|"${DATADIR}/maps"|g'
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/stransball2 ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${DATADIR}
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/stransball2/pkg-plist b/games/stransball2/pkg-plist
deleted file mode 100644
index 6693362343dd..000000000000
--- a/games/stransball2/pkg-plist
+++ /dev/null
@@ -1,57 +0,0 @@
-bin/stransball2
-%%DATADIR%%/demos/demo1.rpl
-%%DATADIR%%/demos/demo2.rpl
-%%DATADIR%%/demos/demo3.rpl
-%%DATADIR%%/demos/demo4.rpl
-%%DATADIR%%/graphics/brain.pcx
-%%DATADIR%%/graphics/font3.pcx
-%%DATADIR%%/graphics/tiles-mask.pcx
-%%DATADIR%%/graphics/tiles.pcx
-%%DATADIR%%/graphics/tittle.pcx
-%%DATADIR%%/maps/canons.map
-%%DATADIR%%/maps/map1.map
-%%DATADIR%%/maps/map10.map
-%%DATADIR%%/maps/map11.map
-%%DATADIR%%/maps/map12.map
-%%DATADIR%%/maps/map13.map
-%%DATADIR%%/maps/map14.map
-%%DATADIR%%/maps/map2.map
-%%DATADIR%%/maps/map3.map
-%%DATADIR%%/maps/map4.map
-%%DATADIR%%/maps/map5.map
-%%DATADIR%%/maps/map6.map
-%%DATADIR%%/maps/map7.map
-%%DATADIR%%/maps/map8.map
-%%DATADIR%%/maps/map9.map
-%%DATADIR%%/maps/sample-pack.lp
-%%DATADIR%%/maps/sample-pack/WS_FTP.LOG
-%%DATADIR%%/maps/sample-pack/directional.map
-%%DATADIR%%/maps/sample-pack/directional2.map
-%%DATADIR%%/maps/sample-pack/heavy-snow.map
-%%DATADIR%%/maps/second-assault.lp
-%%DATADIR%%/maps/second-assault/WS_FTP.LOG
-%%DATADIR%%/maps/second-assault/sa-map1.map
-%%DATADIR%%/maps/second-assault/sa-map2.map
-%%DATADIR%%/maps/second-assault/sa-map3.map
-%%DATADIR%%/maps/second-assault/sa-map4.map
-%%DATADIR%%/maps/second-assault/sa-map5.map
-%%DATADIR%%/maps/second-assault/sa-map6.map
-%%DATADIR%%/maps/second-assault/sa-map7.map
-%%DATADIR%%/maps/second-assault/sa-map8.map
-%%DATADIR%%/maps/transball.lp
-%%DATADIR%%/sound/enemyhit.wav
-%%DATADIR%%/sound/explosion.wav
-%%DATADIR%%/sound/fuel.wav
-%%DATADIR%%/sound/shipshot.wav
-%%DATADIR%%/sound/shot.wav
-%%DATADIR%%/sound/start.wav
-%%DATADIR%%/sound/switch.wav
-%%DATADIR%%/sound/takeball.wav
-%%DATADIR%%/sound/thrust.wav
-@dirrm %%DATADIR%%/sound
-@dirrm %%DATADIR%%/maps/second-assault
-@dirrm %%DATADIR%%/maps/sample-pack
-@dirrm %%DATADIR%%/maps
-@dirrm %%DATADIR%%/graphics
-@dirrm %%DATADIR%%/demos
-@dirrm %%DATADIR%%