aboutsummaryrefslogtreecommitdiff
path: root/games/stransball2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
commitdaffe00d4a57c0ef6a21947a8121b8d233d8d3a5 (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /games/stransball2
parent51498efaebaad1106dcf0d3f70c8feaa14c411ee (diff)
downloadports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.tar.gz
ports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful - Canonicalize patch names - Fix DOS line endings in patch files
Notes
Notes: svn path=/head/; revision=322840
Diffstat (limited to 'games/stransball2')
-rw-r--r--games/stransball2/Makefile3
-rw-r--r--games/stransball2/files/patch-sources-main.cpp57
2 files changed, 31 insertions, 29 deletions
diff --git a/games/stransball2/Makefile b/games/stransball2/Makefile
index 0f1b637381fa..7a5958863274 100644
--- a/games/stransball2/Makefile
+++ b/games/stransball2/Makefile
@@ -12,11 +12,12 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:C/\.//}-linux
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A sequel to Transball and Transball 2 THRUST-type games
-LIB_DEPENDS= SGE.0:${PORTSDIR}/devel/sdl_sge
+LIB_DEPENDS= SGE:${PORTSDIR}/devel/sdl_sge
USE_ZIP= yes
USE_GMAKE= yes
USE_SDL= sdl image mixer sound
+USE_DOS2UNIX= yes
MAKE_JOBS_SAFE= yes
BUILD_WRKSRC= ${WRKSRC}/sources
diff --git a/games/stransball2/files/patch-sources-main.cpp b/games/stransball2/files/patch-sources-main.cpp
index 1152ae654b70..858d4995eaaf 100644
--- a/games/stransball2/files/patch-sources-main.cpp
+++ b/games/stransball2/files/patch-sources-main.cpp
@@ -1,31 +1,32 @@
--- sources/main.cpp.orig 2005-04-16 21:16:54.000000000 +0400
+++ sources/main.cpp 2008-04-07 01:37:52.000000000 +0400
-@@ -6,6 +6,8 @@
- #include <time.h>
- #endif
-
-+#include <sys/types.h>
-+#include <sys/stat.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include "SDL/SDL.h"
+@@ -6,6 +6,9 @@
+ #include <time.h>
+ #endif
+
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "SDL/SDL.h"
@@ -126,6 +128,19 @@
- setupTickCount();
- #endif
-
-+ if (chdir(getenv("HOME")) != 0)
-+ return 0;
-+
-+ struct stat sb;
-+ if (stat(".stransball2", &sb) != 0 &&
-+ (mkdir(".stransball2", 0755) != 0 ||
-+ mkdir(".stransball2/high", 0755) != 0 ||
-+ mkdir(".stransball2/replays", 0755) != 0))
-+ return 0;
-+
-+ if (chdir(".stransball2") != 0)
-+ return 0;
-+
- int time,act_time;
- SDL_Event event;
- bool quit = false;
+ setupTickCount();
+ #endif
+
++ if (chdir(getenv("HOME")) != 0)
++ return 0;
++
++ struct stat sb;
++ if (stat(".stransball2", &sb) != 0 &&
++ (mkdir(".stransball2", 0755) != 0 ||
++ mkdir(".stransball2/high", 0755) != 0 ||
++ mkdir(".stransball2/replays", 0755) != 0))
++ return 0;
++
++ if (chdir(".stransball2") != 0)
++ return 0;
++
+ int time,act_time;
+ SDL_Event event;
+ bool quit = false;