aboutsummaryrefslogtreecommitdiff
path: root/games/stroq
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-14 22:32:13 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-14 22:32:13 +0000
commite0226e49cb90bf4fe93b2c45e48dcd6e76f42c42 (patch)
tree2d07f02a6c20cfad1336d987c816c97edf0bd36c /games/stroq
parent6783597ccc80608a9bafa728532f927fb26bb204 (diff)
downloadports-e0226e49cb90bf4fe93b2c45e48dcd6e76f42c42.tar.gz
ports-e0226e49cb90bf4fe93b2c45e48dcd6e76f42c42.zip
Notes
Diffstat (limited to 'games/stroq')
-rw-r--r--games/stroq/Makefile44
-rw-r--r--games/stroq/distinfo3
-rw-r--r--games/stroq/pkg-descr5
-rw-r--r--games/stroq/pkg-plist3
4 files changed, 55 insertions, 0 deletions
diff --git a/games/stroq/Makefile b/games/stroq/Makefile
new file mode 100644
index 000000000000..930577eede83
--- /dev/null
+++ b/games/stroq/Makefile
@@ -0,0 +1,44 @@
+# New ports collection Makefile for: stroq
+# Date created: 13 Jan 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+
+PORTNAME= stroq
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= stroq
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Flip tiles to make rows of the same color
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+USE_REINPLACE= yes
+MAKE_ENV= QTDIR="${QT_PREFIX}"
+
+QMAKE= qmake
+QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${QMAKE} -project; \
+ ${SETENV} ${MAKE_ENV} QMAKESPEC=${QMAKESPEC} ${QMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-${PORTVERSION} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/stroq/distinfo b/games/stroq/distinfo
new file mode 100644
index 000000000000..ab0a61a94bcc
--- /dev/null
+++ b/games/stroq/distinfo
@@ -0,0 +1,3 @@
+MD5 (stroq-0.2.tar.bz2) = 4009066a3a01f917a08f0fe374a316c3
+SHA256 (stroq-0.2.tar.bz2) = cb806991678254ae8e3b6283be43837964b0fa66545b09364348569b803e6180
+SIZE (stroq-0.2.tar.bz2) = 644711
diff --git a/games/stroq/pkg-descr b/games/stroq/pkg-descr
new file mode 100644
index 000000000000..5bc5f9a431ab
--- /dev/null
+++ b/games/stroq/pkg-descr
@@ -0,0 +1,5 @@
+StroQ is an addictive puzzle game where you have to flip white and
+black tiles in order to form rows of the same color with a single
+stroke of your mouse.
+
+WWW: http://stroq.sourceforge.net
diff --git a/games/stroq/pkg-plist b/games/stroq/pkg-plist
new file mode 100644
index 000000000000..55eb6c3f5b24
--- /dev/null
+++ b/games/stroq/pkg-plist
@@ -0,0 +1,3 @@
+bin/stroq
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%