aboutsummaryrefslogtreecommitdiff
path: root/games/super_mario_bros_python/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-05-01 21:48:33 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-05-01 21:48:33 +0000
commitb050741c540c76df1fee94d97256392e6d727c7f (patch)
treebc171ad4b19db079919a166506b3da9e3d9dd80a /games/super_mario_bros_python/Makefile
parent8f1c2dcdc8cde9473e655e25658b212f55aa9145 (diff)
Notes
Diffstat (limited to 'games/super_mario_bros_python/Makefile')
-rw-r--r--games/super_mario_bros_python/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/games/super_mario_bros_python/Makefile b/games/super_mario_bros_python/Makefile
index 6f0ad84001a6..1255b1ba0d1d 100644
--- a/games/super_mario_bros_python/Makefile
+++ b/games/super_mario_bros_python/Makefile
@@ -21,11 +21,13 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/Super-Mario-Bros-Python-v${DISTVERSION}release
-USES= zip
+USES= shebangfix zip
+SHEBANG_FILES= gamelib/*.py
+python_OLD_CMD?= /usr/bin/env python
+python_CMD?= ${PYTHON_CMD}
USE_PYTHON= 2
PORTDOCS= changelog.txt readme.txt
-
OPTIONS_DEFINE= DOCS
SUB_FILES= ${PORTNAME}
@@ -34,7 +36,9 @@ DESKTOP_ENTRIES="Super Mario Bros. Python" "" ${PORTNAME} \
"${PORTNAME}" "Game;ArcadeGame;" ""
post-patch:
- @${REINPLACE_CMD} -i '' -e '1d' ${WRKSRC}/start.py
+ @${REINPLACE_CMD} -i '' -e '1d' \
+ -e 's|#! /usr/bin/env python|#!${PYTHON_CMD}|' \
+ ${WRKSRC}/start.py
@${FIND} ${WRKSRC} -name "*.py~" -delete -or -name "*.sav~" -delete
do-build:
@@ -49,9 +53,8 @@ do-install:
.for d in data gamelib
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
-
-.for d in *.py *.pyc *.pyo
- @(cd ${WRKSRC} ; ${INSTALL_SCRIPT} ${d} ${STAGEDIR}${DATADIR})
+.for f in *.py *.pyc *.pyo
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
.endfor
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \