aboutsummaryrefslogtreecommitdiff
path: root/games/supertux-devel/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-09-11 13:06:31 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-09-11 13:06:31 +0000
commit3a5c87425fbf975b355be1c9d2a26faa8367c672 (patch)
tree44f5fb28f82e0e0bfcedf1c3388042d19339a8a8 /games/supertux-devel/Makefile
parent33dfa3ec0fdea1483f532e356b501329402f7660 (diff)
downloadports-3a5c87425fbf975b355be1c9d2a26faa8367c672.tar.gz
ports-3a5c87425fbf975b355be1c9d2a26faa8367c672.zip
Notes
Diffstat (limited to 'games/supertux-devel/Makefile')
-rw-r--r--games/supertux-devel/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/supertux-devel/Makefile b/games/supertux-devel/Makefile
new file mode 100644
index 000000000000..aa16169cf435
--- /dev/null
+++ b/games/supertux-devel/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: supertux
+# Date created: 2004-04-17
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supertux
+PORTVERSION= 0.1.3
+PORTREVISION= 9
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
+
+USE_BZIP2= yes
+USE_SDL= image mixer
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,Menu::,,' ${WRKSRC}/src/menu.h
+
+.include <bsd.port.mk>