aboutsummaryrefslogtreecommitdiff
path: root/games/supertux/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-17 05:45:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-17 05:45:46 +0000
commit3d17c00e25455c971947afcffe97b26858260c22 (patch)
tree1802f03d682da58e4fecd7549a0ad1fda1444f38 /games/supertux/Makefile
parent48bd24582f124aed2ba7e72113a28530737f86ba (diff)
downloadports-3d17c00e25455c971947afcffe97b26858260c22.tar.gz
ports-3d17c00e25455c971947afcffe97b26858260c22.zip
Notes
Diffstat (limited to 'games/supertux/Makefile')
-rw-r--r--games/supertux/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/supertux/Makefile b/games/supertux/Makefile
new file mode 100644
index 000000000000..e5c5c5c0930c
--- /dev/null
+++ b/games/supertux/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: supertux
+# Date created: 2004-04-17
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supertux
+PORTVERSION= 0.0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= super-tux
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+WANT_SDL= yes
+USE_SDL= image
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-debug
+OPTIONS= SOUND "SDL mixer (audio) support" on
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+=--disable-sound
+.else
+USE_SDL+= mixer
+PLIST_SUB+= SOUND=""
+.endif
+
+post-patch:
+.if defined(WITHOUT_SOUND)
+ @${RM} -f ${WRKSRC}/data/sounds/* ${WRKSRC}/data/music/*
+.endif
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' \
+ ${WRKSRC}/src/type.h
+
+.include <bsd.port.post.mk>