aboutsummaryrefslogtreecommitdiff
path: root/games/supertuxkart
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-28 12:11:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-28 12:11:40 +0000
commit78720334a32078e11be87fb9a049445d4122f450 (patch)
tree5661afa82f397636bd1fc887a85126ec43ec991d /games/supertuxkart
parent7911f2065ef3c65c1bf12712032077a3bae52719 (diff)
downloadports-78720334a32078e11be87fb9a049445d4122f450.tar.gz
ports-78720334a32078e11be87fb9a049445d4122f450.zip
- Clarify LICENSE
- Add LICENSE_FILE - Fix build with new mesa
Notes
Notes: svn path=/head/; revision=371626
Diffstat (limited to 'games/supertuxkart')
-rw-r--r--games/supertuxkart/Makefile6
-rw-r--r--games/supertuxkart/files/patch-lib__irrlicht__source__Irrlicht__COpenGLExtensionHandler.h12
2 files changed, 16 insertions, 2 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 7e12f32987be..c7e65868a46e 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -11,7 +11,8 @@ EXTRACT_SUFX= -src.tar.bz2
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free 3D kart racing game
-LICENSE= GPLv3
+LICENSE= GPLv3 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg \
@@ -21,7 +22,8 @@ USES= alias cmake dos2unix gettext gmake openal:al,alut pkgconfig \
tar:bzip2
USE_GL= gl glu glut
USE_SDL= sdl
-DOS2UNIX_FILES= lib/irrlicht/source/Irrlicht/Makefile
+DOS2UNIX_FILES= lib/irrlicht/source/Irrlicht/Makefile \
+ lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h
CMAKE_ARGS= -DUSE_WIIUSE=NO
WRKSRC= ${WRKDIR}/SuperTuxKart-${PORTVERSION}
diff --git a/games/supertuxkart/files/patch-lib__irrlicht__source__Irrlicht__COpenGLExtensionHandler.h b/games/supertuxkart/files/patch-lib__irrlicht__source__Irrlicht__COpenGLExtensionHandler.h
new file mode 100644
index 000000000000..63c9ce213910
--- /dev/null
+++ b/games/supertuxkart/files/patch-lib__irrlicht__source__Irrlicht__COpenGLExtensionHandler.h
@@ -0,0 +1,12 @@
+--- lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h.orig 2013-11-14 03:55:29.000000000 +0400
++++ lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h 2014-10-28 06:46:08.000000000 +0300
+@@ -60,6 +60,9 @@
+ #endif
+ #include <GL/gl.h>
+ #include <GL/glx.h>
++ #ifndef PFNGLBLENDEQUATIONPROC
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
++ #endif
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h