aboutsummaryrefslogtreecommitdiff
path: root/games/sxsame
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-15 16:36:51 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-15 16:36:51 +0000
commit6542dd22222027395463c554d8d945cf43cff961 (patch)
tree25f28845dc5e5c9d9a07fc292aa7889505be490d /games/sxsame
parent4686ca73f789e42025248ac0947bda79a3934df7 (diff)
downloadports-6542dd22222027395463c554d8d945cf43cff961.tar.gz
ports-6542dd22222027395463c554d8d945cf43cff961.zip
Support CFLAGS properly. Conform to one file per patch guideline. Be
extra careful with $i; remove unnecessary WRKSRC. PR: 19925 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=30658
Diffstat (limited to 'games/sxsame')
-rw-r--r--games/sxsame/Makefile6
-rw-r--r--games/sxsame/files/patch-aa13
2 files changed, 14 insertions, 5 deletions
diff --git a/games/sxsame/Makefile b/games/sxsame/Makefile
index 395ec733a19c..74d5ed9a4aa8 100644
--- a/games/sxsame/Makefile
+++ b/games/sxsame/Makefile
@@ -25,12 +25,12 @@ BINGRP= games
BINMODE= 2755
MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
-WRKSRC= ${WRKDIR}/sxsame-3.02
-
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/sxsame
.for i in INSTALL.jp README.jp
- @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/sxsame
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/sxsame
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/games/sxsame/files/patch-aa b/games/sxsame/files/patch-aa
index be66a133feb2..e052bf8c11ce 100644
--- a/games/sxsame/files/patch-aa
+++ b/games/sxsame/files/patch-aa
@@ -1,11 +1,11 @@
--- Imakefile.orig Sun May 5 04:10:27 1996
-+++ Imakefile Mon Nov 1 02:11:20 1999
++++ Imakefile Tue Jul 11 21:14:48 2000
@@ -3,7 +3,7 @@
# * Copyleft (c) 1994-1996 Software Research Academy *
# **************************************************************
#
-SAMEDIR = /usr/local/games/sxsame
-+SAMEDIR = $(PREFIX)/lib/X11/sxsame
++SAMEDIR = $(LIBDIR)/sxsame
#BINDIR = /usr/local/bin
#MANDIR = /usr/local/man/man1
@@ -17,6 +17,15 @@
XPMLIB = -lXpm
LOCAL_LIBRARIES = $(XPMLIB) -lX11
+@@ -19,7 +20,7 @@
+ DEFINES = -DSAME_DIR=\"$(SAMEDIR)\"
+
+ #CDEBUGFLAGS = -O2 -Wall
+-CDEBUGFLAGS = -g -Wall
++#CDEBUGFLAGS = -g -Wall
+ #CDEBUGFLAGS = -O2
+ ComplexProgramTarget(sxsame)
+ InstallManPage(sxsame,$(MANDIR))
@@ -29,6 +30,10 @@
#defdata.o:: defdata.c defdata.h
install.dir::